Package Details: dart-sdk-dev 2.19.0_70.0.dev-1

Git Clone URL: https://aur.archlinux.org/dart-sdk-dev.git (read-only, click to copy)
Package Base: dart-sdk-dev
Description: The official Dart sdk from dart-lang project (Development branch)
Upstream URL: https://www.dartlang.org/tools/sdk/archive
Keywords: dart dart-sdk dart-sdk-dev dart2 dartlang flutter
Licenses: custom
Conflicts: dart
Provides: dart
Submitter: KlarkKable
Maintainer: KlarkKable
Last Packager: KlarkKable
Votes: 8
Popularity: 0.008854
First Submitted: 2018-04-19 09:11 (UTC)
Last Updated: 2022-08-11 04:02 (UTC)

Dependencies (1)

Required by (16)

Sources (1)

Pinned Comments

KlarkKable commented on 2019-02-06 17:16 (UTC)

Just so all users are aware, the gtilab is ONLY used as a way to automate pulling the dart package from Google, updating pkgbuild, and pushing it to the aur. All updates for the dart package will be here.

KlarkKable commented on 2018-08-25 21:36 (UTC)

Apologies for the long delay, busy with new job. I made the suggested changes. I have weekly deployments setup here: https://gitlab.com/Kaleb-Pace/dart-sdk-dev

So it should stay up to date now.

If you find any issues feel free to email them here: incoming+Kaleb-Pace/dart-sdk-dev@incoming.gitlab.com

Latest Comments

GostLy commented on 2019-12-13 17:50 (UTC) (edited on 2019-12-13 17:56 (UTC) by GostLy)

Building dart-sdk-dev...
==> Making package: dart-sdk-dev 2.8.0_dev.0.0-1 (Fri 13 Dec 2019 12:26:45 PM EST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found dartsdk-linux-x64-release.zip
==> Validating source files with sha256sums...
    dartsdk-linux-x64-release.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!

I have to manually remove 'dartsdk-linux-x64-release.zip' before upgrading or else I get that error. Can you please do what @Huulivoide suggested and add ${pkgver} to the zip filename.

Huulivoide commented on 2019-10-16 20:27 (UTC)

I would recommend renaming the downloaded source file as it does not contain a version on it's name. Not having a version on the file name can lead to problems, if one building a new version in the same directory with a previous version. For example, when using a git clone if this package or installing with yay. Having an old version of the source archive will throw off makepkg, as it thinks the file has already been downloaded.

source=(dartsdk-linux-x64-release-${pkgver}.zip::https://…/dartsdk-linux-x64-release.zip)

should do the job.

yelkarch commented on 2019-05-25 17:15 (UTC) (edited on 2019-05-25 17:18 (UTC) by yelkarch)

Please update the checksum:


dart-sdk-dev ±|master|→ makepkg -g
==> Retrieving sources...
  -> Found dartsdk-linux-x64-release.zip
==> Generating checksums for source files...
sha256sums=('1d73ece270078dcf86ac85bcf2d4556f242f90f8be5a6bb1ddf9afe05778efac')

KlarkKable commented on 2019-02-06 17:16 (UTC)

Just so all users are aware, the gtilab is ONLY used as a way to automate pulling the dart package from Google, updating pkgbuild, and pushing it to the aur. All updates for the dart package will be here.

ijann commented on 2019-02-01 22:02 (UTC)

This channel is connected to pacman GUI, not with gitlab, you will create problems not only for me, also for others who want to install it.

ijann commented on 2019-02-01 21:53 (UTC)

if you are going to be the updates from gitlab, the others will follow you, and where will this channel "AUR" be? This channel was made for that, show the repositories, I want to update from my pacman GUI without problems, Now I have to enter gitlab and solve it, that is wrong

ijann commented on 2019-02-01 21:49 (UTC)

it's wrong what you're holding, the packages are updated from AUR, not from gitlab, if you can not do it, leave the repository to someone else, I'm not interested if it's updated in gitlab, the update should be through this channel, What part do not stay clear?

ijann commented on 2019-02-01 20:54 (UTC)

Hello KlarkKable, Sorry, but the updates are made through of this channel AUR, not by gitlab, I would beg you not to neglect the updates in AUR. regards

Pixys commented on 2018-09-02 23:11 (UTC)

@KlarkKable, Hi! Thanks, it worked!

KlarkKable commented on 2018-09-02 07:43 (UTC)

@Pixys this is probably not the most elegant solution, but a quick fix is just deleting the dart-sdk-dev directory under $USER/.cache/aurman

Pixys commented on 2018-09-02 07:21 (UTC)

Hello,

Trying to update aur/dart-sdk-dev from 2.0.0_dev.63.0-1 to 2.1.0_dev.3.0-1, I face the following error :

==> Validating source files with sha256sums...
    dartsdk-linux-x64-release.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
2018-09-02 15:14:05,228 - wrappers - makepkg - ERROR - makepkg query ['makepkg', '-cf', '--noconfirm'] failed in directory /$USER/.cache/aurman/dart-sdk-dev

Any trick to solve this?

Thanks for your help!

KlarkKable commented on 2018-08-25 21:36 (UTC)

Apologies for the long delay, busy with new job. I made the suggested changes. I have weekly deployments setup here: https://gitlab.com/Kaleb-Pace/dart-sdk-dev

So it should stay up to date now.

If you find any issues feel free to email them here: incoming+Kaleb-Pace/dart-sdk-dev@incoming.gitlab.com

Ogromny commented on 2018-08-21 01:05 (UTC)

For actual last version:

pkgver=2.1.0_dev.1.0 sha256sums=("b97f967fbdb0d677702a9e51deeb697b3086496e3e69ff7b815e213c2f9a181d")

AnLog commented on 2018-08-08 22:37 (UTC) (edited on 2018-08-08 23:17 (UTC) by AnLog)

provides=('dart') HAS to be ("dart=$pkgver") for other packages to be able to require a certain version. I was trying to make a package that required >=1.25.0 but it didn't work and I didn't know why. Apparently for that to work you have to include the pkgver in your provides variable.

There's another issue with the PKGBUILD that was brought to my attention and explained by eschwartz on the #archlinux-aur. ln -s /opt/$pkgname/bin/* $pkgdir/usr/bin/ apparently isn't correct? Check the PKGBUILD of the dart package to see the way they do it: https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/dart#n49

Alternatively, just use something like this. this:

for f in "$pkgdir"/opt/$pkgname/bin/*; do 
    ln -s /opt/$pkgname/bin/${f##*/} "$pkgdir"/usr/bin/
done

This should work, it did on my machine. A pastebin of the edited PKGBUILD I used: https://paste.debian.net/1037207

I've tried to understand why that way of making a link is wrong but I'm still a little shaky on it. As far as I understood if you don't have any pre-existing install /opt/$pkgname/bin/* is empty and won't expand to anything. This is what I think lead to me having an unknown command error when calling pub get the first time I got this package. By using the for loop that way you will enumerate over the files in the pkgdir where they actually exist and creating the links correctly.

close2 commented on 2018-06-25 09:28 (UTC)

there is an incorrect symbolic link in /usr/bin

ls /usr/bin/* -l lrwxrwxrwx 1 root root 23 Jun 22 11:18 '/usr/bin/' -> '/opt/dart-sdk-dev/bin/'

KlarkKable commented on 2018-06-17 16:02 (UTC)

@morealaz Forgive my ignorance. I appreciate the help! Should reflect the version properly from now on. I also added the provides=('dart') for you.

commented on 2018-06-16 10:07 (UTC)

@KlarkKable: please add provides=('dart') to PKGBUILD.

commented on 2018-06-16 10:04 (UTC)

@KlarkKable: you must update .SRCINFO file every time you update package, in order to reflect changes in AUR. use following command in your build directory to generate and update it:

$ makepkg --printsrcinfo > .SRCINFO

and do not forget to add it to git index:

$ git add .SRCINFO

KlarkKable commented on 2018-06-16 06:54 (UTC)

@MatthewArredondo I would change it if I could. The string replacement I am doing in the sources definition of the PKGBUILD should have updated it automatically (from what I understand). If someone would like to point out how to do so, I would be more than happy to fix it.

MatthewArredondo commented on 2018-05-17 07:00 (UTC)

Should DEF change the name so people don't get confused that the stated version number is older than what the package's version number presently is. Lol, other than that little mixup I love seeing this in the AUR <3

KlarkKable commented on 2018-04-28 06:42 (UTC)

@develhox I appreciate you pointing it out. Should be fixed now.

develhox commented on 2018-04-23 10:08 (UTC) (edited on 2018-04-23 10:09 (UTC) by develhox)

Hi. Thank you for the PKGBUILD, but it has a bug.

The symbolic links created in /usr/bin/ points to the subfolder bin/, but it should be /opt/dart-sdk-dev/bin/