Package Details: dataspell 2024.1.2-2

Git Clone URL: https://aur.archlinux.org/dataspell.git (read-only, click to copy)
Package Base: dataspell
Description: Python IDE for data scientists
Upstream URL: https://www.jetbrains.com/dataspell/
Licenses: custom:jetbrains
Submitter: freswa
Maintainer: freswa
Last Packager: freswa
Votes: 3
Popularity: 0.97
First Submitted: 2021-08-03 17:03 (UTC)
Last Updated: 2024-06-11 10:55 (UTC)

Dependencies (6)

Required by (0)

Sources (3)

Latest Comments

1 2 Next › Last »

Adrian.Carver commented on 2024-06-11 11:09 (UTC)

Thanks, everything works. P.S.: by the way, through yay installed the last 6-8 versions exactly.

freswa commented on 2024-06-11 10:55 (UTC)

No, you're totally right. Jetbrains changed the folder name in their tar archives. Sorry for the inconvenience! I just pushed a fix.t

Adrian.Carver commented on 2024-06-11 10:48 (UTC)

When I try to build a package using makepkg -fc - exactly the same thing happens. Is it possible that I'm doing something wrong?

freswa commented on 2024-06-11 10:16 (UTC)

AUR helpers are unsupported.

Adrian.Carver commented on 2024-06-11 10:06 (UTC) (edited on 2024-06-11 10:08 (UTC) by Adrian.Carver)

Running package_dataspell()...
cp: failed to execute stat for '/home/adrian/.cache/yay/dataspell/src/dataspell-2024.1.2/': No such file or directory available
==> ERROR: A failure occurred in package_dataspell().
Interrupt...
-> build error: dataspell-exit status 4
-> The following packages could not be installed - manual intervention required:
dataspell-jre - exit status 4
dataspell - exit status 4

freswa commented on 2023-01-11 10:31 (UTC)

Missed the "${pkgdir}" for the chmod. Should be fixed with -2.

Firestar commented on 2023-01-11 00:59 (UTC) (edited on 2023-01-11 08:11 (UTC) by Firestar)

when installing it via yay, it run into an error:

chmod: cannot access '/opt/dataspell/plugins/r-plugin/rwrapper*linux': No such file or directory

so I deleted that line in PKGBUILD and re-installed. This time it succeeded, but:

$ ls /opt/dataspell/plugins/r-plugin/
fsnotifier-linux          fsnotifier-osx          lib  rkernelVersion.txt    rwrapper-arm64-osx  rwrapper-x64-osx
fsnotifier-linux-aarch64  fsnotifier-windows.exe  R    rwrapper-arm64-linux  rwrapper-x64-linux  rwrapper-x64-windows.exe

<deleted-account> commented on 2022-12-13 12:58 (UTC)

The rwrappers in '/opt/dataspell/plugins/r-plugin' needs to be marked as executable for R to work in dataspell.