Package Details: dbus-nosystemd 1.12.16-1

Git Clone URL: https://aur.archlinux.org/dbus-nosystemd.git (read-only)
Package Base: dbus-nosystemd
Description: Freedesktop.org message bus system
Upstream URL: https://wiki.freedesktop.org/www/Software/dbus/
Licenses: GPL, custom
Groups: eudev-base
Conflicts: dbus, dbus-core, dbus-eudev, dbus-x11, libdbus
Provides: dbus=1.12.16, dbus-core, libdbus=1.12.16
Replaces: dbus, dbus-core, dbus-eudev, dbus-x11, libdbus
Submitter: TZ86
Maintainer: TZ86
Last Packager: TZ86
Votes: 15
Popularity: 0.000000
First Submitted: 2013-01-24 15:42
Last Updated: 2019-06-21 05:38

Required by (315)

Sources (3)

Pinned Comments

TZ86 commented on 2019-01-18 07:13

@je-vv

Sadly, the build proccess seems to be broken with latest autoconf-archive version. If you have older version in pacman cache, try to install it via pacman -U /var/cache/pacman/pkg/autoconf-archive<…>, it builds and works well even with pretty old 1:2018.03.13-1 which I'm currently using.

Latest Comments

1 2 3 4 Next › Last »

DaarkWel commented on 2019-01-21 05:44

There's issue in dbus tracker: https://gitlab.freedesktop.org/dbus/dbus/issues/249

TZ86 commented on 2019-01-19 06:32

@je-vv

Well, I've checked bugreports in http://lists.gnu.org/archive/html/bug-autoconf/ and arch bugtracker but didn't find anything similar.

je-vv commented on 2019-01-18 21:46

@TZ86, that was it. Do you know if there's a bug filed upstream for it?

TZ86 commented on 2019-01-18 07:13

@je-vv

Sadly, the build proccess seems to be broken with latest autoconf-archive version. If you have older version in pacman cache, try to install it via pacman -U /var/cache/pacman/pkg/autoconf-archive<…>, it builds and works well even with pretty old 1:2018.03.13-1 which I'm currently using.

je-vv commented on 2019-01-17 16:46

Failing build:

libtoolize: copying file 'm4/lt~obsolete.m4' configure.ac:97: installing 'build-aux/compile' configure.ac:21: installing 'build-aux/missing' bus/Makefile.am: installing 'build-aux/depcomp' configure:18959: error: Unexpanded AX_ macro found. Please install GNU autoconf-archive If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. autoconf failed - version 2.5x is probably required

could it be a make dependence missing?

Cromer commented on 2017-04-22 14:37

Just one issue, you only added the creation of the dbus user and group to post_upgrade()

You need to add it to post_install() as well because when a user installs dbus for the first time the user and group does not exist.

TZ86 commented on 2017-04-22 10:07

Fixed

Cromer commented on 2017-04-20 23:15

The "filesystem" package for arch linux has changed. By default it included a dbus user and group in /etc/group and int /etc/passwd

However they removed this last month in filesystem-2017.03-2.

This causes an issue for fresh installs that need dbus-nosystemd, it doesn't run on fresh installs because the user and group do not exist.

Please update the install file to create a dbus user and group on installation/upgrade of the package.

nous commented on 2016-09-18 12:08

We've agreed to use dbus-openrc + dbus-nosystemd. All other variants will be removed.

Alad commented on 2016-09-17 23:42

What are the plans on autolaunch support for this package? Right now it's enabled implicitly due to the makedepends on libx11, so this package and dbus-x11-nosystemd do the same. If this is intended, perhaps merge both packages?