Package Details: dbus-nosystemd 1.12.14-1

Git Clone URL: https://aur.archlinux.org/dbus-nosystemd.git (read-only)
Package Base: dbus-nosystemd
Description: Freedesktop.org message bus system
Upstream URL: https://wiki.freedesktop.org/www/Software/dbus/
Licenses: GPL, custom
Groups: eudev-base
Conflicts: dbus, dbus-core, dbus-eudev, dbus-x11, libdbus
Provides: dbus=1.12.14, dbus-core, libdbus=1.12.14
Replaces: dbus, dbus-core, dbus-eudev, dbus-x11, libdbus
Submitter: TZ86
Maintainer: TZ86
Last Packager: TZ86
Votes: 15
Popularity: 0.000000
First Submitted: 2013-01-24 15:42
Last Updated: 2019-05-24 05:51

Required by (314)

Sources (3)

Pinned Comments

TZ86 commented on 2019-01-18 07:13

@je-vv

Sadly, the build proccess seems to be broken with latest autoconf-archive version. If you have older version in pacman cache, try to install it via pacman -U /var/cache/pacman/pkg/autoconf-archive<…>, it builds and works well even with pretty old 1:2018.03.13-1 which I'm currently using.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Mektub commented on 2014-05-15 17:01

OrdinaryMagician,

thanks, ok now.

OrdinaryMagician commented on 2014-05-15 16:54

Simply remove dbus-nosystemd with -Rdd, update dbus, then reinstall dbus-nosystemd.

The PKGBUILD for this version isn't wrong, more like the other way around. It's just a small issue related to the previous package version using '=' instead of '>=' for the dependency check.

Mektub commented on 2014-05-15 15:19

I see dbus-nosystemd 1.8.2-1 is available, but if I try to update:

core is up to date
extra is up to date
community is up to date
multilib is up to date
archlinuxfr is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: dbus-nosystemd: requires libdbus=1.8.0

I think there is something wrong with the line:

depends=('expat' 'coreutils' 'filesystem' 'shadow' "libdbus>=${pkgver}")

Mektub



TZ86 commented on 2014-04-15 17:08

@Mr Green
Please show output of 'pacman -Q dbus-nosystemd'.

Mr Green commented on 2014-04-15 08:48

Having issues with dbus-daemon

:: Starting D-BUS system messagebus [BUSY] dbus-daemon: error while loading shared libraries: libsystemd-login.so.0: cannot open shared object file: No such file or directory
Tue Apr 15 08:40:23 2014: [FAIL]

Even though systemd is not built in, any ideas on the problem?

artoo commented on 2014-03-27 10:45

Yeah, sorry for more update stuff, and thanks.
But these packages have the potential to break the system, if they don't get removed/updated properly.

TZ86 commented on 2014-03-27 04:56

@artoo
Ugh, more updates… Okay, I'll add your packages to replaces/conflicts.

>Do you want to have the colord-eudev build?

No, I don't use it, and actually 23 packages is more than enough for me. :)

artoo commented on 2014-03-26 18:03

Two things,
if I let AUR people delete my packages, I'd would be probably good to implement a safe upgrade with replaces & conflicts. I don't know how many people use my builds.

Do you want to have the colord-eudev build?
I maintain all builds in a git repo anyway, so should I delete colord-eudev from AUR, or do you want it transferred to rename it?

artoo commented on 2014-03-26 16:30

TZ86

That's very nice.

If you maintain these nosystemd packages anyway, I will ask for deletion of my *-eudev ones, and will only keep eudev-$version.

It gives some time for other stuff I wanted to do.

Thank you. :)

TZ86 commented on 2014-03-25 09:55

@artoo
Now everything should be fine. I've also added "eudev-base" group and additional deps to my *-nosystemd packages. Tell me if I missed something.

>Another tiny thing, your kde-workspace-ck build needs libpulse to build properly.

I've already added warning to pkgbuild (see build()) but probably I should try to make it easer for a user.