Package Details: dbus-x11-git 1.15.8+17+gd9756df2-1

Git Clone URL: https://aur.archlinux.org/dbus-x11-git.git (read-only, click to copy)
Package Base: dbus-x11-git
Description: Freedesktop.org message bus system (with x11 autolaunch) (git version)
Upstream URL: https://wiki.freedesktop.org/www/Software/dbus/
Licenses: GPL, custom
Conflicts: dbus, libdbus
Provides: dbus, libdbus, libdbus-1.so
Replaces: libdbus
Submitter: phyxmeow
Maintainer: phyxmeow
Last Packager: phyxmeow
Votes: 1
Popularity: 0.144620
First Submitted: 2023-12-29 19:38 (UTC)
Last Updated: 2023-12-29 19:45 (UTC)

Required by (812)

Sources (3)

Latest Comments

phyxmeow commented on 2024-01-12 06:34 (UTC) (edited on 2024-01-12 06:35 (UTC) by phyxmeow)

I found that I no longer need this package after a recent update of dbus package, maybe I should remove this.

dkchi commented on 2024-01-11 23:23 (UTC)

archlinux doesn't like "dbus-x11". The reason they hate it is at https://wiki.archlinux.org/title/Running_GUI_applications_as_root. So they modified "systemd" to make "dbus-x11" unusable. Many major Linux distributors normally release "dbus-x11", but in the case of archlinux...

nikdog commented on 2024-01-11 00:45 (UTC)

Both this package and the now missing/defunct dbus-x11 conflict with the new default D-Bus daemon dbus-broker-units package.

error: failed to commit transaction (conflicting files) dbus-broker-units: /usr/lib/systemd/system/dbus.service exists in filesystem (owned by dbus-x11-git) dbus-broker-units: /usr/lib/systemd/user/dbus.service exists in filesystem (owned by dbus-x11-git) Errors occurred, no packages were upgraded.

(I'm not even sure I need this version of D-Bus any more)