Package Details: dcpomatic-git 0.r9393.3057189c6-1

Git Clone URL: https://aur.archlinux.org/dcpomatic-git.git (read-only)
Package Base: dcpomatic-git
Description: A free, open-source program to generate Digital Cinema Packages (DCPs) from videos or images
Upstream URL: http://dcpomatic.com/
Keywords: Cinema DCP
Licenses: GPL2
Conflicts: dcpomatic
Provides: dcpomatic
Submitter: markusk
Maintainer: markusk
Last Packager: markusk
Votes: 1
Popularity: 0.000000
First Submitted: 2014-10-16 10:10
Last Updated: 2018-03-26 12:55

Pinned Comments

markusk commented on 2018-03-26 12:59

dcpomatic-git and it's depend "lib" packages where switched back to "bleeding edge" master branch! Use at own risk!

For production use better switch back to stable package at https://aur.archlinux.org/packages/dcpomatic/

Remember to deinstall all the "dcpomatic libs" when you switch from git to none git versions of my packages.

Latest Comments

markusk commented on 2018-03-26 12:59

dcpomatic-git and it's depend "lib" packages where switched back to "bleeding edge" master branch! Use at own risk!

For production use better switch back to stable package at https://aur.archlinux.org/packages/dcpomatic/

Remember to deinstall all the "dcpomatic libs" when you switch from git to none git versions of my packages.

markusk commented on 2018-03-19 00:16

Compile problems where fixed for the v2.12.x dev pre release. The pkgs builds again! But remember you have reinstall all of the "dcp lib pkgs" too!

markusk commented on 2018-03-17 01:58

@anhtuann: are you sure you the problem happens during dcpomatic-git and not during the install of libdbcp or libsub or any other dep's?

markusk commented on 2018-03-17 01:57

upstream developer is in final RC change mode for version 2.12.0. The current git version 2.11.77 seems to have a compile problem with the boost library on Arch. I have informed the upstream dev via email.

Anonymous comment on 2018-03-16 16:55

I couldn't compile the package. Apparently, reel_writer.cc is the culprit. Anyone having the same problem ?

TilmanV commented on 2018-02-27 09:22

Confirmed. Package compiles without errors. But you have to recompile every related package.

markusk commented on 2018-02-27 04:34

upstream problems where fixed ! the dcpomatic-git packages are building the current beta test branch for v2.12.x !

markusk commented on 2018-02-23 22:20

At the moment upstream dev is gearing up to release stable 2.12.0. At the moment both v2.12.x (git branch for future 2.12.0) and git master branch are throwing compile bugs on my arch system. I submitted some bug reports and upstream seem to be working on these when he has time.

On the other hand 2.10.5 does not work with current Arch packages ...

To tell you the truth as a packaging only guy that has nothing to do with upstream development besides some very minor bug reporting i simply don't know what else besides waiting and bug reporting i can do.

At current these package uses git branch v2.12.x which is the branch for the upcoming 2.12.0 version. At the moment there is no master branch arch pkg.

TilmanV commented on 2018-02-23 19:47

Package still can't be built..

markusk commented on 2017-12-18 01:27

@TilmanV: upstream fixed the bug #1150 for imagemagick that is used in Arch. Second option would be to switch to graphicsmagick as dep. I was able to compile dcpomatic-git pkg after upstream fixed it.

All comments