Package Details: dduper-git 0.01.r48.g496897d-1

Git Clone URL: https://aur.archlinux.org/dduper-git.git (read-only, click to copy)
Package Base: dduper-git
Description: Block-level out-of-band BTRFS dedupe tool
Upstream URL: https://github.com/Lakshmipathi/dduper
Licenses: GPL2
Submitter: nightuser
Maintainer: nightuser
Last Packager: nightuser
Votes: 1
Popularity: 0.38
First Submitted: 2020-09-10 12:13 (UTC)
Last Updated: 2020-12-01 14:49 (UTC)

Latest Comments

qubidt commented on 2022-02-24 07:36 (UTC)

FYI, python-ptable is no longer available (and hasn't had a release since 2015) but python-prettytable (the original, upstream project) is API comptaible and is in the community repo. It's several versions late but should still be useful

nightuser commented on 2020-12-01 14:53 (UTC)

@mbloms: Missed you comment, sorry. I'll fix it soon.

nightuser commented on 2020-12-01 14:53 (UTC)

@trougnouf: fixed

trougnouf commented on 2020-11-22 11:15 (UTC) (edited on 2020-11-22 11:15 (UTC) by trougnouf)

Fails as follow:

[...]
==> Starting prepare()...
patching file dduper
patching file Makefile
Hunk #1 FAILED at 158.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.rej
patching file cmds/commands.h
patching file cmds/inspect-dump-csum.c
patching file cmds/inspect.c
Hunk #1 succeeded at 667 (offset -3 lines).
==> ERROR: A failure occurred in prepare().
    Aborting...
:: failed to verify integrity or prepare dduper-git package

mbloms commented on 2020-10-16 10:37 (UTC) (edited on 2020-10-16 10:50 (UTC) by mbloms)

Hi, you should probably add the "--tags" flag in the pkgver function. Without it, the version won't be updated with the regular tags upstream uses.

Also: You need to include provides and conflicts dduper so this doesn't conflict with dduper-bin.