Package Details: debhelper-python 3.7.3-2

Git Clone URL: https://aur.archlinux.org/debhelper-python.git (read-only)
Package Base: debhelper-python
Description: debhelper scripts for Python 3: py3versions, python3.pm
Upstream URL: http://packages.debian.org/sid/python3
Licenses: custom:MIT
Provides: debhelper-python, dh-python
Submitter: JonnyJD
Maintainer: z3ntu
Last Packager: z3ntu
Votes: 2
Popularity: 0.000000
First Submitted: 2013-01-27 12:47
Last Updated: 2019-07-03 15:31

Latest Comments

z3ntu commented on 2019-07-03 15:36

Should be fixed, sorry.

damentz commented on 2019-07-03 14:13

When trying to make the latest version, I get this:

==> Retrieving sources...
  -> Downloading python3-defaults_3.7.3-1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   347  100   347    0     0    192      0  0:00:01  0:00:01 --:--:--   192
100  134k  100  134k    0     0  40903      0  0:00:03  0:00:03 --:--:-- 94652
  -> Downloading dh-python_3.20180927.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   336  100   336    0     0    203      0  0:00:01  0:00:01 --:--:--   203
  0     0    0     0    0     0      0      0 --:--:--  0:00:02 --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://deb.debian.org/debian/pool/main/d/dh-python/dh-python_3.20180927.tar.xz
    Aborting...

lennonwoo commented on 2019-07-02 01:11

Hello, the archive in Debian has updated to python3.7.3 currently, and the old python3.7.2 archive doesn't exist now.

os369510 commented on 2018-07-20 02:06

Hi, The py3 of version 3.6.4-1 already not exist in http://ftp.debian.org/debian/pool/main/p/python3-defaults/python3-defaults_3.6.4-1.tar.gz

z3ntu commented on 2017-10-24 10:01

I've patched py3versions to accept the normal python paths from Arch Linux.
$ py3versions -d
python3.5

Also the package was updated to 3.6.3

jo-shva commented on 2017-07-13 21:38

Here is a Pastebin with an updated PKGBUILD that works. I discovered many of the packages dependecies are pulled in by the 'debhelper' pkg such as Debian perl bindings.

pastebin: https://pastebin.com/361d9Uqx

This was the only other Debian package outdated for the building of the 'onioncircuits' for tor.
--killhellokitty

railla commented on 2016-10-13 11:09

had to make to following changes in order to build the package:

7c7
< _pkgrel=4
---
> _pkgrel=3
9c9
< _pkgver2=2.20160818
---
> _pkgver2=2.20151103
23,24c23,24
< sha256sums=('798cfc0d8c8257aec269975f8f42203e48f202cc3a32416f4e5538f2ae44b3a9'
< '9491b21ee97f1b57bcd84ee40c557ab38f3fed50641cb7d25545632cad5b09c7')
---
> sha256sums=('8d1284430b77775d4cea62a33b0685e0523b8dfa2ebcc092d382af5cb5b4f237'
> '4b7792423f7e22c1b4ccfafda162c4815de1cf3917465a23f85721496595f944')
35,36c35,36
< cd "$srcdir/$_pkgname2-$_pkgver2"
< #cd "$srcdir/$_pkgname2"
---
> #cd "$srcdir/$_pkgname2-$_pkgver2"
> cd "$srcdir/$_pkgname2"

bigbrozer commented on 2015-09-19 21:57

Hi,
Seems that the correct source for dh-python is now: http://ftp.debian.org/debian/pool/main/d/dh-python/dh-python_2.20150826.tar.xz
SHA256 is: 1d9c946622c21501689118c573b98ff06a5ea7bd23c5c58d3dc193490ad0b457

Allowed me to build the package after these changes.