Package Details: debhelper-python2 2.7.11-1

Git Clone URL: https://aur.archlinux.org/debhelper-python2.git (read-only)
Package Base: debhelper-python2
Description: debhelper scripts for Python 2: pyversions, python2.pm
Upstream URL: http://packages.debian.org/sid/python
Licenses: custom:MIT
Submitter: JonnyJD
Maintainer: JonnyJD
Last Packager: JonnyJD
Votes: 2
Popularity: 0.000380
First Submitted: 2013-01-27 12:47
Last Updated: 2016-05-08 19:52

Latest Comments

railla commented on 2016-10-13 11:16

new version ffce6f85030c79eb85fe68b750389535 python-defaults_2.7.11-2.tar.gz

JonnyJD commented on 2014-01-11 18:07

Well, yes and no. I did uninstall debhelper-python* distro-info dh-make and still couldn't reproduce the problem. (pyversions also isn't called in the packaging)

However, updating my debhelper "did the trick". I can now reproduce the problem.
It looks like the new debhelper tries to call pyversions in more cases, triggering the call also when installing this package..

I solved it with skipping part of the build. (no side effects known)

Let me know if there are still problems.

nbryskin commented on 2014-01-11 09:50

Fails to build package with package itself uninstalled

nbryskin commented on 2014-01-11 09:48

I confirm alex-eri error report

JonnyJD commented on 2013-09-27 09:33

@alex-eri:
I couldn't reproduce your error. Maybe this is not an error with this package, but the error you got in another package, missing this package?

Anyways, I updated this package to the new version.

alex-eri commented on 2013-09-27 04:45

not builds with:
dh_auto_clean: failed to run pyversions

alex-eri commented on 2013-09-27 04:43

new version 2.7.5-5
066c3b10e9f1ede9187eea6fd1f851d5 python-defaults_2.7.5-5.tar.gz