Package Details: debhelper 9.20160403-1

Git Clone URL: (read-only)
Package Base: debhelper
Description: A collection of programs that can be used in a debian/rules file to automate common tasks
Upstream URL:
Licenses: GPL2, GPL3
Submitter: Garoth
Maintainer: None
Last Packager: alub
Votes: 35
Popularity: 0.268535
First Submitted: 2009-05-19 17:42
Last Updated: 2016-04-16 10:12

Latest Comments

Alad commented on 2016-09-04 18:52

Misses git makedepend.

uppfinnarn commented on 2014-01-19 12:06

Currently doesn't build without manually adding /usr/bin/vendor_perl/ to $PATH; it fails with a 'po4a: command not found'.

BlueMatt commented on 2013-12-09 20:36

Any chance the dh_bash-completion stuff could be pulled in from Debian's bash-completion package?

LordAro commented on 2013-09-16 19:07

fyi, to you patch makers, it has (finally!) been fixed in upstream:;a=commit;h=42db16e0390b4eb86669db622ef951fa46956b78

Anonymous comment on 2013-06-22 04:06

lava//I made a patch
refer this

I dont know integrity check pass, so I made pkg without integrity check

# makepkg -s --skipinteg

lava commented on 2013-06-20 08:16

Hi all. Could anyone help me find a way to fix this issue while build (see

JonnyJD commented on 2013-01-27 14:41

This needs in build() (after make):

sed -i -e 's|, "--install-layout=deb"||' Debian/Debhelper/Buildsystem/

Debian patched python distutils for "install-layout=deb".
However, Arch doesn't include this patch so, we skip that parameter.

The patch (for python2) is at

(I am using debhelper in from

Megachip commented on 2012-11-07 20:42

@alub, it is

alub commented on 2012-09-03 14:52

@Megachip: according to, /usr/bin/vendor_perl should be set in your $PATH by /etc/profile.d/

Megachip commented on 2012-09-03 14:24

make: po4a: Kommando nicht gefunden

==> debhelper dependencies:
- binutils (already installed)
- dpkg>=1.14.15 (already installed)
- file>=3.23 (already installed)
- html2text (already installed)
- man-db>=2.5.1 (already installed)
- perl>=5.6.0 (already installed)
- po-debconf (already installed)
- po4a>=0.24 (already installed)
- man-db>=2.5.1 (already installed)
- file>=3.23 (already installed)

:( missing /usr/bin/vendor_perl in path

Anonymous comment on 2012-04-04 18:00

Here's an updated PKGBUILD that works for me:

spatz commented on 2011-11-20 10:14

Lots of newer versions exist, latest is 8.9.11 released on Nov 17, 2011.

slopjong commented on 2011-09-23 08:03

On my system it was /usr/bin/vendor_perl/ I had to add to the PATH for the build to succeed.

manni commented on 2010-11-03 11:27

The build needs an additional dependency: perl-timedate
And I had to add the path po4a to the PATH for the build to succeed.
PATH=/usr/lib/perl5/site_perl/bin:$PATH makepkg -s

This way it worked fine.

Garoth commented on 2010-09-13 20:44

ATTENTION: So I've updated the package to 8.0.0. However, it won't build until the po4a maintainer accepts my fixes to his package. Sorry, that's all I can do.