Package Details: dee 1.2.7-9

Git Clone URL: https://aur.archlinux.org/dee.git (read-only)
Package Base: dee
Description: Model to synchronize multiple instances over DBus.
Upstream URL: https://launchpad.net/dee
Licenses: LGPL
Submitter: xyproto
Maintainer: z3ntu
Last Packager: z3ntu
Votes: 133
Popularity: 3.881084
First Submitted: 2013-10-07 20:43
Last Updated: 2016-11-17 22:26

Latest Comments

DDoSolitary commented on 2017-10-22 02:35

@z3ntu I just found out the reason. The LANG environment variable should be set to "en_US.UTF-8"(maybe some other UTF-8 suffixed locales will work, too) before building. In a fresh install of Arch Linux, locale defaults to "C", which doesn't support UTF-8.

z3ntu commented on 2017-10-21 18:10

@DDoSolitary: If you tell me how to reproduce this issue I will gladly fix it :) Because I tried both extra-x86_64-build and extra-i686-build (which builds the package in a clean chroot) and it worked with both without problems. Or at least please give me the full log.

DDoSolitary commented on 2017-10-21 16:39

I got the same error as @kronarq when trying to build it in a clean chroot environment on Travis CI.

kronarq commented on 2017-09-04 06:22

In case anyone else has similar issues. The issue was during make install. Something about the docs were causing the problem. As a workaround, disabling the docs fixes the issue and allows you to proceed with the install.

z3ntu commented on 2017-09-03 11:13

@kronarq: I just tried rebuilding it locally and it worked fine. Also building it with the tool extra-x86_64-build it worked fine.

kronarq commented on 2017-09-03 04:40

Building dee in a fresh install fails with the following error:

File "/usr/lib/python3.6/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 3734: ordinal not in range(128)

First run was with yaourt tried again and got the same result with running makepkg separately.

z3ntu commented on 2017-06-13 20:34

@kreon: pkg-config is in the base-devel group which is expected to be installed on any system using the AUR.

> Note: Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as dependencies explicitly.

kreon commented on 2017-06-13 16:03

Please add pkg-config as makedep

z3ntu commented on 2017-03-11 20:34

@mirh: If you are an active user of dee, I can give you co-maintainer permissions on this package so you can do it when you notice a breakage.

mirh commented on 2017-03-11 17:34

Can you "bind" a package to dependency versions?
Because for example, after you update from icu-57 to icu-58, linking anything against this fails, if you don't recompile.

I got mixed ideas on what could be possible to do.
https://bbs.archlinux.org/viewtopic.php?id=200125#p1547094
https://bbs.archlinux.org/viewtopic.php?id=217041#p1653835

All comments