Package Details: deepin-wine6-stable-i386 6.0.0.18-1

Git Clone URL: https://aur.archlinux.org/deepin-wine6-stable.git (read-only, click to copy)
Package Base: deepin-wine6-stable
Description: Deepin wine6 stable
Upstream URL: http://www.deepin.org
Licenses: proprietary
Submitter: huyz
Maintainer: huyz
Last Packager: huyz
Votes: 3
Popularity: 1.57
First Submitted: 2021-04-15 03:35
Last Updated: 2021-11-13 06:06

Required by (1)

Sources (3)

Pinned Comments

huyz commented on 2021-08-24 16:14

可喜可贺,deepin 那边终于开始单独分发 deepin-wine{5,6}-stable 的包了。这也就意味着这个包不用再从 deepin-wine-apps 里面拆了,可以直接用 deepin 分发的 deb 包来打包。

但坏消息是,deepin 分发的 deb 包里的可执行文件路径和之前拆包时设置的路径不一致,这意味着 aur 上现有的依赖 deepin-wine{5,6}-stable 的 deepin-wine-apps 都无法启动,需要手动调整启动脚本。具体方法是把 /opt/apps/<package>/files/run.sh 里的 /usr/lib/deeping-wine{5,6}-stable/bin/wine 改成 /usr/bin/deeping-wine{5,6}-stable

Latest Comments

gardotd426 commented on 2021-12-02 00:12

Why is this listed as having a proprietary license? That's not possible. It's Wine, Wine is LGPL, Deepin is GPL3. This isn't proprietary. If anything put "Mixed" for the license, as one is LGPL and one is GPLv3.

Also, this package is a mess. It includes /usr/bin/deepin-wine6-stable, a shell script that calls dpkg. dpkg is a distro for debian-based package managers, that script should never be getting installed. The packaging for this needs to be completely changed.

I mean I'm not sure why this needs to exist in the AUR at all, since Arch already provides wine packages, but either way it needs a lot of work.

JoveYu commented on 2021-11-22 06:07

关于最近lib32-libldap冲突的问题 建议打包者 可以尝试内置这几个动态库 然后在/usr/bin/deepin-wine6-stable文件头部添加export LD_LIBRARY_PATH=[lib文件所在目录]

这样不会与系统相关库冲突

fish47 commented on 2021-11-21 17:14

libldap == 2.4.59-1

lib32-libldap == 2.4.59-2

=============

if any wine6 bottles can not be started, a simple fix is pining these packages.

RylandL commented on 2021-10-27 03:57

这个版本似乎无法访问剪切板里的图片 gnome40

Marsx commented on 2021-09-29 02:10

哈喽,/opt/apps/<package>/files/run.sh文件中无/usr/lib/deeping-wine{5,6}-stable/bin/wine这行内容,请再确认一下?

huyz commented on 2021-08-24 16:14

可喜可贺,deepin 那边终于开始单独分发 deepin-wine{5,6}-stable 的包了。这也就意味着这个包不用再从 deepin-wine-apps 里面拆了,可以直接用 deepin 分发的 deb 包来打包。

但坏消息是,deepin 分发的 deb 包里的可执行文件路径和之前拆包时设置的路径不一致,这意味着 aur 上现有的依赖 deepin-wine{5,6}-stable 的 deepin-wine-apps 都无法启动,需要手动调整启动脚本。具体方法是把 /opt/apps/<package>/files/run.sh 里的 /usr/lib/deeping-wine{5,6}-stable/bin/wine 改成 /usr/bin/deeping-wine{5,6}-stable