Package Details: deluge-git 2.0.0.dev983.g0353b82c0-1

Git Clone URL: https://aur.archlinux.org/deluge-git.git (read-only)
Package Base: deluge-git
Description: A bittorrent client written with python and pygtk (git version, 'develop' branch)
Upstream URL: http://deluge-torrent.org/
Keywords: deluge torrent
Licenses: GPL3
Conflicts: deluge, deluge-stable-git
Provides: deluge
Submitter: Berseker
Maintainer: dbermond
Last Packager: dbermond
Votes: 89
Popularity: 0.948048
First Submitted: 2010-03-19 14:12
Last Updated: 2017-05-13 15:40

Required by (13)

Sources (3)

Latest Comments

dbermond commented on 2017-05-13 15:41

libtorrent-rasterbar 1.1.2 is not required anymore.
libtorrent-rasterbar 1.1.3 is now on binary repositories and and deluge-git seems to be working fine with it.

dbermond commented on 2017-04-09 18:38

deluge-git currently has an upstream requirement of a specific libtorrent-rasterbar version, which is 1.1.2. It will not work with libtorrent-rasterbar 1.1.1 or the current libtorrent-rasterbar git master.
But the libtorrent-rasterbar version offered in the binary repositories is currently outdated, being at 1.1.1.

Being such, you have 3 options if you want to build and use deluge-git:

1) use libtorrent-rasterbar-git 1.1.2.r0.ga42d4390c, which is the default PKGBUILD method. This is the same as libtorrent-rasterbar 1.1.2, but using the git repository.
For this you will need to manually modify libtorrent-rasterbar-git PKGBUILD in order to obtain this specific version: append '#commit=a42d4390c' at the source line (currently there is a ready to use source line for achieving this in libtorrent-rasterbar-git PKGBUILD).
2) use libtorrent-rasterbar 1.1.2. For this you will need to use the PKGBDUILD from the binary repository and modify it to get version 1.1.2.
3) wait for the release of libtorrent-rasterbar 1.1.2 in binary repositories.

dbermond commented on 2017-04-09 18:37

I've adopted this package and putted it to work again.
Please see the important note about libtorrent-rasterbar dependency in the pinned post.
Have a happy deluging! :)

borrelnoot commented on 2017-02-14 22:38

==> Starting build()...
running build
running build_webui
Import error: Requires "slimit" package for minifying WebUI files.

The slimit PKGBUILD needs to be updated aswell.

skydrome commented on 2016-06-30 22:37

added it to makedeps, thanks
hmm, i thought it would minify them itself, ill look into it, never used the webui myself which is why i never came across that

NStal commented on 2016-06-30 06:13

We should run `python2 minify_web_js.py ` before install or the webUI will show blank page.

And to make webUI work corrently, we should also downgrade libtorrent to <=1.0.9 :(

Tomaash commented on 2016-06-26 13:24

Hi, you maybe should add “python2-jsmin” to makedepends. It didn't build without it.

Haron_Prime commented on 2015-09-15 11:28

After update from 2.0.0.dev451-1 don't work WebUI

dizzi90 commented on 2014-09-30 09:35

@dualcorex2 I had the same problem
sudo chown -R deluge:deluge /srv/deluge
seemed to fix it. For some reason deluge user could not access the .log file.

dualcorex2 commented on 2014-07-11 01:49

When I attempt to start the deluged service with provided deluged.service I get:

No handlers could be found for logger "deluge.common"

Also, when I run "sudo -u deluge deluged", but I can run deluged as another user.

Any ideas?

Thanks.

All comments