Package Details: deluge-git 2.0.0.dev726-1

Git Clone URL: https://aur.archlinux.org/deluge-git.git (read-only)
Package Base: deluge-git
Description: A bittorrent client written with python and pygtk - Git Version
Upstream URL: http://deluge-torrent.org
Keywords: deluge torrent
Licenses: GPL3
Conflicts: deluge, deluge-stable-git
Provides: deluge
Submitter: Berseker
Maintainer: skydrome
Last Packager: skydrome
Votes: 80
Popularity: 1.798027
First Submitted: 2010-03-19 14:12
Last Updated: 2016-06-30 01:10

Dependencies (22)

Required by (14)

Sources (3)

Latest Comments

skydrome commented on 2016-06-30 22:37

added it to makedeps, thanks
hmm, i thought it would minify them itself, ill look into it, never used the webui myself which is why i never came across that

NStal commented on 2016-06-30 06:13

We should run `python2 minify_web_js.py ` before install or the webUI will show blank page.

And to make webUI work corrently, we should also downgrade libtorrent to <=1.0.9 :(

Tomaash commented on 2016-06-26 13:24

Hi, you maybe should add “python2-jsmin” to makedepends. It didn't build without it.

Haron_Prime commented on 2015-09-15 11:28

After update from 2.0.0.dev451-1 don't work WebUI

dizzi90 commented on 2014-09-30 09:35

@dualcorex2 I had the same problem
sudo chown -R deluge:deluge /srv/deluge
seemed to fix it. For some reason deluge user could not access the .log file.

dualcorex2 commented on 2014-07-11 01:49

When I attempt to start the deluged service with provided deluged.service I get:

No handlers could be found for logger "deluge.common"

Also, when I run "sudo -u deluge deluged", but I can run deluged as another user.

Any ideas?

Thanks.

Anonymous comment on 2013-05-31 08:17

deluged.service needs fixing:
* It's type is set to 'forking', but the daemon is launched with -d flag (do not daemonize = do not fork).
* No PIDFile set.

So the [Service] section of deluged.service should contain:
ExecStart=/usr/bin/deluged --pidfile=/run/deluged.pid
PIDFile=/run/deluged.pid

Otherwise systemd starts the forking service, waits for it to daemonize and timeouts in ~90 seconds by killing it.
Reference: http://www.freedesktop.org/software/systemd/man/systemd.service.html

skydrome commented on 2013-05-28 15:22

done, thanks

minus commented on 2013-05-21 17:17

The "master" branch currently doesn't contain a fully working version, you might want to use #branch=develop

KaiSforza commented on 2013-04-10 04:42

Note: The pkgver function that is on the wiki is going to say that this is 0.5.4.6000.g123abc, not 1.3.6.10.g123abc (or something) because of how deluge used to do merges and cherry picks. They say they'll be fixing it for 1.4, though, so yeah.

KaiSforza commented on 2013-04-10 03:10

@Berseker: Pacman 4.1 is out, so you can use that PKGBUILD I sent you with the pkgver() function.

Also, I moved libtorrent-rasterbar to a makedepend+optdepend, because it is not required to run deluge in thin-client mode. deluge can build its own libtorrent, but why do that when we have it precompiled. (It'll actually post a warning saying that you can only run in thin-client mode at startup.)

KaiSforza commented on 2013-03-31 05:05

The pyxdg dependency should be python2-xdg (it replaces pyxdg)

Berseker commented on 2013-03-14 19:48

updated according to latest suggestions - thank you KaiSforza & Svenstaro

Svenstaro commented on 2013-01-06 14:48

/srv/deluge should be 775.

Anonymous comment on 2012-10-20 21:55

I can't get the daemon to start in deluge-web :/
If I start it before it doesnt't change anything, I get this:


Traceback (most recent call last):
File "/usr/lib/python2.7/logging/__init__.py", line 846, in emit
msg = self.format(record)
File "/usr/lib/python2.7/logging/__init__.py", line 723, in format
return fmt.format(record)
File "/usr/lib/python2.7/logging/__init__.py", line 464, in format
record.message = record.getMessage()
File "/usr/lib/python2.7/logging/__init__.py", line 324, in getMessage
msg = str(self.msg)
File "/usr/lib/python2.7/site-packages/deluge/error.py", line 47, in __str__
return self.message
File "/usr/lib/python2.7/site-packages/deluge/error.py", line 40, in _get_message
return self._message
AttributeError: 'DaemonRunningError' object has no attribute '_message'
Logged from file main.py, line 263
23:54:32.065 [ERROR ][deluge.main :264 ] You cannot run multiple daemons with the same config directory set.
23:54:32.066 [ERROR ][deluge.main :265 ] If you believe this is an error, you can force a start by deleting /home/guigui/.config/deluge/deluged.pid.

Berseker commented on 2012-10-20 08:04

updated according to your suggestions. Please report any issues

foolosophy commented on 2012-10-19 21:36

The "storage move" bug was already fixed upstream. ishanarora's patch is superfluous
http://dev.deluge-torrent.org/ticket/2140

CtHx commented on 2012-10-13 21:57

Master branch seems not work correctly, I can't connect to the server from the web interface.
Changing to 1.3-stable branch solved my problem.

In initscripts deluge is locked to "deluge" user, maybe it's better to put $DELUGE_USER and put
"deluge" in /etc/conf.d/deluged (DELUGE_USER="deluge")

Berseker commented on 2012-10-13 05:44

updated with latest changes of extra's\PKGBUILD (systemd stuff) and applied patch by ishanarora - please test the PKGBUILD and report any issues ! thanks

ishanarora commented on 2012-10-04 02:46

Move on completion is broken in deluge and deluge-git. The following patch solves it: https://bugs.archlinux.org/task/29414?getfile=9215

CtHx commented on 2012-09-27 15:40

Does the lates version work? I see in the web-interface the server offline...

jackoneill commented on 2012-09-06 05:40

It's python2-mako. It's even listen in the optdepends.

Anonymous comment on 2012-09-05 15:43

I just installed it using makepkg, but I get this:
[root@host ~]# /etc/rc.d/deluge
deluge-web deluged
[root@host ~]# /etc/rc.d/deluge-web start
:: Starting Deluge WebUI [BUSY] /usr/lib/python2.7/site-packages/deluge/ui/web/common.py:83: RuntimeWarning: The Mako library is required to run deluge.ui.web
RuntimeWarning)
[DONE]
and python-mako (0.7.2-1) was installed.
Then when I browse to the site, it returns this error: web.Server Traceback (most recent call last):
exceptions.RuntimeError: The Mako library is required to run deluge.ui.web

Berseker commented on 2012-07-14 17:20

just tried the PKGBUILD, no problems with it (try manual makepkg)

Anonymous comment on 2012-07-13 00:29

install: cannot stat ‘build/lib/deluge/ui/data/pixmaps/deluge.svg’: No such file or directory
I try to install it today, I have the error message above.

Berseker commented on 2012-06-21 05:18

updated at today

Berseker commented on 2012-03-12 06:30

updated the optional depenency

Anonymous comment on 2012-03-11 19:07

@Berseker: Please update dependency python-mako to python2-mako (for web ui to work properly).

Berseker commented on 2011-06-13 18:04

updated. Thank you

Xemertix commented on 2011-06-13 08:25

install: cannot stat `deluge/data/pixmaps/deluge.svg': No such file or directory

I modified the pkgbuild:
install -D -m644 build/lib/deluge/ui/data/pixmaps/deluge.svg "${pkgdir}"/usr/share/pixmaps/deluge.svg

Berseker commented on 2011-03-03 20:00

changed setuptools dependency to python2-distribute

Berseker commented on 2011-01-26 17:21

updated, changed pyopenssl dep to python2-pyopenssl. thanks xemertix

Xemertix commented on 2011-01-26 08:17

new dep python2-pyopenssl

Xemertix commented on 2011-01-12 13:31

If someone needs ip-spoofing http://goodies.lemonsoftware.eu/others/trick_client_identity_deluge
Maybe it's possible to make a patch.

Berseker commented on 2010-12-06 19:03

updated. Thanks for your cooperation

Anonymous comment on 2010-12-06 09:05

Please update dependence python-chardet to python2-chardet.

Berseker commented on 2010-10-27 14:29

Thank you for the compliments. Yeah the svn id line is not necessary I think! I'm going to remove it.
Also I modified the mantainer section, even if I think it was clear that this AUR version is mantained by me, since I'me the one that uploaded the PKGBUILDon AUR.. ^^

Svenstaro commented on 2010-10-27 14:02

Also, I deleted deluge-svn as it was deprecated and didn't really serve any purpose.

Svenstaro commented on 2010-10-27 14:01

Good work Berseker. However, you should remove the svn Id line as you are not submitting this to svn. Also, make Ionut Contributor and yourself Maintainer.

Berseker commented on 2010-10-19 18:21

updated. Changed PKGBUILD by adapting official deluge PKGBUILD to the -git version. Added deluged scripts, Python2 change fixed. Enjoy

Berseker commented on 2010-08-16 11:14

updated with suggestions from wonder. Thanks

wonder commented on 2010-08-09 14:42

@Berseker patch is in base-devel group and this is a must when starting to build packages. we assume that every one has it and it doesn't need to be there

you still have useless dependencies. setuptools should be a makedepends, boost is not needed at all. libtorrent-rasterbar has boost-libs already

Berseker commented on 2010-08-09 13:49

It was necessary some time ago, now any patches is applied so it can be removed safely. Thanks for the report.
Updated at today

jackoneill commented on 2010-08-09 08:55

Why is 'patch' a dependency?

Berseker commented on 2010-06-22 15:15

updated only for new version. No changes in the PKGBUILD, it still works fine

killajoe commented on 2010-06-20 19:40

Building and installing works fine!

PKGBUILD installs:
Core Version: 1.3.900-dev

Anonymous comment on 2010-05-18 16:36

The subversion repository is still open however we have disabled write access to it, so its strictly read-only rendering it fairly useless. I imagine it will be removed at some point in time.

Berseker commented on 2010-05-05 19:54

theoretically deluge has moved to git.
http://dev.deluge-torrent.org/wiki/Development
I do not know if svn is still active, anyway I think that it will be deprecated sooner or later

Ape commented on 2010-05-05 19:37

Should we use this package or deluge-svn?

Berseker commented on 2010-03-27 08:15

sadly the comment that was posted here was lost. What was the suggestion about using the deluge's libtorrent lib?