Package Details: denemo 2.5.0-1

Git Clone URL: https://aur.archlinux.org/denemo.git (read-only, click to copy)
Package Base: denemo
Description: A music score editor
Upstream URL: http://www.denemo.org
Licenses: GPL
Submitter: Barthalion
Maintainer: haawda
Last Packager: haawda
Votes: 5
Popularity: 0.45
First Submitted: 2018-01-05 20:10
Last Updated: 2021-03-05 21:02

Latest Comments

1 2 Next › Last »

haawda commented on 2020-12-04 15:23

Seeme a well known upstream issue. I disabled some configure flags for now,

zoe commented on 2020-12-03 22:09

denemo does not start for me :

  [chris@portable-ch ~]$ denemo
  Denemo data expected in /usr/share/denemo/
  Denemo - MESSAGE : Loading preference file: /home/chris/.denemo-2.4.0/denemorc
  Denemo - MESSAGE : Audio driver is 'portaudio'
  Denemo - MESSAGE : Initializing Fluidsynth
  ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
  ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
  ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
  attempt to connect to server failed
  fluidsynth: warning: SDL2 not initialized, SDL2 audio driver won't be usable
  Denemo - MESSAGE : The default fluidsynth soundfont has been loaded
  Denemo - MESSAGE : Initializing Rubberband
  Denemo - MESSAGE : Initializing PortAudio backend
  ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
  ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
  ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  ALSA lib pcm_route.c:877:(find_matching_chmap) Found no matching channel map
  connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
  attempt to connect to server failed
  Denemo - MESSAGE : Opening output device 'ALSA: default'
  Denemo - MESSAGE : MIDI driver is 'portmidi'
  Denemo - MESSAGE : Initializing PortMidi backend
  Denemo - MESSAGE : Opening input device 'ALSA: Midi Through Port-0'
  Denemo - MESSAGE : Opening output device 'ALSA: Midi Through Port-0'
  denemo: src/hostapi/alsa/pa_linux_alsa.c :3636 : PaAlsaStreamComponent_BeginPolling:  l'assertion « ret == self->nfds » a échoué.
  Abandon (core dumped)

cmsigler commented on 2020-06-01 17:51

@rhendric,

I'm seeing the same thing. It seems I've never tried building denemo before on any of my boxes. But denemo-git built for me, FWIW. Try that instead.

My suspicion is that changes in the operation of gcc ver. 10 are causing problems. Another couple of AUR packages I'm trying have had build problems, one also throwing "multiple definition" errors from ld. The gcc-10.1.0-1 upgrade is dated on 2020-05-08.

Marking out-of-date.

Clemmitt Sigler

rhendric commented on 2020-05-23 19:20

I'm having trouble building this; I get a long list of linker errors along the lines of:

/usr/bin/ld: audio/parseinstruments.o:(.bss+0x0): multiple definition of `Denemo'; audio/midi.o:(.bss+0x20): first defined here

haawda commented on 2019-07-27 22:46

Homepage says: Current stable version: 2.2 from July 28th 2017.

Edit: Okay, mailing list says that 2.3.0 is stable...

haawda commented on 2019-07-27 22:46

Homepage says: Current stable version: 2.2 from July 28th 2017.

haawda commented on 2019-07-27 22:46

Homepage says: Current stable version: 2.2 from July 28th 2017.

haawda commented on 2018-11-22 21:45

Sorry, the last uploads failed, should work now.

SunDoctor commented on 2018-11-21 08:27

Sorry, I can't build last version:

Making package: denemo 2.2.0-5 (Wed 21 Nov 2018 11:23:44 AM MSK) -> Found no_portaudio.patch ==> Validating source files with sha256sums... denemo-2.2.0.tar.gz ... Passed denemo-2.2.0.tar.gz.sig ... Skipped no_portaudio.patch ... FAILED

haawda commented on 2018-02-25 19:58

Trizen cannot handle gpg keys, I think. You have to do the following manually

gpg --recv-keys AE6F83BB6C574235

Alternativly you run makepkg with --skippgpcheck option.

I will add that key to the PKGBUILD to make things easier.