Package Details: denise-git v1.1.3.1.r37.ge9a2811-1

Git Clone URL: https://aur.archlinux.org/denise-git.git (read-only, click to copy)
Package Base: denise-git
Description: Highly accurate C64/Amiga emulator - Git version
Upstream URL: https://sourceforge.net/projects/deniseemu/
Licenses: GPL
Conflicts: denise, denise-bin
Provides: denise
Submitter: sperg512
Maintainer: sperg512 (FredBezies)
Last Packager: FredBezies
Votes: 1
Popularity: 0.000000
First Submitted: 2020-10-22 15:57 (UTC)
Last Updated: 2022-12-28 08:40 (UTC)

Latest Comments

FredBezies commented on 2021-12-19 15:44 (UTC) (edited on 2021-12-19 15:46 (UTC) by FredBezies)

You need to remove prepare section.

patching file denise/data/denise.desktop
Reversed (or previously applied) patch detected!  Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file denise/data/denise.desktop.rej

And it is busted too. See denise page because it is the same building bug.

FredBezies commented on 2021-04-03 21:24 (UTC)

I tried to build denise-git in a clean chroot and I got this error:

In file included from driver/driver.cpp:37:
driver/audio/openal.cpp:6:14: fatal error: AL/al.h: No such file or directory
    6 |     #include <AL/al.h>
      |              ^~~~~~~~~
compilation terminated.
make: *** [Makefile:98: obj/driver.o] Error 1
make: *** Waiting for unfinished jobs....

Fixed by adding openal to depends.

You also need to add libpulse:

In file included from driver/driver.cpp:41:
driver/audio/pulseaudio.cpp:2:10: fatal error: pulse/pulseaudio.h: No such file or directory
    2 | #include <pulse/pulseaudio.h>
      |          ^~~~~~~~~~~~~~~~~~~~

sperg512 commented on 2021-02-02 21:32 (UTC)

@FredBezies it still should be. I can't be asked for the life of me to fix it right now but eventually, I'll just provide a desktop file instead of a patch

FredBezies commented on 2021-01-31 21:56 (UTC) (edited on 2021-02-01 07:49 (UTC) by FredBezies)

patching file denise/data/denise.desktop
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file denise/data/denise.desktop.rej

Looks like the patch is not needed anymore.