Package Details: desktop-privileges 0.5-3

Git Clone URL: https://aur.archlinux.org/desktop-privileges.git (read-only)
Package Base: desktop-privileges
Description: A collection of polkit rules to manage automounting of removable media, suspend and hibernate actions and CPU frequency settings.
Upstream URL: https://aur.archlinux.org/packages/desktop-privileges/
Licenses: GPL
Conflicts: polkit-automount-upower-rules
Replaces: polkit-automount-upower-rules
Submitter: uwinkelvos
Maintainer: flying-sheep
Last Packager: flying-sheep
Votes: 59
Popularity: 0.005148
First Submitted: 2010-11-05 18:50
Last Updated: 2017-09-22 15:03

Latest Comments

nous commented on 2017-09-22 15:39

I've moved out of Arch, thanks for adopting.

flying-sheep commented on 2017-07-26 18:00

hi, can you change the dependencies to just polkit and udisks2, and make pm-utils optional?

your variant packages all have “provides=(basename)”, and with this change, people with regular polkit and udisks2 can also use this package.

Megver83 commented on 2017-03-23 15:38

@nous yes, sad news to know that consolekit is deprecated. I'm maintaining some consolekit and elogind packages, I'm a packager from an Arch based distro, and it has OpenRC packages, so then all consolekit packagers were removed from there and now we are uploading them again, because the transition to elogind it's incomplete for now, I hope it worth

nous commented on 2017-03-22 22:12

Thanks for the heads-up, however this is sad news. I'm still very short on time but I'll take a look into it soon.

Megver83 commented on 2017-03-20 15:10

pm-utils is no longer in Arch Linux so I created it again.
Also, Manjaro removed its consolekit packages https://github.com/manjaro/packages-openrc now they are here https://github.com/udeved/packages-testing I say this because maybe in the future (better said now) polkit-consolekit will be replaced with polkit-elogind, so you could try to see how dektop-privileges work with it, maybe you could create a new package desktop-privileges-elogind or upgrade dektop-privileges.

Cromer commented on 2016-09-03 17:09

'upower-pm-utils' is no longer in the AUR. The dependency should be changed to the following:

'upower' 'pm-utils'

nous commented on 2016-06-05 21:12

This is just a rules collection, there's no compiling involved - only packaging.

Cromer commented on 2016-06-05 03:15

There is a required make dependency that is not met for this package. libgudev, it won't compile unless this is installed.

nous commented on 2015-04-19 09:53

To answer my own question, the old actions are covered by udisks2-nosystemd and mate-power-manager-upower, listed hereafter as depends and optdepends respectively.

nous commented on 2015-04-11 16:10

Just found this, and it seems it can be merged with polkit-automount-upower-rules (or vice-versa). Is there any automagickal way to convert the old actions format into the new one?

All comments