Package Details: despotify-svn 521-2

Git Clone URL: https://aur.archlinux.org/despotify-svn.git (read-only)
Package Base: despotify-svn
Description: Console client for Spotify (development version)
Upstream URL: http://despotify.sourceforge.net/
Licenses: BSD
Conflicts: despotify-ao-svn, despotify-pulse-svn
Submitter: xyproto
Maintainer: None
Last Packager: xyproto
Votes: 72
Popularity: 0.265560
First Submitted: 2009-03-27 19:04
Last Updated: 2015-06-10 12:33

Latest Comments

Hzxllprkwx commented on 2016-05-25 18:53

I can connect, everything seems to work find, it's connected and stuff except... I can search nothing. I do have a premium account though.

ONLINE ap.gslb.spotify.com

xyproto commented on 2016-01-03 12:20

The package builds, installs and runs here (don't have Spotify premium anymore, can't test all functionality). Upstream does not seem to be particularly active, but problems with the application should be reported to them.

zobi8225 commented on 2016-01-01 23:14

@bluevector ; It don't work for me too...

bluevector commented on 2015-12-15 23:20

Is despotify still active&working, or am I the only one that cannot use the tool.(Search does not work & the last update seems @ 2012 in upstream) Is there anyone who can still use despotify?

xyproto commented on 2014-11-03 14:41

Problems with despotify itself can be reported upstream to the despotify developers, here: http://sourceforge.net/p/despotify/bugs/

stecco commented on 2014-07-11 10:10

no search for me too!

caravanlizzy commented on 2014-06-29 16:28

no search for me too!

Anonymous comment on 2013-06-08 19:27

Confirmed... unable to search. Guess just gotta wait for upstream to push an update

xyproto commented on 2013-05-26 09:53

raw, I'm unable to search as well.

Updated the package to to use the prepare() and pkgver() functions.

raw commented on 2013-05-24 13:16

Is it broken just for me or for everyone?

i launch the despotify client and try a search:
(15:12:50) Initialized audio output
(15:12:57) thread_loop(): PAUSE, sleeping
(15:12:57) Logged in as 1122076476@ap.gslb.spotify.com:4070 (DE)
(15:13:01) Searching for: <knorkator>
(15:13:02) Error when searching
(15:13:06) Searching for: <dance>
(15:13:06) Error when searching

i also cant get any playlist

xyproto commented on 2013-05-09 20:04

clubbby, Arch Linux ARM has their own system for handling AUR packages and official packages that doesn't compile. See for instance the "aur" directory of this mirror: http://us.mirror.archlinuxarm.org/armv6h/. I also know that they don't like it if ie. [community] packages are modified in an attempt to be more ARM-friendly, as they have their own methods to handle the porting. despotify-svn is already packaged for armv6h and can be found at their mirror. Also note that Arch Linux ARM is a completely different distro from Arch Linux. Currently, Arch Linux only targets i686 and x86_64.

Anonymous comment on 2013-05-09 19:09

Successful compile and execution on armv6h. Consider adding to arch in PKGBUILD?

xyproto commented on 2012-12-23 04:12

Please consider reporting a bug here, if it has problems: http://sourceforge.net/tracker/?group_id=254350&atid=1126905&source=navbar

xyproto commented on 2012-12-23 04:10

The despotify.se website is currently down as well, so I wonder where to report this.

madalu commented on 2012-12-22 21:58

despotify-svn worked fine until last week. Now both despotify and despotify-simple segfault when selecting a song to play. Can others replicate?

xyproto commented on 2012-08-20 00:15

Updated to 521.

drm00 commented on 2012-08-17 13:02

521 is out: http://despotify.svn.sourceforge.net/

xyproto commented on 2012-05-05 10:47

gDD, updated the package, thanks for noticing.

Anonymous comment on 2012-05-05 03:30

despotify is licensed under BSD (http://despotify.se/faq/), please update the PKGBUILD.

skualito commented on 2012-03-21 08:25

@paulinchenck
from #despotify irc

<pascal_> Hi, is there a way to connect via despotify with a facebook login?
<raw_> no, its not supported. you need to generate a "device password" at spotify and use the numeric customer id from your profile.

skualito commented on 2012-03-21 08:22

@paulincheck
Login with FB is not supported. I asked on #despotify irc, what you want to do is generate a "device password" at spotify and use the numeric customer id from your profile.
I just did it, and enjoy despotify now ;)

Anonymous comment on 2012-03-18 20:07

Does anyone know how to connect to despotify with a facebook login?

xyproto commented on 2012-03-17 17:21

raw, thanks for the info, added a message about it to be displayed at install-time.

raw commented on 2012-03-17 11:40

if you are using pulseaudio and get no sound with despotify, see https://wiki.archlinux.org/index.php/PulseAudio#libao
rev 520 is out.

xyproto commented on 2012-02-23 00:00

ian_fin, thanks, added mpg123 as dependency.

Anonymous comment on 2012-02-22 17:08

Getting the following error while compiling:

sndqueue.c:13:20: fatal error: mpg123.h: No such file or directory
compilation terminated.
make[1]: *** [sndqueue.lo] Error 1
make: *** [lib] Error 2

xyproto commented on 2011-07-30 18:16

evaryont, thank you, updated the PKGBUILD.

evaryont commented on 2011-07-21 05:27

You don't need to use the 32 bit libao on 64 bit Arch. Compiles and operates fine using the 64 bit library.

xyproto commented on 2011-03-19 10:00

The latest svn revision compiles here, but segfaults.

xyproto commented on 2011-02-24 17:05

I can't get a sound out of despotify from the latest revision, but it compiles, installs and runs fine. (I did get sound before).

xyproto commented on 2011-02-21 12:49

Configured despotify to use libao. Now using sed instead of setconf.

xyproto commented on 2010-10-10 19:59

benbrooks, the package was not out of date. setconf was used to fix the segfault, but I might just as well use sed or a patch. The anti-segfault fix currently works, though.

Anonymous comment on 2010-10-10 19:31

This requires setconf as a dependency.

http://aur.archlinux.org/packages.php?ID=25170

xyproto commented on 2010-10-07 12:50

despotify does not segfault anymore, thanks to a suggestion from korkadapa. (:q to quit).

xyproto commented on 2010-07-02 11:22

Previously, despotify included a binary called "simple" that conflicted with libftdi, but now it's called despotify-simple instead.
For the current svn revision, /usr/bin/despotify segfaults, but /usr/bin/despotify-simple seems to work.