Package Details: diceware 0.10-1

Git Clone URL: https://aur.archlinux.org/diceware.git (read-only, click to copy)
Package Base: diceware
Description: Wordlist-based password generator.
Upstream URL: https://github.com/ulif/diceware
Licenses: GPL3
Submitter: ClawOfLight
Maintainer: ClawOfLight
Last Packager: ClawOfLight
Votes: 20
Popularity: 0.173811
First Submitted: 2017-01-07 12:48 (UTC)
Last Updated: 2022-02-15 13:27 (UTC)

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

gesh commented on 2024-03-25 13:54 (UTC)

The addition of python-pip is unnecessary, just convert to PEP517:

depends=('python')
makedepends=('python-build' 'python-installer' 'python-wheel')
license=('GPL-3.0-or-later')

build() {
    cd "${srcdir}/${_src_folder}"
    python -m build --wheel --no-isolation
}

package() {
    cd "${srcdir}/${_src_folder}"
    python -m installer --destdir="${pkgdir}" dist/*.whl
}

netzego commented on 2023-11-03 20:44 (UTC) (edited on 2023-11-03 20:46 (UTC) by netzego)

doesn't build anymore. this need to be fixed in diceware upstream. pr is on github: https://github.com/ulif/diceware/pull/97

/usr/lib/python3.11/site-packages/setuptools/__init__.py:84: _DeprecatedInstaller: setuptools.installer and fetch_build_eggs are deprecated.
!!

        ********************************************************************************
        Requirements should be satisfied by a PEP 517 installer.
        If you are using pip, you can try `pip install --use-pep517`.
        ********************************************************************************

!!

pants commented on 2023-05-03 19:47 (UTC)

python-setuptools needs to be in makedepends to build this package.

ClawOfLight commented on 2021-02-23 18:42 (UTC)

I added python-pip as makedepend and bumped pkgrel, thanks for bringing this up!

e202b15315d6

crasm commented on 2021-02-21 22:30 (UTC)

Hello, this package fails to build unless you have python-pip installed. Can you add it to the makedepends?

makedepends=('python-pip')