Package Details: dicomscope-bin 3.6.0-27

Git Clone URL: https://aur.archlinux.org/dicomscope-bin.git (read-only, click to copy)
Package Base: dicomscope-bin
Description: OFFIS DICOM viewer.
Upstream URL: http://dicom.offis.de/dscope.php.en
Keywords: medical
Licenses: OFFIS
Submitter: AsGreyWolf
Maintainer: g360
Last Packager: g360
Votes: 4
Popularity: 0.000219
First Submitted: 2018-03-19 12:04 (UTC)
Last Updated: 2024-03-02 23:55 (UTC)

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

g360 commented on 2024-03-03 00:00 (UTC)

The package has been updated and now works with current libtiff.so.6.

vct commented on 2023-11-10 18:34 (UTC) (edited on 2023-11-10 18:47 (UTC) by vct)

@zwastik @gc1 A workaround for libtiff.so.5 missing is:

  • if you don't have libtiff package installed: @ pacman -S libtiff
  • now do: @ sudo ln -s /usr/lib/libtiff.so /usr/lib/libtiff.so.5

DICOMscope seems to work fine after doing this

zwastik commented on 2023-06-05 02:53 (UTC)

$ dicomscope 
starting DICOMscope
please wait...
Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/lib/jni/libjInterface.so: libtiff.so.5: cannot open shared object file: No such file or directory
        at java.base/jdk.internal.loader.NativeLibraries.load(Native Method)
        at java.base/jdk.internal.loader.NativeLibraries$NativeLibraryImpl.open(NativeLibraries.java:331)
        at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:197)
        at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:139)
        at java.base/jdk.internal.loader.NativeLibraries.findFromPaths(NativeLibraries.java:259)
        at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(NativeLibraries.java:251)
        at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2437)
        at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:880)
        at java.base/java.lang.System.loadLibrary(System.java:2051)
        at main.MainContext.<clinit>(MainContext.java:58)
        at dicomscope.DICOMscope.main(DICOMscope.java:91)

g360 commented on 2022-03-06 16:56 (UTC) (edited on 2022-03-06 16:56 (UTC) by g360)

The package has been updated and the shared object dependencies bugs have been fixed, in this packages and in the newer libdicomscope-jni-bin and libdcmtk14-bin dependencies.

juxuanu commented on 2021-10-28 09:46 (UTC)

Use http://launchpadlibrarian.net/344065146/dicomscope_3.6.0-18_all.deb

politas commented on 2021-10-12 21:41 (UTC)

curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading http://mirrors.kernel.org/ubuntu/pool/universe/d/dicomscope/libdicomscope-jni_3.6.0-17_amd64.deb
    Aborting...
Failed to build libdicomscope-jni

Failing even earlier

jose1711 commented on 2021-10-09 23:10 (UTC)

$ ldd /usr/lib/x86_64-linux-gnu/jni/libjInterface.so | grep 'not found'
ldd: warning: you do not have execution permission for `/usr/lib/x86_64-linux-gnu/jni/libjInterface.so'
    libicuuc.so.60 => not found

nursoda commented on 2020-05-28 01:45 (UTC)

Currently not installable this way due to multiple (nested) unmet dependencies

marcin commented on 2019-05-08 05:54 (UTC)

Still the same error /bin/dicomscope: cannot execute binary file: Exec format error

AsGreyWolf commented on 2018-05-14 13:12 (UTC) (edited on 2018-05-14 13:12 (UTC) by AsGreyWolf)

You can use java -Djava.library.path=/usr/lib/x86_64-linux-gnu/jni/ -jar /usr/bin/dicomscope I will fix this later