Package Details: diff-pdf 0.5-5

Git Clone URL: https://aur.archlinux.org/diff-pdf.git (read-only, click to copy)
Package Base: diff-pdf
Description: A simple tool for visually comparing two PDF files
Upstream URL: http://vslavik.github.io/diff-pdf
Licenses: GPL
Submitter: alerque
Maintainer: alerque
Last Packager: alerque
Votes: 3
Popularity: 0.094098
First Submitted: 2021-01-25 11:04 (UTC)
Last Updated: 2022-08-15 22:32 (UTC)

Latest Comments

Markus00000 commented on 2022-07-15 07:42 (UTC)

Build fails:

configure: error: wxWidgets is required

From the news:

wxWidgets 3.2 provides a Qt frontend in addition to the GTK3 one, so packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided.

MarsSeed commented on 2022-05-16 21:51 (UTC)

@alerque, thank you for this update!

alerque commented on 2022-05-16 16:22 (UTC)

@MarsSeed Thanks for that tip, I applied your suggestion to the latest pkgrel.

MarsSeed commented on 2022-05-13 21:37 (UTC) (edited on 2022-05-14 15:57 (UTC) by MarsSeed)

This can be built with wxgtk3 if you configure it with:

./configure --prefix=/usr --with-wx-config=wx-config-gtk3

(Arch has renamed the wx-config executable in wxgtk3 package to wx-config-gtk3.)

Project README.md and configure.ac states that it requires at least wxWidgets 3.0.

alerque commented on 2021-11-22 19:43 (UTC)

@steadfasterX Something else on your system got updated and you need to rebuild this package to match. This happens automatically for repository packages (which somebody else bumps the pkgrel number and rebuilds them for you) but not for things you build from the AUR.

steadfasterX commented on 2021-11-19 12:18 (UTC)

no idea why but I get the following error when starting:

Warning: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8), and diff-pdf used 3.0 (wchar_t,compiler with C++ ABI 1016,wx containers,compatible with 2.8).