Package Details: diff-pdf-git 0.5.r1.g201dab3-2

Git Clone URL: https://aur.archlinux.org/diff-pdf-git.git (read-only, click to copy)
Package Base: diff-pdf-git
Description: A simple tool for visually comparing two PDF files
Upstream URL: http://vslavik.github.io/diff-pdf
Licenses: GPL
Conflicts: diff-pdf
Provides: diff-pdf
Submitter: xduugu
Maintainer: alerque (aksr)
Last Packager: alerque
Votes: 16
Popularity: 0.079522
First Submitted: 2015-03-21 20:21 (UTC)
Last Updated: 2022-06-08 10:52 (UTC)

Latest Comments

1 2 Next › Last »

ndandanov commented on 2022-07-21 10:21 (UTC)

After the latest changes around wxWidgets (https://archlinux.org/news/wxwidgets-32-update-may-need-manual-intervention/), the following works properly:

./configure --prefix /usr --with-wx-config=wx-config

MarsSeed commented on 2022-06-08 11:00 (UTC)

Thank you for the wxgtk3 switchover, @alerque! :)

MarsSeed commented on 2022-05-03 20:23 (UTC) (edited on 2022-05-03 20:37 (UTC) by MarsSeed)

@alerque My flag was not incorrect. You just need the following for wxgtk3 build:

./configure --prefix=/usr --with-wx-config=wx-config-gtk3

Because Arch has renamed the wx-config executable in wxgtk3 package to wx-config-gtk3.

Project README.md and configure.ac states that it requires at least wxWidgets 3.0.

alerque commented on 2022-05-03 09:26 (UTC)

@MarsSeed Your flag on this is incorrect, I tested in a chroot and it does not build with wxgtk3 and it works fine with wxgtk2. I see the upstream commit you linked but something isn't working right about it.

ceres-c commented on 2021-01-17 12:13 (UTC)

Would you mind topping up the release number? I had to force the update as yay did not notice there was a package update

nplatis commented on 2021-01-11 22:48 (UTC)

The official "wxgtk2" package has just dropped "providing" wxgtk, thus the dependency cannot be fulfilled. I changed to dependency to "wxgtk2" and everything seems to work.

Markus00000 commented on 2016-06-01 11:40 (UTC)

Build failure: checking for wxWidgets version >= 3.0... ./configure: line 3659: test: 0: unary operator expected ./configure: line 3662: test: 0: unary operator expected no (version 3.0.2 is not new enough) configure: error: wxWidgets is required

xduugu commented on 2015-12-15 00:05 (UTC)

Just built the package, but I cannot reproduce your issue. Did you build it in a clean chroot?

xrchz commented on 2015-12-14 23:29 (UTC)

I ran into this problem: ... ./configure: line 3288: syntax error near unexpected token `POPPLER,' ./configure: line 3288: `PKG_CHECK_MODULES(POPPLER,' ==> ERROR: A failure occurred in build().