Package Details: digikam-git v7.5.0.r345.g61141c0787-1

Git Clone URL: https://aur.archlinux.org/digikam-git.git (read-only, click to copy)
Package Base: digikam-git
Description: An advanced digital photo management application
Upstream URL: https://www.digikam.org/
Keywords: images kde photo photos pictures
Licenses: GPL
Conflicts: digikam
Provides: digikam
Submitter: flamelab
Maintainer: None
Last Packager: Ta180m
Votes: 25
Popularity: 0.000033
First Submitted: 2011-02-06 10:54 (UTC)
Last Updated: 2022-02-08 17:33 (UTC)

Latest Comments

MarsSeed commented on 2022-06-23 15:07 (UTC)

While Qt5 might still work temporarily when building the current master, it is unsupported there.

Only the qt5-maintenance branch supports Qt5 officially.

jblume commented on 2022-06-23 14:58 (UTC)

ffmpeg5.patch is neither working for me nor any longer neccessary. I stripped the lines in PGKBUILD an had no problems.

MarsSeed commented on 2022-06-23 14:58 (UTC)

There is a digikam/qt5-maintenance branch.

If someone needs a VCS package for that, I suggest to fork this one, rename it to digikam-qt5-git and upload that as new package to AUR.

MarsSeed commented on 2022-06-23 14:54 (UTC)

@jblume, this package is an orphan, there is no maintainer.

Also, the master branch now requires Qt6, so no need to add any Qt5 dependency. All Qt5 dependencies need to be removed and the needed Qt6 ones have to be added.

jblume commented on 2022-06-23 14:48 (UTC)

Please add dependency qt5-networkauth because my last compile failed: -- Check dependencies for digikam version 8.0.0-git -- -- Suitable Qt5 >= 5.14.0 detected... CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package): Could not find a package configuration file provided by "Qt5NetworkAuth" with any of the following names:

Qt5NetworkAuthConfig.cmake
qt5networkauth-config.cmake

Add the installation prefix of "Qt5NetworkAuth" to CMAKE_PREFIX_PATH or set "Qt5NetworkAuth_DIR" to a directory containing one of the above files. If "Qt5NetworkAuth" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): core/cmake/rules/RulesQtFramework.cmake:7 (find_package) core/CMakeLists.txt:43 (include)

-- Configuring incomplete, errors occurred! See also "/home/juergen/.cache/pikaur/build/digikam-git/src/build/CMakeFiles/CMakeOutput.log". ==> FEHLER: Ein Fehler geschah in build().

maderios commented on 2022-05-16 09:14 (UTC) (edited on 2022-05-16 18:01 (UTC) by maderios)

Officially from devs, Digikam doesn't compile with ffmpeg 5 now. Here, the patch doesn't work. Solution: compile Digikam with ffmpeg4.4

-DCMAKE_PREFIX_PATH="/usr/lib/ffmpeg4.4;/usr/include/ffmpeg4.4" 

MarsSeed commented on 2022-05-06 17:59 (UTC)

Also the master branch now depends on Qt6 by default, and builds against it if that is installed.

This fails the build for me because I have qt6-base installed but not qt6-webengine:

-- Check dependencies for digikam version 8.0.0-git
-- 
-- Performing Test HAVE_STDATOMIC
-- Performing Test HAVE_STDATOMIC - Success
-- Suitable Qt6 >= 6.2.3 detected...
-- Found Threads: TRUE  
-- Found OpenGL: /usr/lib/libOpenGL.so   
-- Found WrapOpenGL: TRUE  
-- Found XKB: /usr/lib/libxkbcommon.so (found suitable version "1.4.0", minimum required is "0.5.0") 
-- Found WrapVulkanHeaders: /usr/include  
-- Could NOT find Qt6WebEngineWidgets (missing: Qt6WebEngineWidgets_DIR)
CMake Error at core/cmake/rules/RulesQtFramework.cmake:21 (find_package):
Found package configuration file:

    /usr/lib64/cmake/Qt6/Qt6Config.cmake

but it set Qt6_FOUND to FALSE so package "Qt6" is considered to be NOT
FOUND.  Reason given by package:

Failed to find Qt component "WebEngineWidgets".

Expected Config file at
"/usr/lib64/cmake/Qt6WebEngineWidgets/Qt6WebEngineWidgetsConfig.cmake" does
NOT exist


Call Stack (most recent call first):
core/CMakeLists.txt:43 (include)


-- Configuring incomplete, errors occurred!

MarsSeed commented on 2022-05-06 17:33 (UTC)

Fails to patch sources:

==> Making package: digikam-git v7.5.0.r345.g61141c0787-1 (2022-05-06 19:22:29 CEST)
[...]
==> Starting prepare()...
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/core/libs/threadimageio/video/videodecoder_p.h b/core/libs/threadimageio/video/videodecoder_p.h
|index 251e092809..d82926b77e 100644
|--- a/core/libs/threadimageio/video/videodecoder_p.h
|+++ b/core/libs/threadimageio/video/videodecoder_p.h
--------------------------
File to patch:

danieltetraquark commented on 2021-01-06 23:24 (UTC)

@badelf did you uninstall libmagick6 before building? This was the issue for me (see one page back)

badelf commented on 2021-01-06 23:00 (UTC)

I tried this, which is now at beta2, and I get "in function DigikamImageMagickDImgPlugin::DImgImageMagickLoader::load(QString const&, Digikam::DImgLoaderObserver*)': dimgimagemagickloader.cpp:(.text+0x382): undefined reference toMagick::Image::columns() const' /usr/bin/ld: dimgimagemagickloader.cpp:(.text+0x3a8): undefined reference to `Magick::Image::rows() const' " What am I missing here?

ChrisLane commented on 2020-12-20 09:33 (UTC)

@maderios that sounds correct. The dependencies were taken from the package in Extra and since the software functions without 'qt5-imageformats', it should be an optional dependency.

maderios commented on 2020-12-20 06:59 (UTC)

'qt5-imageformats' is not optional dependency because digikam can't display XCF/gimp files without it.

ChrisLane commented on 2020-12-15 23:13 (UTC)

I have adopted the package and updated the source url.

vienna commented on 2020-07-16 13:31 (UTC)

Changing the source and removing libmagick6 was the trick to get it compiled. Takes ~4.5GB of empty space.

maderios commented on 2020-06-21 16:08 (UTC) (edited on 2020-07-12 15:35 (UTC) by maderios)

Right source now, it works for me:

source=('git+https://invent.kde.org/graphics/digikam.git')

malcolm commented on 2020-06-21 01:07 (UTC)

Please, update the url of the git repository!

SolarAquarion commented on 2020-06-19 14:20 (UTC)

Cloning into bare repository '/home/main-builder/pkgsrc/digikam'... fatal: remote error: Please use the https: protocol to connect to anongit

maderios commented on 2020-06-12 19:29 (UTC)

Build doesn't work because git repository changed: https://invent.kde.org/graphics/digikam.git

danieltetraquark commented on 2020-01-01 13:31 (UTC) (edited on 2020-01-01 13:45 (UTC) by danieltetraquark)

EDIT: I think it is fixed by removing libmagick6

maderios commented on 2020-01-01 11:50 (UTC)

It works for me. Add 'imagemagick' dependency. Then makepkg -sicC. Don't use Aur helper.

danieltetraquark commented on 2019-12-31 23:40 (UTC)

I installed im7 (the correct one, version 7.0.9.10-1), now it's complaining about some missing functions I think:

/usr/bin/ld: CMakeFiles/DImg_ImageMagick_Plugin.dir/dimgimagemagickloader.cpp.o: in function `DigikamImageMagickDImgPlugin::DImgImageMagickLoader::load(QString const&, Digikam::DImgLoaderObserver*)':
src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:107: undefined reference to `Magick::Image::columns() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:107: undefined reference to `Magick::Image::rows() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:138: undefined reference to `Magick::Image::columns() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:139: undefined reference to `Magick::Image::rows() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:145: undefined reference to `Magick::Image::alpha() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:154: undefined reference to `Magick::Image::rows() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:154: undefined reference to `Magick::Image::columns() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:167: undefined reference to `Magick::Image::columns() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:168: undefined reference to `Magick::Image::rows() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:173: undefined reference to `Magick::Image::alpha() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:181: undefined reference to `Magick::Image::rows() const'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:181: undefined reference to `Magick::Image::columns() const'
/usr/bin/ld: CMakeFiles/DImg_ImageMagick_Plugin.dir/dimgimagemagickloader.cpp.o: in function `DigikamImageMagickDImgPlugin::DImgImageMagickLoader::save(QString const&, Digikam::DImgLoaderObserver*)':
src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:219: undefined reference to `Magick::Geometry::Geometry(unsigned long, unsigned long, long, long)'
/usr/bin/ld: src/digikam/core/dplugins/dimg/imagemagick/dimgimagemagickloader.cpp:226: undefined reference to `Magick::Image::alpha(bool)'
collect2: Fehler: ld gab 1 als Ende-Status zurück
make[2]: *** [core/dplugins/dimg/imagemagick/CMakeFiles/DImg_ImageMagick_Plugin.dir/build.make:116: core/dplugins/dimg/imagemagick/DImg_ImageMagick_Plugin.so] Fehler 1
[ 88%] Building CXX object core/dplugins/dimg/jpeg2000/CMakeFiles/DImg_JPEG2000_Plugin.dir/dimgjpeg2000loader_save.cpp.o
make[1]: *** [CMakeFiles/Makefile2:17619: core/dplugins/dimg/imagemagick/CMakeFiles/DImg_ImageMagick_Plugin.dir/all] Fehler 2

maderios commented on 2019-12-30 21:55 (UTC)

@danieltetraquark I see in @ctouze comment 'libdigikamcore.so.6.2.0] Error'==> it clearly means Imagemagick 6 is installed on computer, CMAKES looks for Imagemagick 7. If I remember my own experience, Digikam build doesnt like that. Uninstall IM6. You need only IM7 to compile DK. If you neeed IM6, you can reinstall it after installing digikam.

danieltetraquark commented on 2019-12-30 21:28 (UTC)

@ctouze did you find a solution? If have imagemagick installed and the build still fails with exact same error. I don't think it is an upstream bug.

maderios commented on 2019-08-24 09:30 (UTC)

Digikam needs Imagemagick dependency

maderios commented on 2019-05-30 14:50 (UTC)

@ctouze This is digikam git version. You may report bugs upstream https://bugs.kde.org/enter_bug.cgi

ctouze commented on 2019-05-30 13:11 (UTC)

Build issue [34%] Linking CXX shared library libdigikamcore.so / usr / bin / ld: ../libs/dimg/CMakeFiles/dimg_src.dir/loaders/magickloader.cpp.o: in the function "Digikam :: MagickLoader :: load (QString const &, Digikam :: DImgLoaderObserver )" : magickloader.cpp :(. text + 0x3e6): undefined reference to "Magick :: Image :: columns () const" / usr / bin / ld: magickloader.cpp :(. text + 0x40c): undefined reference to "Magick :: Image :: rows () const" / usr / bin / ld: magickloader.cpp :( .text + 0x748): undefined reference to "Magick :: Image :: columns () const" / usr / bin / ld: magickloader.cpp :(. text + 0x760): undefined reference to "Magick :: Image :: rows () const" / usr / bin / ld: magickloader.cpp :(. text + 0x792): undefined reference to "Magick :: Image :: alpha () const" / usr / bin / ld: magickloader.cpp :(. text + 0x8c7): undefined reference to "Magick :: Image :: rows () const" / usr / bin / ld: magickloader.cpp :(. text + 0x8d3): undefined reference to "Magick :: Image :: columns () const" / usr / bin / ld: magickloader.cpp :(. text + 0xb4c): undefined reference to "Magick :: Image :: rows () const" / usr / bin / ld: magickloader.cpp :(. text + 0xb58): undefined reference to "Magick :: Image :: columns () const" / usr / bin / ld: ../libs/dimg/CMakeFiles/dimg_src.dir/loaders/magickloader.cpp.o: in the function "Digikam :: MagickLoader :: save (QString const &, Digikam :: DImgLoaderObserver )" : magickloader.cpp :(. text + 0x1414): undefined reference to "Magick :: Geometry :: Geometry (unsigned long, unsigned long, long, long)" / usr / bin / ld: magickloader.cpp :(. text + 0x14a9): undefined reference to "Magick :: Image :: alpha (bool)" collect2: error: ld returned exit status 1 make [2]: [core / app / CMakeFiles / digikamcore.dir / build.make: 1419: core / app / libdigikamcore.so.6.2.0] Error 1 make [1]: [CMakeFiles / Makefile2: 7207: core / app / CMakeFiles / digikamcore.dir / all] Error 2 make: *** [Makefile: 130: all] Error 2

maderios commented on 2019-04-21 20:38 (UTC)

Digikam git repositories have changed https://mail.kde.org/pipermail/digikam-users/2019-April/028696.html

arojas commented on 2018-03-14 09:36 (UTC) (edited on 2018-03-14 09:38 (UTC) by arojas)

please replace libkipi-git and libksane-git dependencies with their stable versions, there's no need to depend on the git versions. Same for extra-cmake-modules

Sevenseven commented on 2017-03-17 07:15 (UTC)

Could you post full log via pastebin?

rev.cressy commented on 2017-03-16 15:58 (UTC)

I also got the following make[2]: *** [libs/threadimageio/CMakeFiles/threadimageio_src.dir/build.make:447: libs/threadimageio/CMakeFiles/threadimageio_src.dir/videothumbnailer.cpp.o] Error 1 make[1]: *** [CMakeFiles/Makefile2:2252: libs/threadimageio/CMakeFiles/threadimageio_src.dir/all] Error 2 make: *** [Makefile:128: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... I Deleted -DENABLE_MEDIAPLAYER=ON" from pkgbuild and that worked for me.

AndrzejL commented on 2017-01-27 00:22 (UTC)

I always run pacman -Syu before compiling anything so that's not the issue. I will try removing that bit as suggested. Cheers.

Sevenseven commented on 2017-01-26 16:08 (UTC)

Cant reproduce. First try to update all pkg, if this doesn't help try to remove " -DENABLE_MEDIAPLAYER=ON" from pkgbuild.

AndrzejL commented on 2017-01-25 23:05 (UTC)

/tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/digikam/libs/dimg/filters/fx/invertfilter.h:82:10: warning: ‘virtual void Digikam::InvertFilter::filterImage()’ can be marked override [-Wsuggest-override] void filterImage(); ^~~~~~~~~~~ make[2]: *** [libs/threadimageio/CMakeFiles/threadimageio_src.dir/build.make:447: libs/threadimageio/CMakeFiles/threadimageio_src.dir/videothumbnailer.cpp.o] Error 1 make[1]: *** [CMakeFiles/Makefile2:2252: libs/threadimageio/CMakeFiles/threadimageio_src.dir/all] Error 2 make[1]: *** Waiting for unfinished jobs....

Sevenseven commented on 2017-01-22 19:42 (UTC)

Find "error 1" and post here please.

AndrzejL commented on 2017-01-22 18:17 (UTC)

/tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/build/libs/widgets/digikamwidgetscore_src_automoc.dir/../../../../digikam/libs/widgets/metadata/xmpwidget.h:46:13: warning: ‘virtual QString Digikam::XmpWidget::getTagDescription(const QString&)’ can be marked override [-Wsuggest-override] QString getTagDescription(const QString& key); ^~~~~~~~~~~~~~~~~ /tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/build/libs/widgets/digikamwidgetscore_src_automoc.dir/../../../../digikam/libs/widgets/metadata/xmpwidget.h:47:13: warning: ‘virtual QString Digikam::XmpWidget::getTagTitle(const QString&)’ can be marked override [-Wsuggest-override] QString getTagTitle(const QString& key); ^~~~~~~~~~~ /tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/build/libs/widgets/digikamwidgetscore_src_automoc.dir/../../../../digikam/libs/widgets/metadata/xmpwidget.h:49:13: warning: ‘virtual QString Digikam::XmpWidget::getMetadataTitle()’ can be marked override [-Wsuggest-override] QString getMetadataTitle(); ^~~~~~~~~~~~~~~~ /tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/build/libs/widgets/digikamwidgetscore_src_automoc.dir/../../../../digikam/libs/widgets/metadata/xmpwidget.h:53:18: warning: ‘virtual void Digikam::XmpWidget::slotSaveMetadataToFile()’ can be marked override [-Wsuggest-override] virtual void slotSaveMetadataToFile(); ^~~~~~~~~~~~~~~~~~~~~~ /tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/build/libs/widgets/digikamwidgetscore_src_automoc.dir/../../../../digikam/libs/widgets/metadata/xmpwidget.h:57:10: warning: ‘virtual bool Digikam::XmpWidget::decodeMetadata()’ can be marked override [-Wsuggest-override] bool decodeMetadata(); ^~~~~~~~~~~~~~ /tmp/yaourt-tmp-andrzejl/aur-digikam-git/src/build/libs/widgets/digikamwidgetscore_src_automoc.dir/../../../../digikam/libs/widgets/metadata/xmpwidget.h:58:10: warning: ‘virtual void Digikam::XmpWidget::buildView()’ can be marked override -Wsuggest-override] void buildView(); ^~~~~~~~~ [ 32%] Built target digikamwidgetscore_src make: *** [Makefile:128: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build digikam-git. ==> Restart building digikam-git ? [y/N] ==> ------------------------------------ ==> ==> ERROR: unable to update [andrzejl@macbookpro82 ~]$

Zack-Clark commented on 2016-11-18 12:27 (UTC)

Everything compiled fine - good work - no issues there - Thanks! However, my nice new Version 5.4.0 suffers from the exact same problem I had with my 5.3.0 Package version. I cannot create, rename, import any directories or files nor successfully "Scan for new items". I am using LXDE and executing digikam from LXTerminal which shows dozens of the following: QPainter::setCompositionMode: Painter not active QPainter::end: Painter not active, aborted

Sevenseven commented on 2016-09-16 08:24 (UTC)

Done.

rtfreedman commented on 2016-09-12 19:45 (UTC) (edited on 2016-09-12 19:55 (UTC) by rtfreedman)

Please change 'akonadi-contact' to 'akonadi-contacts' in depends and while you're at it, check it for dependencies really needed https://quickgit.kde.org/?p=digikam-software-compilation.git&a=blob&h=a192cddbc6ebe46b5954a5207b7f75ea05851821&hb=fcbde6cdea1e79c05d39d409980e71c72cdbcb59&f=DEPENDENCIES

arojas commented on 2016-07-26 21:24 (UTC)

libkdcraw, libkface and libkgeomap are also no longer used.

evorster commented on 2016-07-10 12:16 (UTC)

libkexiv2 is not a requirement to digikam anymore, according to the developers.

venatux commented on 2016-05-04 11:02 (UTC)

To enable opencv 3, please add -DENABLE_OPENCV3:BOOL=ON to cmake.

SanskritFritz commented on 2016-03-11 11:38 (UTC)

This is a git package, no versions here. Just compile it, and it will give you the latest version from git.

lexikon commented on 2016-03-11 11:08 (UTC)

its stable release? can you update to 5.0.0-beta3?

zaks commented on 2015-12-20 19:19 (UTC)

compile error: [ 8%] Building CXX object libs/dimg/CMakeFiles/dimg_src.dir/filters/greycstoration/greycstorationfilter.cpp.o c++: interner Compiler-Fehler: Getötet (Programm cc1plus) Bitte senden Sie einen vollständigen Fehlerbericht auf Englisch ein; inclusive vorverarbeitetem Quellcode, wenn es dienlich ist. Siehe <https://bugs.archlinux.org/> für nähere Anweisungen. libs/dimg/CMakeFiles/dimg_src.dir/build.make:2294: die Regel für Ziel „libs/dimg/CMakeFiles/dimg_src.dir/filters/greycstoration/greycstorationfilter.cpp.o“ scheiterte make[2]: *** [libs/dimg/CMakeFiles/dimg_src.dir/filters/greycstoration/greycstorationfilter.cpp.o] Fehler 4 make[2]: *** Datei „libs/dimg/CMakeFiles/dimg_src.dir/filters/greycstoration/greycstorationfilter.cpp.o“ wird gelöscht CMakeFiles/Makefile2:654: die Regel für Ziel „libs/dimg/CMakeFiles/dimg_src.dir/all“ scheiterte make[1]: *** [libs/dimg/CMakeFiles/dimg_src.dir/all] Fehler 2 Makefile:127: die Regel für Ziel „all“ scheiterte make: *** [all] Fehler 2 ==> FEHLER: Ein Fehler geschah in build(). Breche ab...

arojas commented on 2015-10-16 10:29 (UTC)

Merged in master

sl1pkn07 commented on 2015-06-07 10:53 (UTC)

why? only need reinstall the pakage

FadeMind commented on 2015-06-07 10:00 (UTC)

Please upgrade version to: 5.0.0.r32078.047dc1f

ior commented on 2015-03-15 18:47 (UTC)

Thank you, it works.

sl1pkn07 commented on 2015-03-15 15:13 (UTC)

sinply reinstall the package with yaourt or makepkg (or your favorite helper)

ior commented on 2015-03-15 15:10 (UTC)

I have install libkipi-frameworks-git r1101.26a6552-1 https://aur.archlinux.org/packages/libkipi-frameworks-git/ Where I can find new version?

sl1pkn07 commented on 2015-03-15 10:30 (UTC)

Sounds your libkipi is out of date. Please update it Greetings

ior commented on 2015-03-15 00:43 (UTC)

Compile error: [ 16%] Building CXX object utilities/kipiiface/CMakeFiles/kipiiface.dir/kipiinterface.cpp.o /tmp/yaourt-tmp-user/aur-digikam-frameworks-git/src/digikam/utilities/kipiiface/kipiinterface.cpp: In constructor ‘Digikam::KipiInterface::KipiInterface(QObject*, const QString&)’: /tmp/yaourt-tmp-user/aur-digikam-frameworks-git/src/digikam/utilities/kipiiface/kipiinterface.cpp:85:22: error: no matching function for call to ‘KIPI::Interface::Interface(QObject* const&, const QString&)’ d(new Private()) ^ /tmp/yaourt-tmp-user/aur-digikam-frameworks-git/src/digikam/utilities/kipiiface/kipiinterface.cpp:85:22: note: candidate is: In file included from /usr/include/KF5/KIPI/KIPI/Interface:1:0, from /tmp/yaourt-tmp-user/aur-digikam-frameworks-git/src/digikam/utilities/kipiiface/kipiinterface.h:39, from /tmp/yaourt-tmp-user/aur-digikam-frameworks-git/src/digikam/utilities/kipiiface/kipiinterface.cpp:26: /usr/include/KF5/KIPI/kipi/interface.h:159:14: note: KIPI::Interface::Interface(QObject*, const char*) explicit Interface(QObject* const parent, const char* name=0); ^ /usr/include/KF5/KIPI/kipi/interface.h:159:14: note: no known conversion for argument 2 from ‘const QString’ to ‘const char*’ utilities/kipiiface/CMakeFiles/kipiiface.dir/build.make:123: set di istruzioni per l'obiettivo "utilities/kipiiface/CMakeFiles/kipiiface.dir/kipiinterface.cpp.o" non riuscito make[2]: *** [utilities/kipiiface/CMakeFiles/kipiiface.dir/kipiinterface.cpp.o] Errore 1 CMakeFiles/Makefile2:3533: set di istruzioni per l'obiettivo "utilities/kipiiface/CMakeFiles/kipiiface.dir/all" non riuscito make[1]: *** [utilities/kipiiface/CMakeFiles/kipiiface.dir/all] Errore 2 Makefile:117: set di istruzioni per l'obiettivo "all" non riuscito make: *** [all] Errore 2

blackhole commented on 2015-03-10 13:04 (UTC)

New problem: -- checking for module 'lensfun' -- found lensfun, version 0.3.0.0 -- Found LensFun: /usr/include/lensfun (found version "0.3.0.0") -- liblensfun: Found version 0.3.0.0 (required: 0.2.6.0)

sl1pkn07 commented on 2015-03-08 00:44 (UTC)

yep. need fix in upstream

tajidinabd commented on 2015-03-08 00:29 (UTC)

CMake Error at CMakeLists.txt:313 (MACRO_BOOL_TO_01): Unknown CMake command "MACRO_BOOL_TO_01". -- Configuring incomplete, errors occurred! See also "/tmp/yaourt-tmp-tajidinabd/aur-digikam-frameworks-git/src/build/CMakeFiles/CMakeOutput.log". ==> ERROR: A failure occurred in build(). any idea how to fix this macro error

sl1pkn07 commented on 2015-02-01 19:43 (UTC)

see the bugreport comments greetings

tajidinabd commented on 2015-02-01 19:16 (UTC)

I get a build error right now in regards to the lensfuncameraselector reported upstream @ https://bugs.kde.org/show_bug.cgi?id=343662 Any ideas what is the problem here?

blackhole commented on 2015-01-15 15:40 (UTC)

Now is fine! Thank you

sl1pkn07 commented on 2015-01-15 14:51 (UTC)

@blackhole try now greetings

blackhole commented on 2015-01-15 11:08 (UTC)

But this package now is useless for the majority of users since qt5-multimedia is depending on gstreamer 0.10. I guess that disabling video in the compilation could fix this (personally I don't need it) Do you know how to change the PKGBUILD?

sl1pkn07 commented on 2015-01-14 23:24 (UTC)

sorry. i can't help with this. my system is gstreamer/vlc free (I have a own build qt5-webkit/qt5-multimedia without gstreamer) you can follow the bug progress in https://bugs.kde.org/show_bug.cgi?id=342607 like @anex has said greetings

blackhole commented on 2015-01-14 22:55 (UTC)

I have a lot of errors about GStreamer. My system is fully updated and I have phonon VLC as backend. ----------------- (digikam:17478): GLib-GObject-WARNING **: cannot register existing type 'GstObject' (digikam:17478): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed (digikam:17478): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed (digikam:17478): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed (digikam:17478): GStreamer-CRITICAL **: gst_element_class_set_details_simple: assertion 'GST_IS_ELEMENT_CLASS (klass)' failed (digikam:17478): GStreamer-WARNING **: static caps 0x7f42391cf650 string is NULL ecc. ecc.

sl1pkn07 commented on 2015-01-14 19:43 (UTC)

Works for me please paste the log when launch by console

blackhole commented on 2015-01-14 16:43 (UTC)

It compiled fine but starting hangs at "initializing main view"

sl1pkn07 commented on 2015-01-08 14:37 (UTC)

Sorry. I have no idea. I do not use gstreamer. My Qt5 copy (and other software) is compiled without gstreamer greetings

anex commented on 2015-01-08 08:08 (UTC)

@ sl1pkn07, any solution to this bug? https://bugs.kde.org/show_bug.cgi?id=342607

sl1pkn07 commented on 2015-01-03 18:04 (UTC)

change the version package (if dont show in updates. please reinstall) . and remove KHTML dependency

sl1pkn07 commented on 2014-12-29 21:26 (UTC)

libkgeomap i'ts not ready because need marble. and marble fails to build in kf5 https://bugs.kde.org/show_bug.cgi?id=342295 greetings

tajidinabd commented on 2014-12-29 21:25 (UTC)

have a question about the libkgeomap has this been ported to KF5 as of yet. I was searching around could not find a status for this library.

sl1pkn07 commented on 2014-12-29 19:03 (UTC)

yes. that file is provide by libkface. but you need the libkface-frameworks-git libkface from [extra] is only for kde4/qt4 make you sure have a latest commit of libkface-frameworks-git greetings

tajidinabd commented on 2014-12-29 18:53 (UTC)

well i try to build this file i get the following error In file included from /tmp/yaourt-tmp-tajidinabd/aur-digikam-frameworks-git/src/digikam/libs/widgets/mainview/daboutdata.cpp:41:0: /tmp/yaourt-tmp-tajidinabd/aur-digikam-frameworks-git/src/digikam/app/utils/componentsinfo.h:52:33: fatal error: recognitiondatabase.h: No such file or directory #include <recognitiondatabase.h> ^ compilation terminated. app/CMakeFiles/digikamcore.dir/build.make:4276: recipe for target 'app/CMakeFiles/digikamcore.dir/__/libs/widgets/mainview/daboutdata.cpp.o' failed make[2]: *** [app/CMakeFiles/digikamcore.dir/__/libs/widgets/mainview/daboutdata.cpp.o] Error 1 CMakeFiles/Makefile2:777: recipe for target 'app/CMakeFiles/digikamcore.dir/all' failed make[1]: *** [app/CMakeFiles/digikamcore.dir/all] Error 2 Makefile:117: recipe for target 'all' failed make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... for me looking around is there an issue with "libkface" perhaps on the right track?

sl1pkn07 commented on 2014-12-29 01:11 (UTC)

yes. i know (I talking about the problem to devs in the IRC) for that i disable baloo in the cmake options gretings

jeagoss commented on 2014-12-29 01:01 (UTC)

This package does not build against the latest baloo-git libraries. It is an upstream problem.

sl1pkn07 commented on 2014-12-29 00:46 (UTC)

oh XD fixed

jeagoss commented on 2014-12-28 23:50 (UTC)

As usual, your packages are making it into my repo. :)

jeagoss commented on 2014-12-28 23:50 (UTC)

makedepends is misspelled. It is currently makedepemds.

paulbarbee commented on 2012-12-14 23:15 (UTC)

I completely forgot I was using KDE 4.10. Thank you for noticing that! I searched for "digikam 4.10" and discovered a post on Arch's forums where someone couldn't get the digikam in the Extra repository to work because of libkdcraw. I re-installed libkdcraw-git and was able to re-install digikam-git without any problems.

Sevenseven commented on 2012-12-14 18:14 (UTC)

>Found KDE 4.10 maybe this? Successfully compiled with kde 4.9.4.

paulbarbee commented on 2012-12-14 05:31 (UTC)

I had trouble starting digikam today. It gave me the following message: "digikam: error while loading shared libraries: libgphoto2_port.so.0: cannot open shared object file: No such file or directory" I tried to reinstall digikam-git and it failed. I tried reinstalling all sources and reinstalling but it failed in the same place. I have copied my re-installation attempt at http://pastebin.com/kdNyEc4a I also tried building straight from git, which got a little farther in the make process. The patebin link to that attempt is http://pastebin.com/CR3TG1te Thank you!

Sevenseven commented on 2012-10-03 11:10 (UTC)

Install them manually or use any aur frontend.

Phlogiston commented on 2012-10-01 18:56 (UTC)

Looks like some additional deps are not there: ==> Missing Dependencies: -> libkipi-git -> libkexiv2-git -> libkdcraw-git -> libksane-git ==> Checking buildtime dependencies... ==> Missing Dependencies: -> libkgeomap-git -> libkvkontakte-git ==> ERROR: Could not resolve all dependencies. The build failed.

paulbarbee commented on 2012-06-11 21:36 (UTC)

I tried to install this package again today in order to get the full log, as per your suggestion, and it built fine. Thanks again for your time and efforts!

Sevenseven commented on 2012-06-11 13:40 (UTC)

Please, post a full log via pastebin.

paulbarbee commented on 2012-06-11 05:08 (UTC)

I tried that but now I get [ 24%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/threads/parallelworkers.o /tmp/packerbuild-1000/digikam-git/digikam-git/src/digikam/libs/threads/parallelworkers.cpp: In member function 'int Digikam::ParallelWorkers::replacementQtMetacall(QMetaObject::Call, int, void**)': /tmp/packerbuild-1000/digikam-git/digikam-git/src/digikam/libs/threads/parallelworkers.cpp:152:48: error: 'class QObject' has no member named 'mocMetaObject' make[2]: *** [digikam/CMakeFiles/digikamcore.dir/__/libs/threads/parallelworkers.o] Error 1 make[1]: *** [digikam/CMakeFiles/digikamcore.dir/all] Error 2 make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... It builds and makes fine when I build from git source according to the digikam instructions at http://www.digikam.org/drupal/download?q=download/GIT I find that very weird and don't understand why it happens. Thank you very much for your help and for your work in Arch!

Sevenseven commented on 2012-06-10 11:47 (UTC)

Update libkgeomap-git first.

paulbarbee commented on 2012-06-10 03:47 (UTC)

I tried to rebuild this package because it was looking for libmarblewidget.so.13. I get the following when trying to build: Linking CXX executable testlensfuniface /usr/bin/ld: warning: libmarblewidget.so.13, needed by /usr/lib/libkgeomap.so.1, not found (try using -rpath or -rpath-link) /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoPainter::autoMapQuality()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::fromLineString(Marble::GeoDataLineString const&)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::~GeoDataLatLonBox()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::east(Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::LayerInterface::~LayerInterface()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setMapThemeId(QString const&)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::north(Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::removeLayer(Marble::LayerInterface*)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::width(Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::addLayer(Marble::LayerInterface*)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::zoomOut(Marble::FlyToMode)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setShowScaleBar(bool)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::LayerInterface::zValue() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::projection() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::staticMetaObject' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::zoom() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::centerLongitude() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::centerOn(Marble::GeoDataCoordinates const&, bool)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setCenterLongitude(double, Marble::FlyToMode)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::setSouth(double, Marble::GeoDataCoordinates::Unit)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoPainter::drawPixmap(Marble::GeoDataCoordinates const&, QPixmap const&)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::geoCoordinates(int, int, double&, double&, Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonAltBox::~GeoDataLatLonAltBox()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::setEast(double, Marble::GeoDataCoordinates::Unit)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::west(Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLineString::GeoDataLineString(QFlags<Marble::TessellationFlag>)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoPainter::drawPixmap(int, int, QPixmap const&)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::maximumZoom() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::ViewportParams::viewLatLonAltBox() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::setWest(double, Marble::GeoDataCoordinates::Unit)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataCoordinates::~GeoDataCoordinates()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLinearRing::GeoDataLinearRing(QFlags<Marble::TessellationFlag>)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLineString::append(Marble::GeoDataCoordinates const&)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::zoomIn(Marble::FlyToMode)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::MarbleWidget(QWidget*)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::centerLatitude() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::centerOn(Marble::GeoDataLatLonBox const&, bool)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::screenCoordinates(double, double, double&, double&) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setShowCompass(bool)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLineString::~GeoDataLineString()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setShowOverviewMap(bool)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::south(Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::viewport()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setCenterLatitude(double, Marble::FlyToMode)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataCoordinates::GeoDataCoordinates(double, double, double, Marble::GeoDataCoordinates::Unit, int)' /usr/lib/libkgeomap.so.1: undefined reference to `typeinfo for Marble::LayerInterface' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::minimumZoom() const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoPainter::drawPolygon(Marble::GeoDataLinearRing const&, Qt::FillRule)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::setNorth(double, Marble::GeoDataCoordinates::Unit)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::setProjection(Marble::Projection)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLineString::operator<<(Marble::GeoDataCoordinates const&)' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLatLonBox::height(Marble::GeoDataCoordinates::Unit) const' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::GeoDataLinearRing::~GeoDataLinearRing()' /usr/lib/libkgeomap.so.1: undefined reference to `Marble::MarbleWidget::zoomView(int, Marble::FlyToMode)' collect2: error: ld returned 1 exit status make[2]: *** [libs/dimg/filters/lens/testlensfuniface] Error 1 make[1]: *** [libs/dimg/filters/lens/CMakeFiles/testlensfuniface.dir/all] Error 2 make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... The build failed.

Sevenseven commented on 2011-06-09 02:52 (UTC)

Updated.

agaida commented on 2011-06-08 16:04 (UTC)

Please add boost as dependency. Thanks. >-- Boost Graph library found................ NO >-- >CMake Error at CMakeLists.txt:92 (MESSAGE): > digiKam needs Boost Graph. You need to install the Boost Graph (headers only) library development package.

Sevenseven commented on 2011-05-21 01:47 (UTC)

Sorry, i am use yaourt.

Phlogiston commented on 2011-05-20 15:47 (UTC)

Thanks, and to update everything I simply do: packer -S kipi-plugins-git libkface-git libkmap-git digikam-git --noconfirm correct?

Sevenseven commented on 2011-05-07 01:34 (UTC)

Yes, just rebuild kdegraphics, here is pkgbuild http://pastebin.com/HmMrtNPu

Phlogiston commented on 2011-05-06 23:29 (UTC)

Is it possible to make this package and its dependencies non coflictable? :: kdegraphics-libs and libkdcraw-git are in conflict. Remove libkdcraw-git? [y/N] n I'd like to use gwenview with digikam-git ...

Sevenseven commented on 2011-03-14 01:30 (UTC)

Yes, i can

flamelab commented on 2011-03-13 19:20 (UTC)

Sevenseven, could you adopt it ? I have orphaned all of the digikam-git related packages.

Sevenseven commented on 2011-03-13 10:01 (UTC)

new ver, please test http://pastebin.com/paw31iBb

commented on 2011-02-21 22:20 (UTC)

@77: great, thanks! compiles, runs : )

Sevenseven commented on 2011-02-21 01:37 (UTC)

pkgbuild for 2.x, maybe they need some fix http://aur.pastebin.com/zfFTcVn5

Sevenseven commented on 2011-02-14 15:36 (UTC)

1.9

flamelab commented on 2011-02-14 15:14 (UTC)

Is master branch still 1.9 or have they passed to 2.x ? All kde stuff from git/svn ? Hehe.... XD

Sevenseven commented on 2011-02-14 15:04 (UTC)

Compiles fine from master branch( all kde`s stuf from git/svn).

flamelab commented on 2011-02-13 09:13 (UTC)

I have limited free time these days, I'll investigate this next week. If anybody finds something, please report it here :)

commented on 2011-02-12 21:11 (UTC)

Does not compile with kdegraphics 4.6.0, also fails with aur-package kdegraphics-libs-digikam2-svn, with a similar message as reported by skarn. Hints?

skarn commented on 2011-02-07 21:10 (UTC)

Trying to build results in drawdecoding.cpp:229:5: error: ‘const class KDcrawIface::RawDecodingSettings’ has no member named ‘NRType’ drawdecoding.cpp:229:5: error: ‘class KDcrawIface::RawDecodingSettings’ has no member named ‘NRType’ and a couple dozen similar messages, alla missing fileds in libkdcraw. Perhaps it needs a newer version than the one included in kdegraphics-libs?

flamelab commented on 2011-02-07 13:01 (UTC)

It's been fixed, I had the updated PKGBUILD ready but hadn't uploaded it yet. If we need any missing dependency, please tell me !

Sevenseven commented on 2011-02-07 07:45 (UTC)

kipi-plugins-svn removed from aur, use kipi-plugins-git

overmind88 commented on 2011-02-07 04:46 (UTC)

Maybe change kipi-plugins-svn to kipi-plugins-git?