Package Details: dilay 1.9.0-1

Git Clone URL: https://aur.archlinux.org/dilay.git (read-only, click to copy)
Package Base: dilay
Description: A 3D sculpting application that provides an intuitive workflow using a number of powerful modeling tool
Upstream URL: http://abau.org/dilay/index.html
Licenses: GPL
Submitter: ShadowKyogre
Maintainer: bitwave
Last Packager: bitwave
Votes: 6
Popularity: 0.000000
First Submitted: 2016-01-08 21:13 (UTC)
Last Updated: 2018-10-10 10:39 (UTC)

Required by (0)

Sources (1)

Latest Comments

seany commented on 2017-08-26 12:51 (UTC)

In order to use this, you will need this PKGBUILD : # Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com> pkgname=dilay pkgver=1.5.0 pkgrel=1 pkgdesc="A 3D sculpting application that provides an intuitive workflow using a number of powerful modeling too$ arch=('i686' 'x86_64') url="http://abau.org/dilay/index.html" license=('GPL') makedepends=('gendesk') depends=('glm' 'qt5-base') source=("$pkgname-$pkgver.tar.gz::https://github.com/abau/dilay/archive/${pkgver}.tar.gz" finalize.patch index-octree.patch index-octree-hpp.patch) prepare() { gendesk -f -n --pkgname "$dilay" --pkgdesc "$pkgdesc" cd "$srcdir/$pkgname-$pkgver" patch lib/src/index-octree.hpp "${srcdir}/index-octree-hpp.patch" patch lib/src/index-octree.cpp "${srcdir}/index-octree.patch" patch lib/src/action/finalize.cpp "${srcdir}/finalize.patch" } build() { cd "$srcdir/$pkgname-$pkgver" qmake-qt5 -r PREFIX="${pkgdir}/usr" make release } package() { cd "$srcdir/$pkgname-$pkgver" make install install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" install -Dm644 logoBg.svg "$pkgdir/usr/share/pixmaps/$pkgname.svg" } sha1sums=('3a70e84d46313c2b348262b06d8b9cb0655f0d93' '070c68dcc3dedb63b52337d717c73a15dfb551e6' '92f7e3eff8da9dfc1a66703b80a190f8f8d4b6ec') The patches are : Finalize.patch: --- src/dilay-1.5.0/lib/src/action/finalize.cpp 2016-04-10 10:31:58.000000000 +0200 +++ finalize.cpp 2017-08-26 14:31:07.942989594 +0200 @@ -2,6 +2,8 @@ * Copyright © 2015,2016 Alexander Bau * Use and redistribute under the terms of the GNU General Public License */ + +#include <functional> #include "action/finalize.hpp" #include "affected-faces.hpp" #include "index-octree.hpp" index-octree.patch GNU nano 2.8.6 Datei: index-octree.patch --- src/dilay-1.5.0/lib/src/index-octree.cpp 2016-04-10 10:31:58.000000000 +0200 +++ index-octree.cpp 2017-08-26 14:31:36.849397552 +0200 @@ -2,6 +2,8 @@ * Copyright © 2015,2016 Alexander Bau * Use and redistribute under the terms of the GNU General Public License */ + +#include <functional> #include <glm/glm.hpp> #include <array> #include <iostream> and index-octree-hpp.patch --- src/dilay-1.5.0/lib/src/index-octree.hpp 2016-04-10 10:31:58.000000000 +0200 +++ index-octree.hpp 2017-08-26 14:31:54.771304481 +0200 @@ -5,6 +5,7 @@ #ifndef DILAY_INDEX_OCTREE #define DILAY_INDEX_OCTREE +#include <functional> #include <glm/fwd.hpp> #include <vector> #include "macro.hpp"

StuckUpCreations commented on 2016-06-20 11:03 (UTC)

fixed by reinstalling my video drivers.. thank you..

StuckUpCreations commented on 2016-06-20 10:23 (UTC)

now im getting a diferent error... /usr/sbin/ld: cannot find -lGL collect2: error: ld returned 1 exit status make[2]: *** [Makefile.Release:209: ../../dilay-1.5.0/dilay] Error 1 make[1]: *** [Makefile:38: release] Error 2 make: *** [Makefile:429: sub-app-release] Error 2

ShadowKyogre commented on 2016-06-15 00:19 (UTC)

@RastaManKing: Updated to 1.5.0. Try rebuilding it.

StuckUpCreations commented on 2016-06-02 23:44 (UTC)

i get the following error: Makefile.Release:853: recipe for target 'obj/src/opengl.o' failed make[2]: *** [obj/src/opengl.o] Error 1 Makefile:38: recipe for target 'release' failed make[1]: *** [release] Error 2 Makefile:351: recipe for target 'sub-lib-release' failed make: *** [sub-lib-release] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build dilay.

ShadowKyogre commented on 2016-02-16 19:06 (UTC)

@swyter: Durp, yeah, it is. I'll also update it for the release you notified me of.

swyter commented on 2016-02-16 14:38 (UTC) (edited on 2016-02-16 15:48 (UTC) by swyter)

Is `gendesk` missing as a make dependency? Also, looks like there's a new version: 2016/02/14 Dilay 1.4.0 release * Added configuration dialog * Added graphics-tablet support (pressure sensitive sculpting tools)