Package Details: discord-canary 0.0.84-1

Git Clone URL: https://aur.archlinux.org/discord-canary.git (read-only)
Package Base: discord-canary
Description: All-in-one voice and text chat for gamers that's free and secure.
Upstream URL: https://discordapp.com/
Keywords: chat voice voip
Licenses: custom
Provides: discord
Submitter: cazzar
Maintainer: Morganamilo (pezz, E5ten, parkerlreed)
Last Packager: parkerlreed
Votes: 136
Popularity: 3.701972
First Submitted: 2016-03-25 06:20
Last Updated: 2019-06-20 21:37

Pinned Comments

Morganamilo commented on 2018-05-01 19:54

Please report issues with Discord itself to https://discord.gg/discord-testers or https://discord.gg/discord-linux.

Report any issues relating to the AUR package here.

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

cazzar commented on 2017-05-17 10:52

If you're going to provide an out-of-date, please provide a new URL

Anonymous comment on 2017-04-30 09:26

I found the key I needed in my previous comment @cazzar

gpg --recv-keys 0FC3042E345AD05D

cazzar commented on 2017-04-30 07:25

Unflagged namely because the current download urls point to the download

https://discordapp.com/api/download/canary?platform=linux&format=tar.gz
version 0.0.17 does not exist by manual URI modification.

Anonymous comment on 2017-04-28 00:58

tried to install the package but there's some unknown public keys:

==> Verifying source file signatures with gpg...
llvm-4.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D)
libcxx-4.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D)
libcxxabi-4.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D)

Terence commented on 2017-02-11 17:50

As @DarkShadow44 said, you have to install those packages outside of the AUR helper dependency cycle.
Using pacaur, you can do:

gpg --recv-keys 8F0871F202119294 # import libc++ gpg signature
pacaur -Sa libc++ # will also install libc++abi
pacaur -Sa discord-canary # dependencies satisfied, no problem during installation and launch

cazzar commented on 2017-02-07 15:21

Read the previous comments then.

And also obviously the issue lies outside of this package. Unless the libc++ dependency was dropped in 0.0.15

Fruggle commented on 2017-02-07 14:49

@cazzar it doesn't for me it gets stuck on libc++

cazzar commented on 2017-02-07 02:25

I don't believe that it doesn't install via yaourt @Fruggle, and 0.0.15 is the latest.
https://gist.github.com/a830dfd8d78233dfeeed0133ee31ca93

I would suggest providing logs.

Fruggle commented on 2017-02-07 00:53

The package doesn't work with yaourt or makepkg with the snapshot. I guess I need to keep using it on the desktop until someone makes a solid package.

DarkShadow44 commented on 2017-02-05 15:41

@lunixer Install them manually

Quote from libc++ and libc++abi:
> IMPORTANT: Many AUR helpers probably won't be able to help you with this package as they can't cope with the bootstrap dependency structure. It is recommended you stick with the basics when building this, id est use makepkg without arguments and install with pacman -U.