Package Details: diskmonitor 0.3.4-1

Git Clone URL: https://aur.archlinux.org/diskmonitor.git (read-only, click to copy)
Package Base: diskmonitor
Description: KDE tools to monitor SMART devices and MDRaid health status
Upstream URL: https://github.com/papylhomme/diskmonitor
Licenses: GPL2
Conflicts: diskmonitor
Provides: diskmonitor
Submitter: None
Maintainer: papylhomme
Last Packager: papylhomme
Votes: 28
Popularity: 0.000882
First Submitted: 2006-09-01 10:20 (UTC)
Last Updated: 2020-06-01 17:35 (UTC)

Latest Comments

1 2 Next › Last »

pdf commented on 2017-01-25 01:53 (UTC) (edited on 2017-01-25 01:56 (UTC) by pdf)

.SRCINFO is outdated: http://pastebin.com/QE1r7TaJ

papylhomme commented on 2017-01-14 10:21 (UTC)

Hello, can you reproduce this problem ? I just reinstalled it without any issue, but I admit my latest Arch update is long overdue :D I'll update the whole system and try it again

promike commented on 2016-12-29 22:35 (UTC)

Hello! There seems to be a little problem with SRCINFO: :: diskmonitor package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD. If they match (or the .SRCINFO is missing), the package can be installed

papylhomme commented on 2015-08-22 19:22 (UTC)

I forgot about this tool :D - Added knotifications and kxmlgui as dependencies. - qt5-declarative is required by the plasmoid, so I left it out as it will always pull plasma-framework. - udisks2 is the backend providing info. Their is no binary link to it as it is accessed via DBus. This time with package version bump !

sl1pkn07 commented on 2015-08-22 19:19 (UTC)

without adding explicity plasma-framework └───╼ namcap diskmonitor-0.3.1-1-x86_64.pkg.tar.xz diskmonitor E: Dependency qt5-declarative detected and not included (libraries ['usr/lib/libQt5Qml.so.5'] needed in files ['usr/lib/qt/qml/org/papylhomme/diskmonitor/libdiskmonitor_qmlplugins.so']) diskmonitor E: Dependency knotifications detected and not included (libraries ['usr/lib/libKF5Notifications.so.5'] needed in files ['usr/lib/qt/qml/org/papylhomme/diskmonitor/libdiskmonitor_qmlplugins.so']) diskmonitor E: Dependency kxmlgui detected and not included (libraries ['usr/lib/libKF5XmlGui.so.5'] needed in files ['usr/bin/diskmonitor']) diskmonitor W: Dependency included and not needed ('udisks2') NOTE: with add plasma-framework in depends, also say udisk2 not need. this is problem of namcap because no search call executables into libs or scripts

papylhomme commented on 2015-08-22 18:03 (UTC)

Hello and thanks, you're right, I certainly shouldn't depend on kdelibs, I fixed it. Regarding the other dependencies being pulled by plasma-framework, the diskmonitor GUI application depends on them explicitly, I prefer to keep them and not to rely on plasma-framework dependencies. Can you test the new PKGBUILD and report if this is working for you ?

sl1pkn07 commented on 2015-08-22 13:31 (UTC)

are you sure needs kdelibs? kdelibs is a qt4/kde4 program and I've test the pkgbuild, only needs: depends=('udisks2' 'plasma-framework') and makedepends=('cmake' 'extra-cmake-modules' 'git' 'python') the rest of depends is pulled by plasma-framework package greetings