Package Details: dive 0.9.2-1

Git Clone URL: https://aur.archlinux.org/dive.git (read-only, click to copy)
Package Base: dive
Description: A tool for exploring each layer in a docker image
Upstream URL: https://github.com/wagoodman/dive
Keywords: docker
Licenses: MIT
Conflicts: dive-git
Submitter: starkers
Maintainer: dbirks
Last Packager: dbirks
Votes: 14
Popularity: 0.135328
First Submitted: 2018-10-31 22:13
Last Updated: 2020-02-10 14:31

Latest Comments

1 2 3 Next › Last »

dbirks commented on 2020-01-10 15:21

@masterkorp

flag provided but not defined: -trimpath

Could you double-check that you're on Go 1.13?

masterkorp commented on 2020-01-10 14:51

I cannot build this: ==> Making package: dive 0.9.1-1 (sex 10 jan 2020 14:47:42 WET) ==> Retrieving sources... -> Downloading dive-0.9.1.tar.gz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 122 0 122 0 0 232 0 --:--:-- --:--:-- --:--:-- 231 100 2791k 0 2791k 0 0 1304k 0 --:--:-- 0:00:02 --:--:-- 4451k ==> Validating source files with sha256sums... dive-0.9.1.tar.gz ... Passed ==> Making package: dive 0.9.1-1 (sex 10 jan 2020 14:47:45 WET) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found dive-0.9.1.tar.gz ==> Validating source files with sha256sums... dive-0.9.1.tar.gz ... Passed ==> Removing existing $srcdir/ directory... ==> Extracting sources... -> Extracting dive-0.9.1.tar.gz with bsdtar ==> Sources are ready. ==> Making package: dive 0.9.1-1 (sex 10 jan 2020 14:47:46 WET) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> WARNING: Using existing $srcdir/ tree ==> Starting build()... flag provided but not defined: -trimpath usage: go build [-o output] [-i] [build flags] [packages] Run 'go help build' for details. ==> ERROR: A failure occurred in build(). Aborting... Error making: dive

JoeCool commented on 2019-09-24 13:36

Upstream is up-to-date now and so is this package.


old:

Last Updated: 2019-09-07 16:45

Yes, the AUR package hasn't been updated yet.

If you build <https://github.com/wagoodman/dive/archive/master.tar.gz> manually it will install correctly. There is no tagged upstream release that fixes it yet.

The Makefile and dist path was changed so you need to either make build instead of go build now or provide an output dir.

quick and dirty patch: https://gist.github.com/clst/a7e766ee1d91ef787fe12fadf4f2d351 only use if you know what you are doing

petrbel commented on 2019-09-24 12:08

@starkers it doesn't seem to fixed (tried right now):

go: github.com/docker/distribution@v0.0.0-20181126153310-93e082742a009850ac46962150b2f652a822c5ff: invalid pseudo-version: revision is longer than canonical (93e082742a00)

starkers commented on 2019-09-18 15:26

@Thrilleratplay yes.. looks like this is fixed now

https://github.com/chenrui333/dive/blob/f48715d4c536fdaf0ec57277f2677e4ed8076ad3/go.mod#L58

Thrilleratplay commented on 2019-09-16 12:16

I believe this pending PR is relevant to the error we are all getting with Go 1.13

https://github.com/wagoodman/dive/pull/227

mlamm commented on 2019-09-16 08:17

Same here, compiling with go 1.13.

Building via yaourt and also manually cloning the project from github failed for me with:

github.com/go-critic/go-critic@v0.0.0-20181204210945-1df300866540: invalid pseudo-version: does not match version-control timestamp (2019-05-26T07:48:19Z)

Afterwards, I looked for any ~/.go, ~/go directories, nuked them all, now I am getting the same error as in https://aur.archlinux.org/packages/dive/#comment-707166

starkers commented on 2019-09-12 11:34

Just a thought.. I'm on a fresh arch install right now.. and I had no luck replicating the issue.. so I can only assume its down to local config somehow?

dive seems to have a go.mod which is good.. ...could it be as simple as ensuring that we export GO111MODULE=on in build() ?

I'm not entirely sure if peoples local GOPATH could be used by the build but maybe just ensuring that GO111MODULE is on would help some users?

lotia commented on 2019-09-12 07:18

This may well be due to a transitive dependency failing to compile with go 1.13. Would be good to see if people experiencing this problem are also compiling with go 1.13.

The following github issue about golangci-lint may be of use since that was the error I was seeing when attempting to update dive. dive depends on golangci-lint which in turn depends on go-critic.

https://github.com/golangci/golangci-lint/issues/659

JoeCool commented on 2019-09-11 23:46

I am getting a different error when trying to upgrade from 0.7.2-1 ==> 0.8.1-1

==> Starting build()...
go: github.com/golangci/golangci-lint@v1.17.1 requires
github.com/go-critic/go-critic@v0.0.0-20181204210945-1df300866540: invalid pseudo-version: does not match version-control timestamp (2019-05-26T07:48:19Z)
==> ERROR: A failure occurred in build().
Aborting...