Package Details: dlangide 0.8.5-2

Git Clone URL: https://aur.archlinux.org/dlangide.git (read-only)
Package Base: dlangide
Description: D language IDE based on DlangUI
Upstream URL: https://github.com/buggins/dlangide
Keywords: dlang ide
Licenses: BSL
Groups: dlang
Submitter: geov
Maintainer: geov
Last Packager: geov
Votes: 6
Popularity: 0.002253
First Submitted: 2016-09-22 20:53
Last Updated: 2018-01-06 18:17

Latest Comments

geov commented on 2019-03-17 14:24

I'm waiting for this bug to be fixed upstream actually.

tastyminerals commented on 2019-03-14 17:34

Fails to build

/home/pavel/.dub/packages/emsi_containers-0.8.0-alpha.12/emsi_containers/src/containers/unrolledlist.d(568,29): Error: cannot implicitly convert expression ~this.registry of type const(ulong) to immutable(uint)
/usr/bin/dmd failed with exit code 1.
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build dlangide-git.
==> Restart building dlangide-git ? [y/N]

geov commented on 2017-06-30 11:50

Thanks to Majora320. I've changed build configuration.

Majora320 commented on 2017-06-29 16:16

I noticed that the PKGBUILD builds in debug configuration (the default). It should build in release mode by appending (IIRC) `--build=release` to the dub line in build().