Package Details: docker-bin 17.11.0-1

Git Clone URL: https://aur.archlinux.org/docker-bin.git (read-only)
Package Base: docker-bin
Description: Pack, ship and run any application as a lightweight container, using official binaries
Upstream URL: https://www.docker.com/
Licenses: Apache
Conflicts: docker, docker-ce, docker-git
Provides: docker, docker-ce
Submitter: javmorin
Maintainer: javmorin
Last Packager: javmorin
Votes: 7
Popularity: 0.461112
First Submitted: 2016-08-18 18:48
Last Updated: 2017-11-21 10:06

Required by (55)

Sources (3)

Pinned Comments

javmorin commented on 2017-11-21 18:57

(From the release docs)

IMPORTANT: Docker CE 17.11 is the first Docker release based on containerd 1.0 beta.

Docker CE 17.11 and later won't recognize containers started with previous Docker versions. If using Live Restore, you must stop all containers before upgrading to Docker CE 17.11. If you don't, any containers started by Docker versions that predate 17.11 won't be recognized by Docker after the upgrade and will keep running, un-managed, on the system.

Latest Comments

javmorin commented on 2017-11-27 23:40

@daenney I appreciate the note, but the commit you referenced is part of the moby core (https://github.com/moby/moby) cleanup. The manpages are now part of (and built from) the cli sub-project (https://github.com/docker/cli) which was factored out of the moby core project several months ago.

The manpages should still build properly with the PKGBUILD. To verify this, I just wiped my build cache and rebuilt the current PKGBUILD and encountered no errors.

If you are still seeing errors after wiping your local build tree, can you send me a gist link with the actual log output so I can try and triage?

Edited: to correct moby link

daenney commented on 2017-11-27 23:02

17.11.0-1 is broken. In commit https://github.com/moby/moby/commit/2b45ec7f786bc91d6db42bd33c13e28a06d30aa3#diff-b67911656ef5d18c4ae36cb6741b7965 support for manpages was removed. Though it's still listed as a phony target in the Makefile the call to make manpages in the PKGBUILD makes it fail.

javmorin commented on 2017-11-21 18:57

(From the release docs)

IMPORTANT: Docker CE 17.11 is the first Docker release based on containerd 1.0 beta.

Docker CE 17.11 and later won't recognize containers started with previous Docker versions. If using Live Restore, you must stop all containers before upgrading to Docker CE 17.11. If you don't, any containers started by Docker versions that predate 17.11 won't be recognized by Docker after the upgrade and will keep running, un-managed, on the system.

javmorin commented on 2017-03-02 17:11

Notice: As docker has changed the naming format of their releases, this package may be changing along with it. It is my intention to follow the lead of the Community docker package. I will also provide a stable and edge variant.

I do not intend to provide docker EE packages as I do not (at present) have access to them.

I will add comments here as things develop.

Update: (2017-03-12) -- After discussions with @seblu, the current plan is to stick with "docker" as the package name. We will review stable vs edge packaging after docker releases discreet versions. For now expect docker and docker-bin to follow the docker edge release cycle.

qwivan commented on 2017-02-11 23:39

'docker' should be add into conflicts, not just provides.

javmorin commented on 2017-02-06 06:27

@jtyr this package just wraps what docker provides in their package. That warning must have been added recently, but as I run overlay myself, I had not encountered it. I don't intend to alter the provided docker service though as I am trying to keep it all "as delivered". Good to note the issue here. I believe that the other storage backends (overlay, zfs, btrfs, etc.) all should work with the docker-provided binaries.

Hopefully upstream adjusts their default option to one without a warning in the future.

UPDATE: As of 1.13.1 (https://github.com/docker/docker/releases/tag/v1.13.1) docker prefers overlay2 or overlay storage backends (depending on which is available) over devicemapper

jtyr commented on 2017-02-06 02:24

I had to add "-s overlay2" into the ExecStart in /usr/lib/systemd/system/docker.service to make it working. Otherwise it was complaining that devicemapper cannot be used with statically linked binary.

javmorin commented on 2017-01-29 01:12

@staaas Good call. I have done this and pushed it as 1.13.0-2

staaas commented on 2017-01-28 11:46

I think it makes sense to add `provides=('docker')` to PKGBUILD, otherwise it's impossible to install community/docker-compose or aur/docker-compose-bin together with this package.