Package Details: docker-stable-bin 18.06.0-1

Git Clone URL: https://aur.archlinux.org/docker-stable-bin.git (read-only)
Package Base: docker-stable-bin
Description: Pack, ship and run any application as a lightweight container, using official binaries
Upstream URL: https://www.docker.com/
Licenses: Apache
Conflicts: docker, docker-bin, docker-ce, docker-git
Provides: docker, docker-bin, docker-ce
Submitter: javmorin
Maintainer: javmorin
Last Packager: javmorin
Votes: 1
Popularity: 0.037533
First Submitted: 2017-04-11 21:31
Last Updated: 2018-07-19 22:42

Required by (70)

Sources (3)

Pinned Comments

javmorin commented on 2017-12-28 19:01

IMPORTANT: You must stop all containers and plugins BEFORE upgrading to Docker CE 17.12.

Docker CE 17.12 and later won't recognize containers started with previous Docker versions. If using Live Restore, you must stop all containers before upgrading to Docker CE 17.12. If you don't, any containers started by Docker versions that predate 17.12 won't be recognized by Docker after the upgrade and will keep running, un-managed, on the system.

See https://github.com/moby/moby/pull/35812 for details

Latest Comments

javmorin commented on 2018-03-05 19:04

@kevlar1818 I don't see why not. I will have to do a bit of research on that from both the packaging side (including verifying component availability in Arch Linux ARM) as well as any architecture translations (since the only arch specifically matching is aarch64). If you have any knowledge on that last bit, please pass it along.

kevlar1818 commented on 2018-03-05 18:31

Could this be generalized to accept any architecture provided here?

https://download.docker.com/linux/static/

I'd like to use this package on Arch Linux ARM.

javmorin commented on 2017-12-28 19:01

IMPORTANT: You must stop all containers and plugins BEFORE upgrading to Docker CE 17.12.

Docker CE 17.12 and later won't recognize containers started with previous Docker versions. If using Live Restore, you must stop all containers before upgrading to Docker CE 17.12. If you don't, any containers started by Docker versions that predate 17.12 won't be recognized by Docker after the upgrade and will keep running, un-managed, on the system.

See https://github.com/moby/moby/pull/35812 for details