Package Details: dockerfile-language-server 0.12.0-1

Git Clone URL: https://aur.archlinux.org/dockerfile-language-server.git (read-only, click to copy)
Package Base: dockerfile-language-server
Description: Language server for Dockerfiles
Upstream URL: https://github.com/rcjsuen/dockerfile-language-server-nodejs
Keywords: docker Dockerfile langserv language-server LSP
Licenses: MIT
Replaces: dockerfile-language-server-bin, nodejs-dockerfile-language-server-nodejs
Submitter: lmartinez-mirror
Maintainer: neoninteger
Last Packager: neoninteger
Votes: 8
Popularity: 0.000160
First Submitted: 2021-06-20 06:51 (UTC)
Last Updated: 2024-05-24 10:47 (UTC)

Latest Comments

neoninteger commented on 2023-06-20 23:22 (UTC)

I've increased the verbosity of GitHub notifications for this repository, so I shouldn't miss future updates. Thanks for flagging!

lmartinez-mirror commented on 2021-06-20 15:52 (UTC)

Yes it would, since it's effectively replacing it. I'll add it shortly.

languitar commented on 2021-06-20 09:24 (UTC)

Would it make sense to add a replaces statement for my -bin version in this PKGBUILD?

ouuan commented on 2021-06-19 12:59 (UTC)

There was a bug in one of the official packages causing the inclusion of dev files in all sorts of node packages. Please update your system and rebuild the affected packages.

It's not a bug. It's a breaking change in npm 7.

Please remove --user root and add chown -R root:root "${pkgdir}" instead. Since npm 7, the --user option is no longer available. --user root not only doesn't fix the permission problem, but also installs the package named "root", which conflicts with other packages that also have the --user root option.

asmz commented on 2021-04-19 17:17 (UTC) (edited on 2021-04-19 17:28 (UTC) by asmz)

@languitar Thank you for the advice, that truly came at lightning speed. :)

Sadly I couldn't make it work - my system is up-to-date, i uninstalled the packages and made sure the associated node module (root) was removed as well. Upon reinstall of the packages (clean build) there's still the same clashing files.

No biggie though - I'll just remove the sql-langserver (numerous deprecated modules and open security issues).

languitar commented on 2021-04-18 17:31 (UTC)

@asmz There was a bug in one of the official packages causing the inclusion of dev files in all sorts of node packages. Please update your system and rebuild the affected packages.

asmz commented on 2021-04-18 17:22 (UTC) (edited on 2021-04-18 17:29 (UTC) by asmz)

I'm experiencing issues installing this package because of a module called root seems to be owned by sql-language-server, yet dockerfile-language-server-bin also wants to install it (possibly in another version?).

The err msg is as follows (for all files): dockerfile-language-server-bin: /usr/lib/node_modules/root/package.json exists in filesystem (owned by sql-language-server)

Any ideas how to properly resolve this?

sum01 commented on 2020-05-11 06:21 (UTC)

You might want to add a replaces('nodejs-docker-langserver') or something like that. It'll help migrate people who had the other package installed.

radmen commented on 2020-04-24 18:16 (UTC)

@languitar: you're completely right! I've sent the request to merge this package with the one mentioned by you. Thanks!

languitar commented on 2020-04-24 15:09 (UTC)

Isn't this a duplicate of https://aur.archlinux.org/packages/dockerfile-language-server-bin/