Package Details: dogecoin-daemon 1.10.0-5

Git Clone URL: https://aur.archlinux.org/dogecoin-daemon.git (read-only)
Package Base: dogecoin-daemon
Description: Dogecoin is a peer-to-peer network based digital currency - daemon
Upstream URL: http://dogecoin.com/
Keywords: cryptocurrency dogecoin moon
Licenses: MIT
Conflicts: dogecoin-qt
Submitter: acerix
Maintainer: acerix
Last Packager: acerix
Votes: 13
Popularity: 0.000000
First Submitted: 2014-01-01 23:04
Last Updated: 2018-04-02 16:19

Latest Comments

acerix commented on 2018-04-02 16:21

How is libressl a dependency? That is an "EXPERIMENTAL" package in AUR and the latest stable release of dogecoin (1.10) seems to need openssl 1.0 to compile, otherwise I get "configure: error: Detected LibreSSL: This is NOT supported, and may break consensus compatibility!".

muhviehstarr commented on 2018-04-02 11:15

add libressl to depends

mmozeiko commented on 2015-10-07 05:24

Makes sense. Thanks.

acerix commented on 2015-10-06 23:22

Thanks, I suggested the patch upstream: https://github.com/dogecoin/dogecoin/issues/1292

For this package though, I changed it to compile without UPNP as I'm pretty sure anyone using this daemon doesn't actually want automatic port forwarding.

mmozeiko commented on 2015-10-05 05:24

After miniupnpc upgrade to 1.9.20150730-1 version follwing patch is needed to compile source: https://github.com/bitcoin/bitcoin/commit/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch

2mac commented on 2014-04-09 15:27

Tried starting with `dogecoind` but was never able to access the server.

spudospard commented on 2014-02-28 17:10

Good job acerix, thank you

acerix commented on 2014-02-06 01:09

This is based on litecoin-daemon and I didn't spend time fiddling with it, but I just I tried your suggestions.

I got the following error after removing boost, so I left that in:

/dogecoin-master-1.5/src/leveldb/helpers -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
alert.cpp:8:53: fatal error: boost/algorithm/string/classification.hpp: No such file or directory

It seems fine with the other two removed, so I updated the PKGBUILD.

Thanks for the optimizations!

Dtgr commented on 2014-02-05 07:53

automoc4 should not be in makedepends. It introduces redundant qt4 dependency. I suspect boost and qrencode could be removed from makedepends as well as my system told that they're no longer required by any package.

Zucca commented on 2014-01-21 15:50

Ah. Thank you. :)

All comments