Package Details: dolfin-git 20180212-1

Git Clone URL: https://aur.archlinux.org/dolfin-git.git (read-only)
Package Base: dolfin-git
Description: the C++ interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations.
Upstream URL: https://bitbucket.org/fenics-project/dolfin
Licenses: GPL3
Groups: fenics-git
Submitter: myles
Maintainer: heitzmann
Last Packager: heitzmann
Votes: 7
Popularity: 0.000000
First Submitted: 2013-03-22 22:40
Last Updated: 2018-02-15 18:15

Dependencies (10)

Required by (1)

Sources (1)

Latest Comments

heitzmann commented on 2018-02-24 11:38

I've dug both petsc and slepc from their repos and activated them back again.

heitzmann commented on 2018-02-23 16:23

I wonder that as well... you can still find petsc-maint, but there is currently no package providing slepc.

chawlindel commented on 2018-02-23 15:28

Does anyone know why the petsc package isn't in AUR anymore?

myles commented on 2017-12-20 18:55

Its yours

heitzmann commented on 2017-12-20 15:41

Myles, I'm splitting the dolfin package into a C++-only and the Python interfaces. I'd like to use this package name (dolfin-git) for the C++ interface, since it looks like you haven't been updating it.

Do you mind adding me as a maintainer? (Or, if you prefer, disown the package so I can claim it?)

Thanks!

heitzmann commented on 2016-11-18 13:52

For anyone interested, I've just submitted updated versions of all fenics packages (dolfin, mshr, ffc, ufl, fiat, instant, dijitso) for python 3 under the names python-*-git.

I could not get dolfin to compile with VTK support, so that is missing in the current PKGBUILD.

heitzmann commented on 2015-11-19 19:21

videan42 is right, python2-sympy is the correct dependency.
There's also a new one missing: gl2ps from extra.

videan42 commented on 2015-11-11 23:01

I just ran into the same problem as Calucinho and it looks like the script needs `python2-sympy` to be installed to generate the form files. I think this should be the dependency and not `python-sympy`? Once I fixed that, everything built fine.

ftschindler commented on 2015-11-05 11:22

Recently, I get the following error:
```
make[2]: *** No rule to make target '/usr/lib64/libgl2ps.so', needed by 'dolfin/libdolfin.so.1.7.0dev'. Stop.
```
which I could resolve by installing `gl2ps`. This should perhaps become an additional (make) dependency...

Calucinho commented on 2015-11-03 14:37

Hi Myles, I still cannot build dolfin-git from your AUR package. Could you have a look at the log files from my previous comment?

All comments