Package Details: domoticz-latest 3.8153-3

Git Clone URL: https://aur.archlinux.org/domoticz-latest.git (read-only)
Package Base: domoticz-latest
Description: Web based home automation
Upstream URL: http://www.domoticz.com
Keywords: domotic
Licenses: GPL
Conflicts: domoticz, domoticz-beta, domoticz-git, domoticz-svn
Submitter: saez0pub
Maintainer: saez0pub
Last Packager: saez0pub
Votes: 5
Popularity: 0.713272
First Submitted: 2017-05-03 19:38
Last Updated: 2017-09-30 19:56

Latest Comments

hexadecagram commented on 2017-10-01 05:07

I am using pacmatic, which in turn, uses pacaur and cower.

I am still seeing the same error with domoticz-latest:

:: Installing domoticz-latest package(s)...
:: domoticz-latest package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

And yet again, domoticz-git builds just fine.

However, if I rm -fR ~/.cache/pacaur/domoticz-latest and run pacmatic again, it installs without a hitch!

saez0pub commented on 2017-09-30 19:53

Hello,

Sorry, I haven't seen your comment sooner.
The SRCINFO was at the same version. It's maybe the tool you're using, with makepkg or yaourt, it works.
I updated the minor version for testing, can you retry ?

domoticz-git is building from the sources from the last version on guthub.
domoticz compiles the last stable version.
domoticz-beta downloads the last version precompiled sources of the beta version from domoticz web site.
domoticz-latest downloads the last version precompiled sources of the stable version from domoticz web site.


I made domoticz-beta and domoticz-latest because I install this on raspberry pi and the compilationj is too long. So I switched to a precompiled version.

hexadecagram commented on 2017-08-13 01:01

When attempting to install, I get this:

:: Checking domoticz-latest integrity...
:: Building domoticz-latest package(s)...
:: Installing domoticz-latest package(s)...
:: domoticz-latest package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD:: ensure package name has a VCS suffix if this is a devel package

I switched to domoticz-git, which built and installed successfully. Which AUR backage should I be using? domoticz-latest or domoticz-git?

blahbla77 commented on 2017-08-06 14:26

Yes, it works now. Thanks

saez0pub commented on 2017-08-03 21:27

I've updated the version.
The systemd unit script has been updated, it was unconsitent because type was forking and daemon option was set.
I was issuing PID file problems
I've removed the daemon option.
@blahbla77, maybe it was your problem.

saez0pub commented on 2017-08-01 20:07

Hello,

Can you try this :
LD_PRELOAD=/usr/lib/libcurl.so.3 /opt/domoticz/domoticz

It seems that you are not using the systemd script which have 'LD_PRELOAD=/usr/lib/libcurl.so.3' in the environment.

blahbla77 commented on 2017-07-31 09:35

Domoticz keep restarting, getting these in log:
/opt/domoticz/domoticz: /usr/lib/libcurl.so.3: no version information available (required by /opt/domoticz/domoticz)
Domoticz is starting up....
Domoticz running...
Domoticz is exiting...

I have this installed: community/libcurl-compat 7.54.1-1 [installed]

saez0pub commented on 2017-05-03 19:42

You are right, I've request a merge of this package to domoticz-latest.

I'm building domoticz on raspberry pi, the building from source is a pain on this little plateform, so I'm using the compiled version from the official site, it is already compiled and faster to install.

uffe commented on 2017-04-30 14:27

BTW: domoticz release archive is found here:

https://github.com/domoticz/domoticz/releases/

uffe commented on 2017-04-30 13:56

This PKGBUILD is a kind of flawed.

You are building latest release - not a fixed version -
Either you should fix to a version or rename the package to domoticz-latest.

Thanks

All comments