Package Details: dontstarve july21-1

Git Clone URL: (read-only)
Package Base: dontstarve
Description: An open world survival video game.
Upstream URL:
Keywords: game humblebundle
Licenses: custom
Submitter: hobarrera
Maintainer: hobarrera
Last Packager: hobarrera
Votes: 6
Popularity: 0.125595
First Submitted: 2013-08-06 21:59
Last Updated: 2015-08-10 19:51

Dependencies (0)

Required by (0)

Sources (4)

Latest Comments

postblue commented on 2016-07-06 08:51

Having this error when compiling curl :(

../lib/.libs/ undefined reference to `SSLv3_client_method'

gcc version 6.1.1 20160602 (GCC)

mythmon commented on 2015-08-10 16:36

Using a hib:// protocol and suggesting users use DLAGENT is nicer than "https://download-it-manually" which fails with more cryptic error messages.

Here is a diff that should apply to the PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index 2120ffb..dbcd2a3 100644
@@ -10,7 +10,7 @@ arch=("i686" "x86_64")
@@ -19,6 +19,8 @@ md5sums=('20907561ae855bb08d919c59d18b2a82'
+# Add a warning if DLAGENT isn't set up correctly.
+DLAGENTS+=("hib::/usr/bin/echo Could not find %u. Manually download it to '$(pwd)', or set up a hib:// DLAGENT in /etc/makepkg.conf. Hint: try aur/hib-dlagent.")

build() {
cd "$srcdir/curl-${_curlver}"

wenLiangcan commented on 2014-05-30 19:04

@hobarrera Got the same error :(

hobarrera commented on 2014-05-30 18:56

@wenLiangcan: Odd. Can you try running:
cd /opt/dontstarve/bin && LD_LIBRARY_PATH=/opt/dontstarve/bin/lib64 dontstarve

wenLiangcan commented on 2014-05-30 18:19

@hobarrera I'm upgraded from 1383879308. Before the upgrading, the program is running correctly.

hobarrera commented on 2014-05-30 17:55

@wenLiangcan: Uhm... that's REALLY wierd, since the PKGBUILD is building the correct version of libcurl to avoid this. Are you sure you're not running some pre-existing installation?

wenLiangcan commented on 2014-05-29 04:19

Failed to start the game:

$ dontstarve
./dontstarve: ./lib64/ version `CURL_OPENSSL_3' not found (required by ./dontstarve)

hobarrera commented on 2014-05-28 16:21

Sorry for the huge delay these last couple of updates. Game updated and working fine now! :)

hobarrera commented on 2014-01-08 18:50

@mirandir: Can you provide the entire error. Is that when starting the game? My system if perfectly up-to-date, and I just rebuilt and ran this package and it worked fine.

@maxmin: Steps 2 to 4 are innecesary. I don't understand what you mean by step 5, since you can install the package from any location.

maxmin commented on 2014-01-06 14:10

And if you get a segfault when running it, maybe try the gcc version 4.8.2-6.

All comments