Package Details: doom3-data 1.3.1.1304-4

Git Clone URL: https://aur.archlinux.org/doom3-data.git (read-only)
Package Base: doom3-data
Description: Doom 3 patch data files; not the full game!
Upstream URL: http://www.idsoftware.com/
Licenses: custom
Submitter: chungy
Maintainer: chungy
Last Packager: chungy
Votes: 10
Popularity: 0.849042
First Submitted: 2012-06-09 22:31
Last Updated: 2015-10-11 13:14

Latest Comments

Gently commented on 2014-04-11 20:36

Rebuilt.

Ok, I thinks its done. Followed your thoughts and here is what I got:

Change log:

2014-04-11 Gently <toddrpartridge@gmail.com>

* 1.3.1.1304-4 :
ChangeLog added
Retail game files added
URL changed to id software ftp
Links for legacy /opt/doom3/ packages
Description-comment more verbosed
rm'd icon - belongs to regular package

Download: https://drive.google.com/file/d/0B-3Ad-VEtVXFZFFLTk9GVDM2aWs/edit?usp=sharing

appreciate the tips, this, i think, is about ready to go.

Gently commented on 2014-04-08 14:35

Thanks for the, response today, chungy.

As to your thoughts, I think they are all very knowledgeable.

Additionally:

1. Why is the comment changed to note being for the original closed...

: I had this thought... "brewing" in my thoughts for a bit now and the rbdoom3-bfg-git package build reminded me the desire to get it done However, I made this package build before I know about that it had been done by you... here. As regards to the note for the closed source, that was my bad. it should be listed as open as it comes from git, even in the aur/doom3 version... regards.

2. Why is the version set to 1.0?

: Guess. :) Because they are the original data files, that is probably the version they belong.

. Why not include the update...

: Thats a good thought. I hadn't originally because they are already in the aur/doom3 package build.

4. Why put it in /opt?

: Legacy and... too many other doom3packages/"mod builds" have been done. To be reasonable all the package and mod builds would have to be altered. Additionally, for reasoning, the aur/doom3 package has files: /opt/doom3/{base,d3xp}/game01.pk4, the directory would need to be link and I am unable to see how this could be done.

chungy commented on 2014-04-08 00:00



I'm confused by what your purposes with your changes are:

1. Why is the comment changed to note being for the original closed source Doom 3 engine? This one was really made primarily for the open source ones, although I have no objection at all for the original engine to depending on it.
2. Why is the version set to 1.0?
3. Why not include the update files?
4. Why put it in /opt? If the proprietary engine requires looking in a directory there, its package could have symlink. (On this note, moving it to /usr/share/games/doom3 is most sensible, the only problem I have is affecting downstream packages...)

Automating the installation of the non-redistributable files is something that definitely would be nice, but I opted against it because of all the ways that there are to get Doom 3. Could definitely include your script, though.

chungy commented on 2014-04-07 23:58

I'm confused by what your purposes with your changes are:

1. Why is the comment changed to note being for the original closed source Doom 3 engine? This one was really made primarily for the open source ones, although I have no objection at all for the original engine to depending on it.
2. Why is the version set to 1.0?
3. Why not include the update files?

Automating the installation of the non-redistributable files is something that definitely would be nice, but I opted against it because of all the ways that there are to get Doom 3. Could definitely include your script, though.

Gently commented on 2014-04-07 11:38

Hello.

I've had time to rebuild this lately and I was hoping that it could be downloaded. I noted that the newdoom3 pkgbuild i built will need it too:

https://aur.archlinux.org/packages/doom3/

doom3-data | https://drive.google.com/file/d/0B-3Ad-VEtVXFZGJRdjFrd3dVc0U/edit?usp=sharing | doom3-data-1.0-1.src.tar.gz