Package Details: dot-bin 87.0-0

Git Clone URL: https://aur.archlinux.org/dot-bin.git (read-only, click to copy)
Package Base: dot-bin
Description: Dot Browser is a privacy-conscious web browser based on Firefox. (Binary)
Upstream URL: https://github.com/dothq/browser
Licenses: MPL-2.0
Conflicts: dot, dot-git
Provides: dot
Replaces: dot
Submitter: dothq
Maintainer: jackspade
Last Packager: jackspade
Votes: 4
Popularity: 0.000448
First Submitted: 2021-04-18 15:02 (UTC)
Last Updated: 2021-10-11 07:36 (UTC)

Dependencies (12)

Required by (0)

Sources (3)

Latest Comments

Pound_Hash commented on 2022-01-27 20:40 (UTC)

Build failed:

curl: (47) Maximum (50) redirects followed
==> ERROR: Failure while downloading https://download.dothq.co/dot/releases/linux/x86/raw
    Aborting...
Build failed with exit code 1 in /home/alan/.cache/rua/build/dot-bin

Alireza commented on 2021-10-30 07:02 (UTC) (edited on 2021-10-30 07:04 (UTC) by Alireza)

dot-bin: /usr/bin/dot exists in filesystem (owned by graphviz)

========
Oh, I just saw your comment.... Thanks in advance

jackspade commented on 2021-10-26 23:17 (UTC)

I'm working towards a name change. The planned new name is "dot-browser". I'll push a new package soon and submit a request for this one to be merged into the new one.

ABotelho commented on 2021-10-21 02:48 (UTC)

Are there plans to rename this package? It still conflicts with graphviz. I also echo SeerLite for the new name to be "dot-browser".

jackspade commented on 2021-10-11 07:37 (UTC)

New maintainer here! PKGBUILD has been updated and SHA256 integrity checks have been added. Thanks for the report!

afontenot commented on 2021-10-11 02:53 (UTC) (edited on 2021-10-11 02:57 (UTC) by afontenot)

Edit: didn't notice that this package had been disowned, but if someone adopts it, please take the following into account.

The version numbering for this package is very badly behaved, perhaps even enough so to be grounds for removal from the AUR. Please fix it.

Specifically, you're not using the real version numbers, just a fake placeholder "0.1" and downloading whatever happens to be the latest binary from the dot website and skipping checksums for no good reason. You need to be downloading a specific version (if possible), preferably using the actual release numbering, and adding a checksum for that specific release to the PKGBUILD.

See https://wiki.archlinux.org/title/Arch_package_guidelines for more.

Downloading the latest version of a package without a version update is only acceptable for -git AUR packages, and only then when there are not changes to the dependencies or build process.

iontunnel commented on 2021-07-20 07:35 (UTC)

I echo SeerLite.

SeerLite commented on 2021-05-30 03:24 (UTC)

Binary name conflicts with package graphviz.

dot-bin: /usr/bin/dot exists in filesystem (owned by graphviz)

graphviz is required by gimp, so I think it's a good idea to rename the browser binary to something like dot-browser