Package Details: dotnet-runtime-preview 5.0.0+100+rc.2.20479.15-2

Git Clone URL: https://aur.archlinux.org/dotnet-core-preview.git (read-only, click to copy)
Package Base: dotnet-core-preview
Description: The .NET Core runtime (preview, binary)
Upstream URL: https://www.microsoft.com/net/core
Licenses: MIT
Conflicts: dotnet-runtime=5.0.0
Provides: dotnet-runtime=5.0.0, dotnet-runtime-5.0
Submitter: fmauNeko
Maintainer: fmauNeko
Last Packager: fmauNeko
Votes: 6
Popularity: 0.000269
First Submitted: 2018-12-05 14:21
Last Updated: 2020-10-15 07:23

Required by (34)

Sources (3)

Latest Comments

1 2 3 Next › Last »

xhyinne commented on 2020-10-29 21:09

Interesting, because when I try to build and run a dotnet project (targeting net5.0) with this package it complains about no matching runtime being found; when I use the non-preview dotnet package (project targeting netcoreapp3.1) it works fine as expected. Any idea why?

fmauNeko commented on 2020-10-29 08:31

Your issue cannot come from that, because the binaries are prebuilt, and those version numbers (which are correct, build numbers are almost always mismatched between SDK and Runtime, and I've even seen a mismatched Runtime and Host version once).

You can check the version numbers at https://dotnet.microsoft.com/download/dotnet/5.0 .

Plus, those fields are only used for packaging purpose, and are used in patch names in the binary distribution from Microsoft, so if I change them, you'll get empty packages.

xhyinne commented on 2020-10-29 02:04

It looks like the runtime and sdk versions are mismatched:

pkgver=5.0.0+100+rc.2.20479.15 _hostver=5.0.0-rc.2.20475.5 _runtimever=5.0.0-rc.2.20475.5 _sdkver=5.0.100-rc.2.20479.15

This causes the SDK to register as 5.0.0+100+rc.2.20479.15, and the runtime as 5.0.0-rc.2.20475.5, despite using 5.0.100-rc.2.20479.15 for all the source packages. When trying to run an application, dotnet complains about not being able to find a matching runtime, and I traced it down to this mismatch. Could you update the hostver and runtimever to match the pkgver and sdkver, which is also the same as the version in the sources?

fmauNeko commented on 2020-09-23 08:37

@ofrades that's a community repo package (https://www.archlinux.org/packages/community/x86_64/netstandard-targeting-pack/).

3.1.8 has been released 10 days ago, sync your repos and retry ;)

ofrades commented on 2020-09-23 08:17

Getting errors retrieving files from mirrors:

:: Retrieving packages... error: failed retrieving file 'netstandard-targeting-pack-3.1.7.sdk107-1-x86_64.pkg.tar.zst' from . . .

fmauNeko commented on 2020-06-22 11:45

@LiteracyFanatic I already had it fixed, but forgot to push. It's solved with the -3 version! Thanks :)

LiteracyFanatic commented on 2020-06-22 11:16

The package fails to install with the following error message:

yay -S dotnet-sdk-preview
 -> Could not find all required packages:
    dotnet-sdk=3.1 (Wanted by: dotnet-sdk-preview)

It seems to be caused by a minor typo which is resolved by this patch.

From fb4894b49e33e65f5cfee98f45f1f250bc2c60c0 Mon Sep 17 00:00:00 2001
From: Jordan Cannon <LiteracyFanatic@gmail.com>
Date: Mon, 22 Jun 2020 05:53:17 -0500
Subject: [PATCH] Fix typo in dotnet-sdk-3.1 dependency

---
 .SRCINFO | 2 +-
 PKGBUILD | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index 03c5a47..4df3e0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -51,7 +51,7 @@ pkgname = dotnet-runtime-preview

 pkgname = dotnet-sdk-preview
    pkgdesc = The .NET Core SDK (preview, binary)
-   depends = dotnet-sdk=3.1
+   depends = dotnet-sdk-3.1
    depends = dotnet-runtime-preview
    depends = glibc
    provides = dotnet-sdk-preview
diff --git a/PKGBUILD b/PKGBUILD
index 7c67bb1..b16ea1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,7 +61,7 @@ package_aspnet-runtime-preview() {

 package_dotnet-sdk-preview() {
   pkgdesc='The .NET Core SDK (preview, binary)'
-  depends=('dotnet-sdk=3.1' 'dotnet-runtime-preview' 'glibc')
+  depends=('dotnet-sdk-3.1' 'dotnet-runtime-preview' 'glibc')
   provides=("dotnet-sdk-preview" "dotnet-sdk=${_sdkver%-*}" "dotnet-sdk-5.0")
   conflicts=("dotnet-sdk-preview" "dotnet-sdk=${_sdkver%-*}" "dotnet-sdk-5.0")

-- 
2.27.0

The most recent commit message says that the change was intended to allow a side-by-side installation with the 3.1 SDK. That's definitely a good thing, but does this package really need to depend on the the 3.1 SDK? Isn't changing from /opt/ to /usr/share/ enough to make a side-by-side installation with dotnet-sdk work?

twainilicious commented on 2020-06-06 08:47

Could you please update this to .NET 5 Preview 4? Thanks a bunch!

selplacei commented on 2019-12-08 07:34

This should be marked as conflicting with community/dotnet-sdk-bin. Easier to answer yes to yay's request to remove it instead of deleting it manually after installation fails.

ShalokShalom commented on 2019-11-14 20:50

I report that the search function of AUR seems to miss this package.

Tested with the current versions of both Firefox and Falkon.

The URL/page itself is obviously working.