Package Details: dovecot2-antispam-hg 51-1

Git Clone URL: https://aur.archlinux.org/dovecot2-antispam-hg.git (read-only)
Package Base: dovecot2-antispam-hg
Description: Integrates DSPAM into dovecot IMAP server. Mercurial Version for dovecot >= 2.1
Upstream URL: http://hg.dovecot.org/dovecot-antispam-plugin/
Licenses: GPL
Conflicts: dovecot-antispam
Submitter: seiichiro0185
Maintainer: seiichiro0185
Last Packager: teekay
Votes: 9
Popularity: 0.000000
First Submitted: 2011-01-18 20:13
Last Updated: 2015-07-28 21:29

Dependencies (2)

Required by (0)

Sources (0)

Pinned Comments

seiichiro0185 commented on 2017-04-25 04:16

Since the Mercurial repository used in this PKGBUILD seems to be down, you can use the git build from here: https://aur.archlinux.org/packages/dovecot2-antispam-git/

Latest Comments

1 2 Next › Last »

post-factum commented on 2017-04-26 19:59

https://wiki2.dovecot.org/Plugins/Antispam is deprecated

Use https://wiki2.dovecot.org/HowTo/AntispamWithSieve

Latest src works, however, and is available here: https://dovecot.org/tmp/dovecot-antispam-plugin-final.tbz2

teekay commented on 2017-04-25 07:02

Yeah, the hg version is DEPRECATED

seiichiro0185 commented on 2017-04-25 04:16

Since the Mercurial repository used in this PKGBUILD seems to be down, you can use the git build from here: https://aur.archlinux.org/packages/dovecot2-antispam-git/

andriesinfoserv commented on 2014-11-02 04:38

I knew i was forgetting something! :) thanks for the help and for maintaining this essential package.

seiichiro0185 commented on 2014-11-01 09:19

@andriesinfoserv: The Plugin is only compatible with the version of dovecot it was compiled against, which means you'll have to recompile the plugin for every new version of dovecot.

Unfortunately I can't do anything against this, since this is how the dovecot-plugins work..

andriesinfoserv commented on 2014-10-31 05:18

doesn't seem to be compat with dovecot 2.2.15.1.

imap: Error: Module is for different ABI version 2.2.ABIv13(2.2.13) (we have 2.2.ABIv15(2.2.15)): /usr/lib/dovecot/modules/lib90_antispam_plugin.so
Oct 30 23:48:37 mail.mailserver.org dovecot[346]: imap: Fatal: Couldn't load required plugins

thanks in advance

seiichiro0185 commented on 2013-05-20 16:53

You are right, that was meant for the version which goes into my repository. The binaries are only compatible with a specific version of dovecot. But for the AUR-Package which is compiled anyways that's not necessary. I changed the PKGBUILD now

teekay commented on 2013-05-20 16:40

why did you set the depend to <2.2.2?
It works fine with dovecot-2.2.2-1 here

seiichiro0185 commented on 2013-05-15 06:11

I updated the PKGBUILD for the current version of dovecot.

aclindsa commented on 2013-05-14 15:48

The current 'hg clone' line in the PKGBUILD fails on my machine with:
"==> Connecting to Mercurial server....
abort: 'http://hg.dovecot.org/' does not appear to be an hg repository:"

If you change it to the following, it succeeds:
hg clone "${_hgroot}${_hgrepo}"