Package Details: dreampie 1.2.1-1

Git Clone URL: https://aur.archlinux.org/dreampie.git (read-only)
Package Base: dreampie
Description: A Python shell which is designed to be reliable and fun.
Upstream URL: http://dreampie.org
Licenses: GPL
Submitter: keenerd
Maintainer: keenerd
Last Packager: keenerd
Votes: 38
Popularity: 0.000023
First Submitted: 2010-02-21 16:39
Last Updated: 2015-06-13 04:12

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

Stunts commented on 2012-11-15 16:08

When using dreampie with python3 I cannot import some modules such as Biopython (Bio), numpy or matplotlib.
Importing works if the interpreter is started from IDLE, or is using python2.
Can anyone confirm this, or is it just a local config issue?
Thanks.

jmb commented on 2012-11-02 11:09

The source line should be changed to the following:
source=($pkgname-$pkgver.tar.gz::https://github.com/noamraph/dreampie/tarball/$pkgver)

This ensures that the tarball will be renamed to dreampie-1.2.1.tar.gz once downloaded. For those of us who keep a cached copy of the sources for all the packages we build, this avoids conflicts between packages that have the same version numbers.

Stunts commented on 2012-10-22 13:31

I could be wrong with this, but I don't think you have to.
Dreampie is written in python2. When using it for python3 it is just providing an interface for the python3 interpreter (it can also be used for pypy or jython or whatever else you want).
In order to follow Arch's naming guidelines it should remain "dreampie" (as it is a program, not a library).
Just my 2 eurocents. =-)

keenerd commented on 2012-10-22 13:11

Sorry about the delay. I've been trying to figure out the least painful way to provide a python3 version and fit Arch's new python naming guidelines. I'm leaning towards 'dreampie' (python3 version) and 'dreampie-py2'.

Stunts commented on 2012-10-22 12:47

Updated PKGBUILD here:
https://gist.github.com/3931335

Works with python3 too and no need for patches. =-)

keenerd commented on 2011-04-06 12:41

Fair enough, I did not know they supported py3k. Patch added.

keenerd commented on 2011-04-06 12:41

Fair enough, I did not know they supported py3k. Patch added.

Stunts commented on 2011-04-01 17:03

Hi, I'm a stubborn guy so I kept poking at my knee.
Now it doesn't hurt any more. Here's what I did:
sed -i 's/sys.setdefaultencoding('utf-8')/import platform\nif not "3.2" in platform.python_version():\n sys.setdefaultencoding('utf-8')/' /usr/share/dreampie/subp_main.py
Care to add it to your PKGBUILD?
Thanks.

Stunts commented on 2011-03-01 16:35

Actually according to their page:
"Supports Python 2.5, 2.6, 2.7, Jython 2.5, IronPython 2.6 and Python 3.1."
Although I've just noticed we have switched to python 3.2 in arch...
Guess the differences from 3.1 to 3.2 are somewhat significant after all...
But I loled at your comment keenerd. =-)

keenerd commented on 2011-03-01 16:06

"Doc, it hurts when I poke my knee."
"Well then stop poking it."

If Dreampie does not support python3, then that is not really "broken" :-)

All comments