Package Details: drivesync 1.4.0-2

Git Clone URL: https://aur.archlinux.org/drivesync.git (read-only, click to copy)
Package Base: drivesync
Description: Google Drive synchronization for Linux
Upstream URL: https://github.com/MStadlmeier/drivesync
Licenses: MIT
Submitter: marcoscarpetta
Maintainer: XBars93
Last Packager: XBars93
Votes: 2
Popularity: 0.000000
First Submitted: 2018-01-10 11:48 (UTC)
Last Updated: 2019-05-05 16:18 (UTC)

Latest Comments

kde35 commented on 2022-04-21 15:30 (UTC)

And, trying to rebuild fails with the same error message as in the comment by Munzu

kde35 commented on 2022-04-21 15:28 (UTC)

It used to work, but it stopped working, probably after my updating ruby. I get

<internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require': /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/mime-types-3.1/lib/mime/types/logger.rb:28: _1 is reserved for numbered parameter (SyntaxError) /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/mime-types-3.1/lib/mime/types/logger.rb:28: _2 is reserved for numbered parameter /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/mime-types-3.1/lib/mime/types/logger.rb:28: _3 is reserved for numbered parameter from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/mime-types-3.1/lib/mime/types.rb:226:in <top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/mime-types-3.1/lib/mime-types.rb:1:in<top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/google-api-client-0.23.4/lib/google/apis/core/upload.rb:21:in <top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/google-api-client-0.23.4/lib/google/apis/core/batch.rb:30:in<top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/google-api-client-0.23.4/lib/google/apis/core/base_service.rb:19:in <top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/google-api-client-0.23.4/generated/google/apis/drive_v3/service.rb:15:in<top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire' from /usr/share/drivesync/vendor/bundle/ruby/2.6.0/gems/google-api-client-0.23.4/generated/google/apis/drive_v3.rb:15:in <top (required)>' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:160:inrequire' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:160:in rescue in require' from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:149:inrequire' from /usr/share/drivesync/src/synchronizer.rb:1:in <top (required)>' from /usr/share/drivesync/drivesync.rb:1:inrequire_relative' from /usr/share/drivesync/drivesync.rb:1:in <main>' <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:inrequire': cannot load such file -- google/apis/drive_v3 (LoadError) from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in require' from /usr/share/drivesync/src/synchronizer.rb:1:in<top (required)>' from /usr/share/drivesync/drivesync.rb:1:in require_relative' from /usr/share/drivesync/drivesync.rb:1:in<main>'

Munzu commented on 2021-05-17 13:33 (UTC)

The installation fails for me. I get the following error message:

google-api-client-0.23.4 requires ruby version ~> 2.0, which is incompatible with the current version,
ruby 3.0.1p64
==> ERROR: A failure occurred in build().
    Aborting...
:: Packages failed to build: drivesync-1.4.0-2

BobDschingis commented on 2019-12-15 11:56 (UTC)

@t.langlois Same here - follwed the link and got the same message like t.langlois had. On github it seems, that the maintainer is aware of this problem: https://github.com/MStadlmeier/drivesync/issues/29

t.langlois commented on 2019-12-08 14:38 (UTC)

Hi, I could build the package but after running drivesync the first time, when I enter the URL to grant permission I get the following error:

Sign in with Google temporarily disabled for this app This app has not been verified yet by Google in order to use Google Sign In.

How can I solve this ?

fernandocv commented on 2019-02-08 18:42 (UTC)

Problem building it!

==> Error: Could not find all required packages: ruby<2.6.0 (Wanted by: drivesync)

Can you solve it?

thomasaiman commented on 2019-01-21 00:16 (UTC)

Is the ruby<2.6.0 dependency still necessary? Ruby 2.6 is now officially out

TAAPAye commented on 2018-04-17 19:28 (UTC)

I keep getting the error: /usr/share/drivesync/src/drive_manager.rb:151:in block in folder_with_name': undefined methodfirst' for nil:NilClass (NoMethodError) after a few files sync. Not familar with ruby but I assume its a simple fix since the actual syncing goes through.

For anyone with the same problem: while ! drivesync; do sleep 1s; done to keep trying after errors