Package Details: drumgizmo 0.9.11-1

Git Clone URL: https://aur.archlinux.org/drumgizmo.git (read-only)
Package Base: drumgizmo
Description: an open source cross-platform drum plugin and stand-alone application (lv2)
Upstream URL: http://www.drumgizmo.org
Licenses: GPL
Groups: lv2-plugins
Submitter: sekret
Maintainer: sekret
Last Packager: sekret
Votes: 6
Popularity: 0.851690
First Submitted: 2016-02-08 11:55
Last Updated: 2016-10-31 20:11

Latest Comments

funkmuscle commented on 2016-10-29 20:07

0.9.11 is out

http://www.drumgizmo.org/wiki/

sekret commented on 2016-09-22 17:58

When I add zita-resampler, namcap says

drumgizmo W: Dependency zita-resampler included but already satisfied

So I removed it :) In fact, zita-resampler is a dependency of jack

$ pacman -Si jack | grep Depends
Depends On : libsamplerate db zita-alsa-pcmi zita-resampler


HOWEVER, it is no dependency of jack2. So I changed the dependency jack to jack2 and got this

configure: WARNING: *** Building resample support!
configure: error: *** zita-resampler library or headers not found. Set ZITA_LDFLAGS or ZITA_CPPFLAGS to add searchpath.

So thanks @goldpaw for pointing this out, I wouldn't have discovered this issue by myself!


I'll update as soon as possible. You won't believe it, but my ISP doesn't allow me to commit my changes here. I fucking hate it! I cannot update my own webpage via ftp because of this crap ... I can only do it via tethering through my mobile ...
rant off ...

goldpaw commented on 2016-09-21 15:22

zita-resampler is a dependency and should be listed here.

sekret commented on 2016-08-15 13:30

Hey guys, please excuse my terribly slow reaction! I didn't have time back then in june and simply forgot about this. I'll take a look on all my packages asap!

I'm willing to add the --enable-vst option, thanks for requesting it :)

BUT it doesn't build here!

make[2]: *** No rule to make target '/public.sdk/source/vst2.x//audioeffectx.cpp', needed by 'libvstsdk_la-audioeffectx.lo'. Stop.
make[2]: Leaving directory '/build/drumgizmo/src/drumgizmo-0.9.10/plugin'
make[1]: *** [Makefile:434: all-recursive] Error 1
make[1]: Leaving directory '/build/drumgizmo/src/drumgizmo-0.9.10'
make: *** [Makefile:365: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Looks like I'm missing something ... I never built vst plugins ... I installed the steinberg-vst36 package, but it doesn't help.

funkmuscle commented on 2016-06-17 20:11

yes, is it possible to add the linux vst version too? The devs said we should have both when I was doing some testing to fix the issue with version 9.9. They said sometimes the lv2 may work while the vst won't or the other way around. helps with narrowing down issues.

bunyi commented on 2016-04-05 16:07

Please add also vst version of the plugin.

funkmuscle commented on 2016-03-27 00:13

I've started an IRC chat about this so the boys are looking into it. we're at it again tomorrow as I'm testing for them.

eduardomezencio commented on 2016-03-26 19:17

I already know what is wrong.. it's not your fault. Upstream bug.
In 0.9.9, when the jack sample rate is different from the drum kit sample rate, there will be no sound. It's a bug and the developers are aware of it. Maybe it would be better to keep this package in 0.9.8.1 while we have this problem?

sekret commented on 2016-03-26 16:31

Hey guys, thanks for the notification! I only built it, the build process ran fine, so I updated. I haven't had the chance to test it yet, but since now there are two users with problems this seems like a real issue.

I'll look into it! Or does one of you guys already have an idea what's wrong? According to the release notes this version comes with major rewrites, so it's very likely that it's a bug. I'll contact the authors as soon as I tested it myself.

eduardomezencio commented on 2016-03-26 15:56

I also get no sound after updating

All comments