Package Details: dualsub-git v1.0.0.r28.g26d11c2-1

Git Clone URL: https://aur.archlinux.org/dualsub-git.git (read-only)
Package Base: dualsub-git
Description: tool for merging and translating subtitles
Upstream URL: https://github.com/bonigarcia/dualsub
Licenses: GPL-3
Submitter: jose1711
Maintainer: jose1711
Last Packager: jose1711
Votes: 1
Popularity: 0.000000
First Submitted: 2014-06-18 20:46
Last Updated: 2017-01-24 20:55

Latest Comments

jose1711 commented on 2017-01-24 20:56

fixed but please do not use update flag for broken pkgbuilds. thanks

simgunz commented on 2017-01-24 13:40

I had to remvoe the word SNAPSHOT to make it compile.

Angel_Caido commented on 2015-09-08 16:15

This package wasn't compiling for me. I had to modify the package() section in the PKBUILD to make it work.
This is how the package() section should look like:

package() {
cd ${srcdir}/${pkgname}
install -Dm755 ./target/dualsub-1.1.0-SNAPSHOT-jar-with-dependencies.jar ${pkgdir}/usr/share/java/dualsub/dualsub.jar
install -D -m644 $srcdir/dualsub.png $pkgdir/usr/share/pixmaps/dualsub.png
install -D -m644 $srcdir/dualsub.desktop $pkgdir/usr/share/applications/dualsub.desktop
mkdir -p -m755 ${pkgdir}/usr/bin
echo -e "#!/bin/sh
java -jar /usr/share/java/dualsub/dualsub.jar" > $pkgdir/usr/bin/dualsub
chmod 755 ${pkgdir}/usr/bin/dualsub
}

Angel_Caido commented on 2015-09-08 16:14

This package wasn't compiling for me. I had to modify the package() section in the PKBUILD to make it work.
This is how mine looks like:

<b>package() {
cd ${srcdir}/${pkgname}
install -Dm755 ./target/dualsub-1.1.0-SNAPSHOT-jar-with-dependencies.jar ${pkgdir}/usr/share/java/dualsub/dualsub.jar
install -D -m644 $srcdir/dualsub.png $pkgdir/usr/share/pixmaps/dualsub.png
install -D -m644 $srcdir/dualsub.desktop $pkgdir/usr/share/applications/dualsub.desktop
mkdir -p -m755 ${pkgdir}/usr/bin
echo -e "#!/bin/sh
java -jar /usr/share/java/dualsub/dualsub.jar" > $pkgdir/usr/bin/dualsub
chmod 755 ${pkgdir}/usr/bin/dualsub
}
</b>