Package Details: dummynet 20130607-10

Git Clone URL: https://aur.archlinux.org/dummynet.git (read-only)
Package Base: dummynet
Description: A live network emulation tool, originally designed for testing networking protocols, and since then used for a variety of applications including bandwidth management.
Upstream URL: http://info.iet.unipi.it/~luigi/dummynet/
Licenses: BSD
Submitter: said
Maintainer: gamanakis
Last Packager: gamanakis
Votes: 3
Popularity: 0.004191
First Submitted: 2013-01-25 16:58
Last Updated: 2015-09-28 17:52

Latest Comments

gamanakis commented on 2015-07-17 17:23

Since linux-4.1.2 there is a problem with the ipv6.h dependency of inet_hashtables.h and it doesn't compile.

gamanakis commented on 2015-01-20 13:44

dummynet-lts as separate package submitted

gamanakis commented on 2015-01-20 13:12

I updated the PGKBUILD file so that the extramodules directory is handled better.
It is recommended to install manually, without using "yaourt".
1) cower -d dummynet
2) cd dummynet; makepkg
3) pacman -U *.pkg.tar.xz

gamanakis commented on 2015-01-20 13:10

I updated the PGKBUILD file.
It is recommended to install manually, without using "yaourt".
1) cower -d dummynet
2) cd dummynet; makepkg
3) pacman -U *.pkg.tar.xz

gamanakis commented on 2015-01-19 17:59

Because the package consists of a userland-utility and a kernel-module please avoid yaourt and install manually. Use cower to download and extract the tarball with "cower -d dummynet", then use "makepkg -s", and install with "pacman -U *pkg.tar.xz".

/usr/lib/modules/extramodules-`uname -r`/ipfw_mod.ko is not a standard directory in Archlinux.

gamanakis commented on 2015-01-19 17:58

Because the package consists of a userland-utility and a kernel-module please avoid yaourt and install manually. Use cower to download and extract the tarball, then use "makepkg -s", and install with "pacman -U *pkg.tar.xz".

/usr/lib/modules/extramodules-`uname -r`/ipfw_mod.ko is not a standard directory in Archlinux.

emctoo commented on 2015-01-19 16:06

try to install with yaourt, get error in last step:

...
error: failed to commit transaction (conflicting files)
dummynet: /usr/lib/modules/3.18.2-2-ARCH/extramodules exists in filesystem
Errors occurred, no packages were upgraded.

Maybe fail to install /usr/lib/modules/3.18.2-2-ARCH/extramodules/ipfw_mod.ko, found that directory is a symbol link.

So just change the install line:

install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/extramodules-`uname -r`/ipfw_mod.ko

Now it success to install, hope it helps.

emctoo commented on 2015-01-19 16:04

try to install with yaourt, get error in last step:

...
error: failed to commit transaction (conflicting files)
dummynet: /usr/lib/modules/3.18.2-2-ARCH/extramodules exists in filesystem
Errors occurred, no packages were upgraded.

Maybe fail to install /usr/lib/modules/3.18.2-2-ARCH/extramodules/ipfw_mod.ko, found that directory is a symbol link.

and this fix it (simply modify the directory, any side-effect?):

- install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/`uname -r`/extramodules/ipfw_mod.ko
+ install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/extramodules-`uname -r`/ipfw_mod.ko

Now it success to install, hope it helps.

emctoo commented on 2015-01-19 16:03

try to install with yaourt, get error in last step:

...
error: failed to commit transaction (conflicting files)
dummynet: /usr/lib/modules/3.18.2-2-ARCH/extramodules exists in filesystem
Errors occurred, no packages were upgraded.

Maybe fail to install /usr/lib/modules/3.18.2-2-ARCH/extramodules/ipfw_mod.ko, found that directory is a symbol link.

and this fix it (simply modify the directory, any side-effect?):

- install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/`uname -r`/extramodules/ipfw_mod.ko
+ install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/extramodules-`uname -r`/ipfw_mod.ko

Now it success to install, hope it helps.

emctoo commented on 2015-01-19 16:02

try to install with yaourt, get error in last step:

...
error: failed to commit transaction (conflicting files)
dummynet: /usr/lib/modules/3.18.2-2-ARCH/extramodules exists in filesystem
Errors occurred, no packages were upgraded.

Maybe fail to install /usr/lib/modules/3.18.2-2-ARCH/extramodules/ipfw_mod.ko, found that directory is a symbol link.

and this fix it (simply modify the directory, any side-effect?):

- install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/`uname -r`/extramodules/ipfw_mod.ko
+ - install -Dm755 ipfw_mod.ko $pkgdir/usr/lib/modules/extramodules-`uname -r`/ipfw_mod.ko

Now it success to install.

All comments