Package Details: dungeons-of-dredmor 1.1.3-1

Git Clone URL: https://aur.archlinux.org/dungeons-of-dredmor.git (read-only)
Package Base: dungeons-of-dredmor
Description: Rogue-like game with hilarity as the centerpiece. Requires purchase from Humble Store (or Bundle).
Upstream URL: http://dungeonsofdredmor.com/
Licenses: unknown
Submitter: JazzplayerL9
Maintainer: snarfies
Last Packager: snarfies
Votes: 14
Popularity: 0.000000
First Submitted: 2011-11-29 21:12
Last Updated: 2015-07-15 22:12

Latest Comments

Rhinoceros commented on 2015-11-20 23:48

A minor note: when building you are asked for the `absolute path to dungeonsofdredmor-linux-1.1.3.tgz`. However, you actually need to type in the path to the *directory* containing this file, not the path of the file itself.

snarfies commented on 2015-07-15 22:16

Okay... I've updated for AUR4. I THINK I did it right, this is my first AUR submission experience. DLC packs will follow... eventually. Unless I am beaten to it.

axper commented on 2014-06-13 18:34

Changed URL, feel free to adopt

TomBoshoven commented on 2014-06-13 18:23

Wow, I didn't even know that site existed.
I'll orphan this for now, as I started using the Steam version.
I don't expect that there will be many (or any) new versions here, but feel free to adopt and change the URL.

axper commented on 2014-06-13 08:22

I think it would be better to link to http://dungeonsofdredmor.com/ rather than dev's site.

TomBoshoven commented on 2013-07-31 16:52

Why was this flagged out of date?
1.1.3 is still the current version on the Humble Introversion Bundle page for me.

TomBoshoven commented on 2013-02-07 19:18

Thanks for the response.
Update will come after a quick test.

You know, not only does the name of the package change at every release, but so dos the extension. I went from .zip to .tar.gz to .tgz .

The PKGEXT variable is not unused. It was added by JazzPlayerL9 (original submitter) and it changes the package extension to .pkg.tar instead of .pkg.tar.xz, in order to skip compression. Apparently, compression is not worth the effort here. Feel free to remove the line.

And I had noticed my release version mistake earlier, but wanted to spare people an update notice. It is correct now. Thanks for telling me though.

Ideka commented on 2013-02-07 16:42

Thanks for the package.

Last version is 1.1.3 now. Simply changing pkgver to 1.1.3 and _gamepkg to dungeonsofdredmor-linux-${pkgver}.tgz seems to work fine.

Also there is a seemingly unused PKGEXT variable, and lastly the first release should be 1 not 0: https://wiki.archlinux.org/index.php/Arch_Packaging_Standards#Package_naming

Ideka commented on 2013-02-07 16:31

Last version is 1.1.3 now. Also the first release should be 1 not 0.

TomBoshoven commented on 2013-01-12 20:58

Why was this package flagged out of date?
The last date shown on my HiB page is 2012-08-30.

Also, should I change this PKGBUILD to use the HiB DLAGENT (https://aur.archlinux.org/packages/hib-dlagent) ?
That would add support for automatic downloading of the game through the new login system.

All comments