Package Details: dupeguru-me 6.8.1-1

Git Clone URL: https://aur.archlinux.org/dupeguru-me.git (read-only)
Package Base: dupeguru-me
Description: Find duplicate songs on your system
Upstream URL: http://www.hardcoded.net/dupeguru_me/
Licenses: BSD
Submitter: hsoft
Maintainer: idwaker
Last Packager: hsoft
Votes: 29
Popularity: 0.463711
First Submitted: 2013-04-14 22:00
Last Updated: 2015-06-08 22:04

Latest Comments

hsoft commented on 2014-07-05 15:03

Oh, yes. I didn't get that error because I hadn't installed "python-pip" on my system (the error originates from a conflict between virtualenv's pip and system pip).

Fixed now.

Harey commented on 2014-07-02 07:19

Still not working with user permissions:
error: could not create '/usr/lib/python3.4/site-packages/jobprogress': Permission denied

As root it works, but this is not a good idea for makepkg...

hsoft commented on 2014-07-01 15:05

It turns out that the qt5-related problem was a missing dependency on libxkbcommon-x11. Oops, sorry. It's fixed now.

hsoft commented on 2014-06-02 19:08

I've filed a bug at http://bugs.python.org/issue21643 and I can work around the problem in the PKGBUILD, but in the end it's not of much use because PyQt5 ( https://www.archlinux.org/packages/extra/x86_64/python-pyqt5/ ) is out of date compared to Qt5 which has been recently update to v5.3.

There's not much else to do than to wait that PyQt5 is updated to v5.3.

hsoft commented on 2014-06-02 18:38

Interesting. I seems to be a regression introduced in Python 3.4.1 by http://bugs.python.org/issue21197 .

I file a bug and then find a workaround for the PKGBUILD.

omlet05 commented on 2014-06-02 16:50

hi,
I've got this:

Error: [Errno 17] File exists: '/tmp/yaourt-tmp-root/aur-dupeguru-me/src/env/lib' -> '/tmp/yaourt-tmp-root/aur-dupeguru-me/src/env/lib64'
Installing pip requirements
PyQt 5.1+ required. Install it and try again. Aborting

hsoft commented on 2014-01-17 19:23

Yeah, that is caused by the combination of two things:

1. polib's author didn't publish its releases on PyPI
2. pip 1.5 stopped allowing downloads external to PyPI by default

polib's author has just commented that he's going to upload polib to PyPI as soon as he can (I expect it to happen before the end of the week-end). See https://bitbucket.org/izi/polib/issue/42

So the problem should fix itself shortly. As for the dependencies on other AUR packages, I prefer to avoid it (and polib is a really small package) because it makes package building harder than it should.

kozaki commented on 2014-01-16 17:14

Harey's right :)
Simply added python-polib to the PKGBUILD. The next minute, dupeguru-me was built and already scanning these folders. By the time I wrote this it found 298 dupes, even when I supposedly cleaned them all already :}

Harey commented on 2014-01-16 15:54

Got it! It needs an additional makedepend: python-polib from AUR
https://aur.archlinux.org/packages/python-polib/
Then all is fine ;)

kozaki commented on 2014-01-16 12:10

Hi, same than Harey in this location.
~/.pip/pip.log:
<snip>
Skipping http://polib.googlecode.com/files/polib-0.5.0.tar.gz (from https://pypi.python.org/simple/polib/) because it is externally hosted.
Skipping http://polib.googlecode.com/files/polib-0.5.1.tar.gz (from https://pypi.python.org/simple/polib/) because it is externally hosted.
Skipping link http://polib.readthedocs.org (from https://pypi.python.org/simple/polib/); not a file
Skipping link http://polib.readthedocs.org/ (from https://pypi.python.org/simple/polib/); not a file
Skipping link http://polib.readthedocs.org/en/latest/projects.html (from https://pypi.python.org/simple/polib/); unknown archive format: .html
Skipping link http://polib.readthedocs.org/en/latest/quickstart.html (from https://pypi.python.org/simple/polib/); unknown archive format: .html
<snip>

All comments