Package Details: duply 1.11.3-1

Git Clone URL: https://aur.archlinux.org/duply.git (read-only)
Package Base: duply
Description: A shell front end for duplicity. It manages backup job settings in profiles and allows to batch execute commands.
Upstream URL: http://duply.net/
Keywords: duplicity wrapper
Licenses: GPLv2
Submitter: Schnouki
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 64
Popularity: 1.082371
First Submitted: 2009-12-21 11:46
Last Updated: 2016-06-26 13:44

Latest Comments

SanskritFritz commented on 2015-12-02 22:56

That would create another dependency, but I just might do it nevertheless. Thanks for the heads-up.

justin8 commented on 2015-11-23 00:11

Can you please include the man pages for duply? Running 'duply txt2man' outputs it to stdout.

troyengel commented on 2015-08-26 01:01

FYI if you use Amazon S3 or Google Cloud Storage: the update to duply 1.10+ changes how TARGET_USER and TARGET_PASS work - your backups WILL BREAK upgrading from 1.9.2. You need to do this:

1) Copy TARGET_USER and TARGET_PASS from your .duply/<profile>/conf to a notepad, then comment them out. If you don't comment them out, the new duply 1.10+ will shove them into your bucket name resulting in errors and a python exception.

2) If you don't already, create a wrapper script to run your duply commands so that you can export the variables. It's generally not good security practice to globally export these types of things, limit it to just when you actually run duply.

3) In the wrapper, export the Environment variables for your service before you run duply that are the same values as TARGET_USER and TARGET_PASS, for example:

S3:
export AWS_ACCESS_KEY_ID=(old TARGET_USER)
export AWS_SECRET_ACCESS_KEY=(old TARGET_PASS)

Google:
export GS_ACCESS_KEY_ID=(old TARGET_USER)
export GS_SECRET_ACCESS_KEY=(old TARGET_PASS)

At this point it should work as expected (like before). The Changelog and new example template embedded into the code is terrible at describing this breaking change and how to fix it. (you can also put them in ~/.boto if you only have one set of credentials, etc.)

hakunamenta commented on 2014-06-26 15:25

update to version 1.7.4 is possible

SanskritFritz commented on 2014-03-24 10:57

patch is part of base-devel
https://wiki.archlinux.org/index.php/Pkgbuild#depends

SanskritFritz commented on 2014-03-24 10:55

patch is part of base-devel

NSL commented on 2014-03-24 10:47

Please add 'patch' as build depency

SanskritFritz commented on 2013-03-17 12:29

chetwisniewski you're right, sadly a patch is needed. I'll write to the mailing list first asking for help.

chetwisniewski commented on 2013-03-17 01:25

Line 376 looks for python, should be python2

SanskritFritz commented on 2011-06-14 07:19

Thanks, adopted.

Schnouki commented on 2011-06-13 21:34

Updated and orphaned since I don't use this anymore. Feel free to adopt it if you want!

SanskritFritz commented on 2011-06-06 08:42

For those who use symmetric encription, it is advised to skip version 1.5.5, see here:
https://sourceforge.net/tracker/?func=detail&aid=3312208&group_id=217745&atid=1041147
or use the patched development version mentioned in the bugreport.

SanskritFritz commented on 2011-05-30 12:41

No need to write, just Flag Out-of-date :)

t-8ch commented on 2011-05-30 12:28

1.5.5 is out :-)

SanskritFritz commented on 2010-06-24 21:10

Thanks for the update!