Package Details: dvb-usb-rtl2832u-openpli 20130918-6

Git Clone URL: https://aur.archlinux.org/dvb-usb-rtl2832u-openpli.git (read-only)
Package Base: dvb-usb-rtl2832u-openpli
Description: Linux module for the RTL2832U DVB-T USB2.0 device
Upstream URL: http://openpli.org/forums/topic/20899-rtl2832u-chipset-support-proposal
Licenses: GPL
Provides: dvb-usb-rtl2832u
Submitter: R00KIE
Maintainer: R00KIE
Last Packager: R00KIE
Votes: 18
Popularity: 0.000001
First Submitted: 2012-04-02 18:06
Last Updated: 2017-07-23 11:59

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

Lenny commented on 2014-05-18 18:25

Upstream changed url for rtl2832 patch.
New git raw url: http://sourceforge.net/p/openpli/openpli-oe-core/ci/master/tree/meta-xtrend/recipes-bsp/linux/linux-etxx00/dvb-usb-rtl2832.patch?format=raw

R00KIE commented on 2014-02-23 16:02

You may not need to recompile the driver on every minor kernel release but you never know when and how it's going to break if you don't ;)

As for the remote, I'm not using it. When I bouth my receiver I took the time to make the remote control work but never published the patch, I think a different patch may be needed for every different remote so it's not really worth the trouble.

The guys at openpli don't bother with it either, I believe they use dedicated IR receivers and configure lirc to use that instead of the one on the dvb receiver.

trzalica commented on 2014-02-23 15:19

Thanks for reply to @R00KIE & @Gringo!
I don't need to recompile this driver and reinstall it after each small kernel update but sometimes it brakes but that isn't big deal. It important that now everything works! :) I don't use driver in kernel because it simply doesn't recongnize my device (I look through terminal and it doesn't show DVB-t device).
Just one more small question: you're using remote controler you get with your DVB-t card or?

Once again thanks for answers!

Gringo commented on 2014-02-23 15:14

@trzalica: lol, I see that Kaffeine is a media player, while Caffeine is a screensaver blocker. Confusing!!

R00KIE commented on 2014-02-23 14:50

Using this package means __recompiling__ and __reinstalling__ the package on every kernel update as even minor updates can break the driver.

R00KIE commented on 2014-02-23 13:57

Like Gringo says I only package the driver, if the problem was a missing vid:pid I suppose I could manage to add it (assuming that all the harware in the receiver was supported), however my programing skills and knowledge about the driver and usb/dvb subsystem would not allow me to do more.

Even upstream, which in this case is the openpli community, probably can't do more than they already have, which is "fix" the driver provided by realtek and make it compile cleanly with modern kernels.

@Gringo
What is included in the kernel is a different driver, written from scratch, and not this or any of the other drivers floating around, I beleive the reason for doing this was license concerns.

@all
That said (and I've posted this view before), from my experience, I'd say that for normal everyday use the driver included with the kernel works better if it supports your hardware.

This driver is most useful if and when you need to position an antenna, because it will report sane snr and signal strength values (and tools like femon will properly report when the receiver has a lock on the signal).

Gringo commented on 2014-02-23 13:56

@trzalica: I use 3.12.13, but the driver is included since 3.7.4. Remember that you might have to recompile the driver on a kernel update in case you do want this package, e.g. when you want to use the remote. That means re-installing the package!

If you use the in-kernel module you don't have to do anything, since the package is pre-compiled (unless you build the kernel from source of course), which is very convenient.

I don't see what Kaffeine has to do with this. It's a just a very bulky program that accomplishes the simple task of disabling the screensaver. I don't see the need for a screensaver, let alone a screensaver blocker.

Gringo commented on 2014-02-23 13:54

@trzalica: I use 3.12.13, but the driver is included since 3.7.4. Remember that you might have to recompile the driver on a kernel update. That means re-installing the package!

If you use the in-kernel module you don't have to do anything, since the package is pre-compiled (unless you build the kernel from source of course), which is very convenient.

I don't see what Kaffeine has to do with this. It's a just a very bulky program that accomplishes the simple task of disabling the screensaver. I don't see the need for a screensaver, let alone a screensaver blocker.

trzalica commented on 2014-02-23 13:20

@Gringo - please, can you tell me which kernel you're using? Maybe 3.13 or?

I used older version of this driver (from openpli community and it worked well). Today I tried to reinstall once again driver and Kaffeine and now everything works again - it's a little bit weird...

Gringo commented on 2014-02-23 11:10

@trzalica: what doesn't work? Do you have logs you can share? Remember this is not a support website of the driver. R00KIE just packages the driver for Arch Linux, which you can also do yourself.

If this is the first time you tried this package/driver on Linux, we might not even be able to help you. You should ask 'upstream' (openpli project) instead. Also, I don't need even need this driver myself for basic support (scanning and viewing channels) anymore, since this driver is included in the kernel.