Package Details: dvb-usb-rtl2832u-openpli 20130918-6

Git Clone URL: https://aur.archlinux.org/dvb-usb-rtl2832u-openpli.git (read-only)
Package Base: dvb-usb-rtl2832u-openpli
Description: Linux module for the RTL2832U DVB-T USB2.0 device
Upstream URL: http://openpli.org/forums/topic/20899-rtl2832u-chipset-support-proposal
Licenses: GPL
Provides: dvb-usb-rtl2832u
Submitter: R00KIE
Maintainer: R00KIE
Last Packager: R00KIE
Votes: 18
Popularity: 0.000000
First Submitted: 2012-04-02 18:06
Last Updated: 2017-07-23 11:59

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 Next › Last »

kamiljk87 commented on 2012-08-23 19:47

In kernel 3.4.9-1-ARCH to compile successfull must change in Makefile line 22 from /lib/modules/$(KVER)/build to /usr/lib/modules/$(KVER)/build . And compilation was successfull.

R00KIE commented on 2012-07-14 17:37

Updated the PKGBUILD to install the module into /usr/lib.

R00KIE commented on 2012-04-06 13:42

Small status update regarding remote control support:

Upstream(1) does not plant to work on making the USB tuners work as generic IR receivers since they already use/support generic receivers that work with all remotes. As it is the driver needs to be patched to support the _one_ remote that is intended to be used with the USB tuner (eg. the bundled remote).

The bundled remote should work fine if the correct mappings are patched into the driver, however other remotes may not work, this depends on the IR protocol used by the remote(2). The current package does not patch the upstream driver as it doesn't make sense, since support is specific to each type of remote. I can provide some instructions on how to get each button code and an example patch if anyone is interested.

The (better) alternative to patching the driver is to use an IR receiver that works well with LIRC and supports all remotes.

(1) The OpenPLi devs working on keeping this driving building and working with current kernels.
(2) Based on the test I have performed with the USB tuner and remotes I own.

Anonymous comment on 2012-04-03 10:27

thanks !

R00KIE commented on 2012-04-02 18:12

Updated package here [1]. It builds cleanly and works with kernel 3.3 and includes a signal strength reporting fix and 3 more supported adapters.

I will leave this package here for future reference in case the git repo starts to be updated again or some other repo appears with a better driver.

[1] https://aur.archlinux.org/packages.php?ID=58148

R00KIE commented on 2012-04-02 18:09

This is an updated version of [1] which compiles cleanly with kernel 3.3 and should also work with 4.4.
This also includes 3 more supported adapters and a signal strength reporting fix.

Module name is dvb_usb_rtl2832u as requested in [1].

[1] https://aur.archlinux.org/packages.php?ID=51225

R00KIE commented on 2012-04-02 13:45

I can reproduce the problem but solving it is beyond my capabilities. I have posted in [1] asking if there are any plans to update the driver to compile with kernel 3.3 or if there is already any code available that works.

Meanwhile there isn't much I can do and I will be in the same situation as you when linux-3.3 is moved to core.

[1] http://openpli.org/forums/topic/20899-rtl2832u-chipset-support-proposal/page__view__findpost__p__267984

Anonymous comment on 2012-03-29 09:18

Error while compiling for me:

http://pastebin.com/4VkwFuNr

R00KIE commented on 2012-03-18 21:47

You are right, linux-headers needs to be added to makedepends.

As I have linux-headers installed, building has never exploded for me. Updated pkgbuild has been submitted.

Anonymous comment on 2012-03-18 21:27

or makedepends, preferably