Package Details: dvbcut 0.6.1-2

Git Clone URL: https://aur.archlinux.org/dvbcut.git (read-only)
Package Base: dvbcut
Description: Qt3 application for cutting parts out of DVB streams
Upstream URL: http://dvbcut.sourceforge.net/
Licenses: GPL
Submitter: AndyRTR
Maintainer: webmeister
Last Packager: webmeister
Votes: 13
Popularity: 0.000000
First Submitted: 2005-11-23 19:13
Last Updated: 2015-07-05 17:24

Latest Comments

« First ‹ Previous 1 2

Anonymous comment on 2010-06-08 13:03

New PKGBUILD. I changed the source to 'Subversion Revision 170'. Reason:
- Fixes for gcc 4.4 and 4.5 are included
- dvbcut.desktop and icon are included

---
Old PKGBUILD: http://pastebin.org/318408

Anonymous comment on 2010-05-23 11:46

Updated. Thanks everyone for informing me. Special thanks to pquiney, who fixed the problem.

Anonymous comment on 2010-05-22 23:17

Fixed it!

Add the lines below to the PKGBUILD file (below the existing sed lines)

# Fix for compilation error under gcc 4.5 (pquiney)
sed -i 's/index::index/class index/' ${srcdir}/${pkgname}-${pkgver}/src/mpgfile.h
sed -i 's/index::index/class index/' ${srcdir}/${pkgname}-${pkgver}/src/main.cpp

I have emailed the updated PKGBUILD file to the maintainer.

Anonymous comment on 2010-05-22 22:18

Build Fails on x86_64 as well.

Same error several time over, starting with....

In file included from differenceimageprovider.cpp:25:0:
mpgfile.h: At global scope:
mpgfile.h:52:3: error: 'index::index' names the constructor, not the type
mpgfile.h: In member function 'const index::picture& mpgfile::operator[](unsigned int) const':
mpgfile.h:96:12: error: 'idx' was not declared in this scope

harveythedog commented on 2010-05-13 06:36

Build Failed (i686)